PDA

View Full Version : G-55V Networking Issues



aawilson
10-30-2013, 01:51 PM
My home network is running on an ASUS RT-N66U with Tomato Firmware (1.28.0000 MIPSR2-112 K26 USB AIO-64K). I have a single wireless SSID defined with WPA2 Personal + AES. I've had an ongoing problem where my wireless card will periodically become unusable, that has expressed itself in a couple of different ways (the machine typically runs Windows 7 64-bit).

When I first started using this network, I was running on an Atheros AR9485WB adapter. When I was running this adapter, the network would disconnect entirely. After reading around online, there seemed to be a consensus that this card had troubles connecting to WPA2 networks. I tried several versions of drivers, and didn't get any noticeable improvement. Switching to a WPA- or WEP-secured network stopped the connection issue, but was not a long-term solution due to security issues with those schemes, so I have switched it back and am attempting to solve the root issue.

I eventually switched to an Intel Centrino Advanced-N 6235 on recommendation from the same sites, and am using the latest drivers-only 64-bit install from this link: Intel Download Center Drivers. The version reported there (I assume the Intel ProSet driver package version) is 16.1.5, and the version reported in my device manager (I assume the actual driver version) is 15.9.0.5.

This has improved the situation somewhat in that the network does not completely disconnect. However, it will still achieve unusable latency (pings of 1000-3000 ms to the router, if it resolves at all, which is not guaranteed with this state). Disabling and re-enabling the device will typically resolve the issue temporarily. Other machines on the network do not get into this state at all--it is only this machine.

I've tried all sorts of resolutions and trawled the Internet for answers, and can't come up with anything. Maybe this forum will be more helpful?

Dr. Zchivago
10-30-2013, 02:17 PM
How close to the computer is the router? I've had a similar issue with my machine. I think it may be either an issue with the high-gain nature of modern access points - the signal is choppy at very close ranges (maybe try reducing radio gain?).

Or, I was thinking it could be interference from an unshielded power supply (like the one inside the laptop) - I had a problem a few years back when I had an AP sitting on top of a desktop tower, and no one could get a decent signal from that AP until I moved it to a room with no appliances.

Can anyone else shed some light? Because, from my end, that's all speculation, and I have the same issue on my G55vw.

aawilson
10-30-2013, 02:27 PM
Those are both interesting ideas. The distance is about 30'-40'. The signal strength seems fine and inSSIDer 3 doesn't report significant conflicts (and anyway, the other machines that are doing fine are roughly the same distance away). Unshielded power supply issues might be an interesting path, but it seems like it'd be a bear to diagnose. If I had any idea what to look for in a pcap dump, then I might be able to get somewhere, but it is much too much information for me to parse without some expert guidance.