PDA

View Full Version : Display contrast changing depending on the colors displayed



ggBanks
11-03-2013, 01:24 PM
Hey everyone, I have my G55 for over a year now, but since recently I've encountered a "thing" with the display. Whenever I have something with a dark background displayed on the screen I can see that the screen slowly fades out its colors, and when I put something that has a white background for example Google Chrome, the display colors become crisp and saturated. The brightness is slightly affected too in the same way. What could cause this?

Pitcher@asus
11-04-2013, 06:51 AM
please install vga driver from asus support site to try again, if not help, i think you will sent to service center to check it.

Perzonallica
11-04-2013, 07:57 AM
I have the same issue since summer, and I think it's a Nvidia driver problem. I uninstalled the newest version of the driver, and everything worked OK, until I installed the version located on the Asus Support page for the Windows 8.1 x64. The display contrast is changing again...
Then I tried it on Ubuntu too, and there is no such problem.
It's a bit frustrating when I have to do some design work, or when I'm playing games. :(

UPDATE: And for me this "thing" mainly comes out when my notebook is not plugged in. Sometimes it is happening when it is plugged in too, so I have to restart the NB. Sometimes the restart solves the problem, sometimes it doesn't.

ggBanks
11-04-2013, 08:13 AM
I can see! The problem is that it is changing gradually over 1 or 2 seconds so it must be software related and controlled, but I highly doubt it is because of the nvidia drivers. The thing that makes me think like this is that most of the time I use the laptop connected to an external monitor and the external monitor is not affected by the same issue. If the signal is transferred through HDMI it is OK, but the issue only appears on the laptops integrated monitor.

Perzonallica
11-04-2013, 09:03 AM
Hmmm... If it's not the nvidia driver, than maybe the Win8? Because with Win7 I didn't experienced this issue... And YES, I can confirm that the issue only appears on the laptops integrated monitor.

ggBanks
11-04-2013, 09:57 AM
Yes I am using Win8.1 but why the F would Microsoft do this, if its the case ?!
Powersaving or something?

neohiryuu
11-09-2013, 04:59 AM
This has been bugging me too ever since it mysteriously started happening a few months ago. and I think I finally figured it out. Figured I'd sign up here just to share it with you guys.

Apparently there is a power saving feature in windows. It will dim your screen backlight, and compensate by cranking up the 'software' brightness, saving your battery some life. The reason you notice it more on battery is because there are two settings for each power profile, one for battery, and one for plugged in. Just go to your "Power Options" control panel then "Change advanced power settings." In the "Display" section, there are two setting, "Enable adaptive backlight" and "Adaptive backlight." Mess with those, and you'll be able to lessen, or disable the effect completely.

Hope that helps you guys out a bit

ggBanks
11-09-2013, 01:53 PM
Thank you mate, I fixed it! I can recall fiddling with the settings there, but for some reason I have altered the power saving settings while at high performance mode and that's why I didn't see the changes :D How lame of me!

StreetGT
11-17-2013, 11:45 PM
please install vga driver from asus support site to try again, if not help, i think you will sent to service center to check it.

LOL, update drivers, last one released = 2013/02/20, do you think people will use that drivers?

Lazy people...

tibidk
11-29-2013, 10:52 AM
I've tried all and still haven't managed to fix the problem.
So, i completely uninstalled the driver and left windows to take care of it. The difference is that i no longer have the nvidia control pannel, but windows still recognises my card.
I just let games take over the display settings and it works like a charm.
Also solved my horisontal screen flickering issue even though i only run at 60 HZ ... give it a try. Worst case, you have to reinstall the driver. Hope this helps