PDA

View Full Version : ATK Issue? [solved]



Talentless
11-04-2013, 06:59 PM
Why is it that my fn keys do not work unless and until go into the ATK Package folder and double-click on Hcontrol? I found this on a web search after trying to find out why my fn keys weren't working at all, and this work-around does make them functional... but I shouldnt have to do that every time I restart my PC. What am I missing?

cl-Albert
11-04-2013, 07:53 PM
Hcontrol should be started and running in the background automatically once Windows starts up, so possibly it's been removed from the Windows boot-up items or is unable to run for some reason (firewall, antivirus, etc.?)?

If it's been working before and stopped working recently, you may want to look into any recent changes, or maybe try Windows system restore if you can lose your changes since the restore date (back-up if necessary).

Otherwise, you can try to reinstall the ATK driver or check the ASUS download site for a newer version too.

Talentless
11-04-2013, 10:00 PM
thank you for the quick response, is there a way to simply re-add it to system start-up then, or will a reinstall of the ATK package automatically set it to start automatically

cl-Albert
11-04-2013, 11:00 PM
Actually, curious if you're running Windows Vista or something older if it matters, but if you don't mind reinstalling the ATK package that should normally be good enough although it may depend on what is causing the problem as well.

I was checking my Win7 MSconfig startup items though and didn't see Hcontrol listed (other ATK items were listed though and my Fn keys working fine), so that's why I was curious about your Windows version, but we might see how your ATK reinstall goes before worrying about anything else.

Talentless
11-05-2013, 02:11 AM
I've been on Windows 8 for a while, just updated to 8.1, but problem was around before the 8.1 update i ran this morning. I'll just try a clean removal and install of the ATK package... I've been too lazy to really address the situation until now.

Update: Was a simple solution as you suspected. Reinstall fixed everything. Maybe I messed with my start-up stuff at some point. Either way... all set.

cl-Albert
11-05-2013, 07:38 PM
Thanks for the feedback and glad to hear it helped... for now.
A little curious about what caused the problem and if you may run into it again later, but I guess time will tell.

If you didn't already know, you can check the ASUS download site for the latest ATKACPI driver and hotkey-related utilities version (which shows up as the ATK Package in Programs and Features) for your notebook model under the 'utilities' section if necessary, but it's probably not worth worrying about right now if everything is okay.