View Full Version : G73 can't boot from external HDDs?

09-02-2011, 07:10 PM
I have one of the watered down G73s from best buy that has only one Hard drive. I decided I wanted to mess around with linux so i got a seagate external drive. I formatted it and installed backtrack 5. however when i change the boot order or select the external drive to boot from all i get is a black screen with >_

On my other laptop It works fine but i'd rather run it off of the G73. did I do something wrong or is there a fix I forgot to apply?

09-02-2011, 11:45 PM
Easiest way is to hit Esc and select the boot device

09-03-2011, 05:32 AM
thats the way i normally select the drive with the same result explained in the first post

09-21-2011, 08:11 AM
Im having the same issue, is there a fix for this? I have been using an old HP laptop that worked fine.. Tried booting it up on the asus g73 after selecting the usb drive to boot first but just get a flashing cursor, doesnt even make it to the boot menu...
Any chance of a bios fix for this??? quite bad not being able to boot from an external usb drive..

update: upgraded to latest bios for g73 and still no joy.

update: speaking of which the booting section in this bios is really limited. Shouldn't you be able to specify boot any external drive as an option as well as boot any usb card etc etc like most bioses have these days? or these years? :)