PDA

View Full Version : Linux Ubuntu and/or Slackware install help on G750JH



Randomname
11-07-2013, 05:38 PM
Hi there,

Just like the title says, I want to install Ubuntu and/or Slackware on my G750JH and I want it to be on Dual/Triple(?) boot with my Windows 8
I've already setup the partitions for both of them (2x50Gb), a friend of mine tried to install Ubuntu on his laptop (Compaq) and he was successful until the part when he turns his computer on there is no dual boot option, the laptop only boots Win 8, so I don't want to run into some trouble like he did, so I thought about asking the experts :D

It would be great if I could install Ubuntu and Slackware, since I'm a noob when it comes to computers, could you explain it so that I can understand :D
Thanks :D

villiansv
11-07-2013, 05:48 PM
In the BIOS set Fast Boot = Off, and Secure Boot = Off (Launch CSM can be off too, modern Linux distros have no problems booting in UEFI mode). Install the Linuxes in their respective partitions, and when rebooting you can hold ESC to get a bios popup menu, which would ideally have auto-recognised your new UEFI linux installation and allows you to boot into it. It is likely that selecting the Linux option there will send you to the Grub boot menu, which can in turn load Windows. In any case, once you see what options you have with the ESC menu at bootup, you can head back into the bios and change the boot order as you wish (e.g. set the Linux bootloader to be first, due to it being able to also load Windows). Or you could just keep using ESC when restarting - up to you.

These are just general instructions, anything more specific would require more info from you (e.g. I tried X, but Y happened, and I get Z error, what should I do).

Randomname
11-08-2013, 07:31 PM
In the BIOS set Fast Boot = Off, and Secure Boot = Off (Launch CSM can be off too, modern Linux distros have no problems booting in UEFI mode). Install the Linuxes in their respective partitions, and when rebooting you can hold ESC to get a bios popup menu, which would ideally have auto-recognised your new UEFI linux installation and allows you to boot into it. It is likely that selecting the Linux option there will send you to the Grub boot menu, which can in turn load Windows. In any case, once you see what options you have with the ESC menu at bootup, you can head back into the bios and change the boot order as you wish (e.g. set the Linux bootloader to be first, due to it being able to also load Windows). Or you could just keep using ESC when restarting - up to you.

These are just general instructions, anything more specific would require more info from you (e.g. I tried X, but Y happened, and I get Z error, what should I do).

Thank you for replying to my question.

Well, I've disabled the Fast Boot option (which was quite easy), what I couldn't find was the Secure Boot option. I entered the Windows Charms menu (Winkey+C) and then went to Settings pressed Shift key and then pressed the Power button + the Restart option, which led me to the all blue whatever menu (too lazy to look it up), went to Troubleshoot, Advanced option, there were no UEFI options (settings). Since I couldn't find the UEFI settings there, I powered off my laptop, and when it started to pressing the 'Esc' button (may I add, like a madman), when the blue-white screen appeared (I think it's referred to as the BIOS screen). I combed out all the tabs and options but nowhere to be found were the UEFI setting, so I went on to installing Ubunut, as I hoped it would go smooth. (well, to be frank, I really, really hopped that it would go smooth)

Alright, I have installed Ubuntu first, I've formatted one of the partitions to Ext4, then installed it normally afterwards. I loaded it from a USB stick, went to Try without installing (something like that), when it prompted for restart, I naturally restarted it, and plugged out the USB stick, what happens next is quite interesting, it didn't give me a dual boot option, it went straight to Windows 8 and of course, my partition where it was installed disappeared, which even I knew was normal, since Windows doesn't recognize Ext4 format, so I thought it was to normal. I went to the BIOS screen (I hope that it's called that way) and Ubuntu (or even Linux) was nowhere to be found as a option, I couldn't even find a option to boot in Windows 8 (if it's relevant at all).
Oh, I forgot to add when it asks if I want to erase all information on the HDD, I went to Something else, and from there on I installed it.

If you need any more info for anything, please let me know, I hope that I'm able to resolve the issue with your help.
Thank you very much :)

P.S. I writing in a formal manner because I'm bored xD

villiansv
11-08-2013, 09:47 PM
BIOS --> Security tab --> Secure Boot Menu --> set it to disabled from there. I was under the impression that Ubuntu/OpenSuse etc (major Linux distros) have support for SecureBoot, but maybe not yet, or it's iffy. Try this, then when booting hit ESC and see if a bootable option other than your Windows/USB/DVD drive shows up in the popup blue screen.

If that doesn't work, I'd suggest trying it a slightly different way - in addition to the old BIOS options, set the Launch CSM to ON in the BIOS, then reinstall Linux (make sure you format your ext4 partition from before during install, I'm sure you can figure that out). Something that >>may<< work is to also set up a separate boot partition in Linux - make it about 500mb-1gb max, and set its mount point to /boot (format as ext4). This is something I've done for ages when installing various distros, as I sometimes used file systems like XFS/JFS that GRUB couldn't boot from. In any case, it may make the recognition of GRUB as an extra boot option easier, but it may also have no effect whatsoever. Try it and GL.

Randomname
11-08-2013, 11:03 PM
Ok, thanks :)

Will try it out and give feedback :)

Randomname
11-09-2013, 07:31 PM
BIOS --> Security tab --> Secure Boot Menu --> set it to disabled from there. I was under the impression that Ubuntu/OpenSuse etc (major Linux distros) have support for SecureBoot, but maybe not yet, or it's iffy. Try this, then when booting hit ESC and see if a bootable option other than your Windows/USB/DVD drive shows up in the popup blue screen.

If that doesn't work, I'd suggest trying it a slightly different way - in addition to the old BIOS options, set the Launch CSM to ON in the BIOS, then reinstall Linux (make sure you format your ext4 partition from before during install, I'm sure you can figure that out). Something that >>may<< work is to also set up a separate boot partition in Linux - make it about 500mb-1gb max, and set its mount point to /boot (format as ext4). This is something I've done for ages when installing various distros, as I sometimes used file systems like XFS/JFS that GRUB couldn't boot from. In any case, it may make the recognition of GRUB as an extra boot option easier, but it may also have no effect whatsoever. Try it and GL.

Hi, I've tried the first one and I can't find any of the options, including the 'set the Launch CSM to ON'.
I don't know if it's relevant or not, but I've accidentally deleted FreeDos on my machine :S
It was some time ago, when I got the laptop :S

villiansv
11-09-2013, 07:45 PM
BIOS should be the same for all G750s. Can you post pics of your BIOS tabs?

Zygomorphic
11-09-2013, 09:55 PM
separate /boot partition should not be necessary unless the guy plans on using XFS or ZFS partitions (which I don't recommend for the average user, due to their complexity, and lack of broad support). EXT4 is a very good filesystem since it supports journaling. It's also support by GRUB. The issue with /boot partitions is that they take up space (or are small, in which case kernel updates fill them up) that could be used for user programs if the boot and root partitions are in the same partition. However, I do recommend a separate /home partition, so that you can change distros without losing your personal files.

Randomname
11-11-2013, 04:05 AM
separate /boot partition should not be necessary unless the guy plans on using XFS or ZFS partitions (which I don't recommend for the average user, due to their complexity, and lack of broad support). EXT4 is a very good filesystem since it supports journaling. It's also support by GRUB. The issue with /boot partitions is that they take up space (or are small, in which case kernel updates fill them up) that could be used for user programs if the boot and root partitions are in the same partition. However, I do recommend a separate /home partition, so that you can change distros without losing your personal files.


What would you recommend me to do, since I can't disable the Secure Boot option?
Or is there a way to disable it through cmd?
Thank you for your answer :)

Zygomorphic
11-11-2013, 11:14 AM
What would you recommend me to do, since I can't disable the Secure Boot option?
Or is there a way to disable it through cmd?
Thank you for your answer :)
The most recent versions of Ubuntu should have signing keys, which means that you shouldn't need to turn Secure Boot off. Why can't it be turned off, it should be one of the "Security" settings in the BIOS. If you can, please get into the BIOS menu again and post pictures of all the pages. That will really help.

Perlange
02-18-2014, 02:06 PM
Hi! I have finally succeded to tripleboot my G750 JH with Linux Mint (which is based entirely on Ubuntu) and Linux Manjaro.
Weeks of painful trial are over!
I did like this:
1. Created partitions one for Mint one for Manjaro on the SSD disk after shrink of Windows partition and deletion of the 20 GB Windows recovery
partition at the end of the SSD which was instead copied to an recovery USB with ASUS BAcktrack.
2. Started computer with F2 kept pressed until BIOSmeny appeared and put secure boot to disable and disabled fastboot in Windows
3. Installed Manjaro on one of the partitions from a DVD. To start from the DVD I kept Esc pressed until boot menu appeared and
chose UEFIDVD as boot option. I did NOT install any bootloader for Manjaro at all
4. Then I started from a liveDVD with Mint. Started from the option UEFIDVD NOT the normal DVD option.
5. Installed Mint in its partition and the bootloader, GRUB, in the EFI partition of the Windows installation. On my computer it was DEV/sdb1
6. Restart. Now GRUB appears first and has Mint, Windows and Manjaro listed as boot choices. All work!

Good luck!

Zygomorphic
02-19-2014, 02:25 AM
+rep, @Perlange. Thanks for sharing all the details. I might have to try Manjaro at some point - not familiar with it.

Perlange
02-20-2014, 01:48 PM
Since the GRUB that Mint installed found the Manjaro the same method should work for any other distro or distros
installed in the same way.

stress4ever
02-25-2014, 08:40 AM
I"ve been tring to install fedora, with all the bios options disable i'm unable to create a partition suitable for linux. message during installation if I try automatic partitioning failed "failed to find suitable stage1 device".

Geraldo29
02-26-2014, 02:17 AM
Thank for information.

http://www.bediro.com/images/3/b1.png