PDA

View Full Version : G570 Left Click issues when typing [solved]



veteranmina
11-08-2013, 12:48 AM
Okay, so I am a very big Minecrafter and this machine is a beast at running it.

My only issue is that I cannot get the left click to fully register my clicks all the time, meaning it is intermittent on responding.

Weird thing is that the left click registers clicks at anywhere else BUT minecraft. I have looked all over in minecraft for a answer,
but I have not so I have decided to come here and see if anyone else has come across this.

What I have done:

External mouse works fully
Fully updated drivers/firmware
Fully updated windows updates
Changed multiple settings for mouse/touchpad

veteranmina
11-08-2013, 01:00 AM
Okay, actually just found out. If i am typing anything on the keyboard the left click stops functioning. Right click works great

veteranmina
11-08-2013, 01:20 AM
Derp, found the issue.

In windows 8 (possibly only 8.1) there is a setting in the Windows 8 Control panel (not the original control panel) in mouse/keyboard setting that controls the delay to mouse clicks after key registered click. I turned it off and it know works fully.

Zerochaotix
01-08-2014, 11:36 AM
Just wanted to confirm that this is true for Windows 8.1 as well. It was driving me crazy until I stumbled across this post.

If you're trying to find the exact spot to change this setting use the following path:
Open up the charm bar --> Settings --> Change PC Settings (on the bottom) --> PC and Devices --> Mouse and Touchpad; The change the "Touchpad" setting to "No delay (always on)"

Props to veteranmina! Windows 8 is not my favorite OS lol.

Darnassus
01-08-2014, 12:00 PM
Thanks for the note, that's useful to know. I assume it was automatically turned on by default?

Kazzers
01-19-2014, 08:43 PM
G750JW-DB71 here. Experienced the same trackpad / touchpad click delay after upgrading from Windows 8 to Windows 8.1. Originally thought the issue was a setting in the Elantech/ASUS driver. Even went as far as searching for and editing registry entries under Elantech. But it's not - confirming that it is in fact an automatic Windows setting.

I guess Microsoft developers are not avid gamers.

(Here's hoping this thread gets enough Googlebot crawls to get pushed up on Google Search for other people trying to troubleshoot this issue.)

hmscott
01-19-2014, 10:02 PM
Just wanted to confirm that this is true for Windows 8.1 as well. It was driving me crazy until I stumbled across this post.
If you're trying to find the exact spot to change this setting use the following path:
Open up the charm bar --> Settings --> Change PC Settings (on the bottom) --> PC and Devices --> Mouse and Touchpad; The change the "Touchpad" setting to "No delay (always on)"
Props to veteranmina! Windows 8 is not my favorite OS lol.

Thanks for the detailed click path Zerochaotix :)

LAMINI
03-17-2014, 10:41 PM
New ASUS G750 user posting that this resolved his issues ^_^

gammite
07-01-2014, 09:00 PM
thanks for this thread. i was about to have my laptop shipped to repair this issue. awesome find guys. thanks.

what made my situation worse was i couldn't attribute it to anything because i use an external mouse 99% of the time. had i updated and the mouse didn't work i would have known it was the update.

gammite
07-07-2014, 11:37 PM
Well i thought that this had resolved my issues.

It worked for a day. After a reboot the same issue persists and switching the settings doesn't help anymore.


I am sure that this is a software issue. Does anyone have any more guidance?

PenguinFam48
01-22-2015, 03:34 AM
Thanks for the note, that's useful to know. I assume it was automatically turned on by default?

Seriously I was this close to giving up and returning this back to the store because I swore it was defective. I spent a good 2 hours going through random forums and troubleshootings and came across this! I can't believe it was something as simple as this...

I was trying out GW2 and couldn't understand why the left click wasn't registering more than half of the time, VERY frustrating. Glad it was a simple fix :)

(Windows 8.1 here!)