PDA

View Full Version : G750JX Static Noise from speaker on AC [solved]



wesnaly
11-10-2013, 05:26 PM
Hi, I recently purchased a G750jx and have been facing the current problem. When I played any youtube videos or watch, listen to any music , movies, gaming, there will be this static noise that will appear with the sound. I have tried the differnt power plans, went back to the dealer to change my adapter, tried different realtek version drivers, upgraded my graphics card to to avail. I even tried reformatting, but it doesnt change a thing. I have read through the whole list of problems similar to mine, the only difference is that the static noise only appears when i plug in my ac. When i run only on battery nothing happens..

:mad:I even went back to the dealer, but to my surprise, there was no static sound...and the salesman said he cant do a 1-1 exchange if he cant find a problem with it. I dont really wan to rma my laptop within my first week...any input will be greatly appreciated. I have tried two different locations, one is my own house, another is my friends, but times there were static noise coming from the speaker whenever music, video, game is being played.

Any input would be greatly appreciated.

Update : Just got my laptop back from RMA, looks like it was a motherboard problem. Got battlefield 4 up and running at ULTRA, looking fricking awesome!

Randomname
11-11-2013, 04:18 AM
I'm experiencing similar problems with mine, are there any other speakers or magnets near it?

Since I live in Serbia, there is a big old box near my laptop (the box is a old TV), I'm not experiencing this at some restaurant or similar, only when I'm in my apartment the problem happens :S

hmscott
11-11-2013, 04:36 AM
Both of you should invest in a power line isolator, line filter, and put a surge protector in front of both.

You are getting line noise induced through the power line, that is why you are hearing it only in one location.

I have had a blown power supply in one similar circumstance, so it is a serious situation in some cases. After the power supply was replaced it was run on the other side of a large transformer acting as an isolator, until we could get the power company in to check the line.

Eventually the power company came out and ran a line analyzer on the power line, and ended up finding a bad transformer down the line that was causing the problem. After the bad line transformer was replaced the line was clean - no more noise and I could plug in without the isolator.

If you have a noisy appliance causing the problem - and you can't recycle the appliance, get an isolator on it, and if possible move it and/or your computer to a different circuit off of the circuit the appliance is using.

wesnaly
11-11-2013, 04:54 AM
Thanks for the reply.
But I have 2 another asus laptop on my table(its long), and none of them have faced this problem for the past 4 years.

hmscott
11-11-2013, 06:14 AM
Thanks for the reply.
But I have 2 another asus laptop on my table(its long), and none of them have faced this problem for the past 4 years.

Did you run either of the other 2 laptops on that same ac socket recently? The faults happen randomly, so this may be a new / intermittent problem. If appliance induced it might on be when a heater, fan, or fridge is running

Try one of those laptops or another audio device on the same ac socket as the G750.

If the problem isn't reproducible at another location as you said, then your ac has a problem.

Some power supplies are more sensitive than others, and some peripherals plugged in can help drain the noise through their path to ground.

Does the G750 sound Ok plugged in elsewhere in the house?

You can also try a "cheater" plug that breaks the ground connection. Not recommended long term, only for debugging. If it stops the noise then your wiring has a grounding problem.

wesnaly
11-11-2013, 11:04 AM
I even tried interchanging the different Ac adapter to see if there's any different, but still the same. Dont think it has to do with my other electrical appliances.
Tried different locations in the house, still had the same problem.

Anyway sent it for RMA today, there was also static but not so loud as when it was at home. Gonna wait to take it back and see what the technician say about it.

Thanks

LeonardoTan
11-11-2013, 06:51 PM
Jeez so many problem with this series, is the built quality good? Screen and speaker and what else now? This makes me slightly afraid to buy one.

wesnaly
11-27-2013, 10:34 AM
*Can Be Closed*

Symho
11-27-2013, 05:24 PM
Jeez so many problem with this series, is the built quality good? Screen and speaker and what else now? This makes me slightly afraid to buy one.

I had sent back 3 times. And last mouth they refund it! Now I'm waiting for a review of G750JX-CV200H!