View Full Version : Missing Bios Downloads for Asus Rampage 4

Dexterity Cubed
11-17-2013, 11:20 PM
I recently bought an Asus Rampage 4 Extreme and I need a bios update for it to work with an i7-4690x and the section on the support page which is suppose to show the bios versions does not display it. I have tried two separate computers to try to see if it was just a problem unique to one computer and it wasn't. Could someone send me to a site where I can find the most up to date bios. Or could someone tell me if this is just asus updating the webpage.


p.s. sorry if this is the wrong section of the forum I couldn't find the right one.

11-17-2013, 11:30 PM
They show for me.


11-21-2013, 02:12 PM
I ran into the same issue with the Formula VI. They had 0904 and 1002 there.. now they have taken away both of those and back down to 0804. I have used 1002 with no issues so far, but do not know why they have removed them and if i should flash back down? I was hoping Raja would chime in here.

11-21-2013, 02:16 PM
I ran into the same issue with the Formula VI.
You do not have the same issue as Dexterity posted. His issue was nothing was displayed on the BIOS update page.