View Full Version : ASUS G55 bluetooth issues

11-22-2013, 01:41 PM
I just bought a new G55 and installed Windows 7 x64. I've downloaded and installed the drivers available on the ASUS support page. Everything works fine except Bluetooth.

First, I installed the Atheros BlueTooth driver but it didn't seem to work. I then installed the Intel driver, again with no result. The bluetooth device doesn't even appear in the Device Manager list (not even highlighted with an exclamation mark).

I uninstalled the Atheros driver and then tried unstalling the one from Intel, but was unable to. I get the following message: "The software removal you are attempting cannot proceed. To remove this software, please first be sure that Intel wireless adapter is correctly installed and enabled" and the uninstallation is canceled.

To summarize:
1. Can't uninstall the Intel driver.
2. Bluetooth is not recognized in any way and does not work.

Any advice/suggestions?

11-22-2013, 03:24 PM
@m3talman, first of all please determine the wifi card that you have in your laptop.

there are 3 different cards that can be found in a g55, one is atheros, another one is intel, and the last one is broadcom. these cards are all hybrid cards, you need to install the right wifi and bt drivers.

11-22-2013, 08:32 PM
My WiFi card is the Atheros AR9485 Wireless Network Adapter.

11-25-2013, 06:31 PM
Not sure if this can help, but if you're still working on this, check your device manager to see if the bluetooth radio appears, or else use the Fn+F2 keys to toggle the wireless and bluetooth off and on to make it show up (the bluetooth disappears from device manager when disabled). If the bluetooth driver hasn't been installed yet, you may just see a yellow question mark, so try installing the bluetooth driver when you have the yellow question mark.
Make sure the bluetooth is enabled by clicking on the bluetooth icon if it has the red circle with slash through it before it disappears when you are enabling the wireless devices as in the screenshot below which is from my Win7 G75VW unit.

If you're not using the ASUS factory Win7 image and not seeing this onscreen display, make sure you've installed the "ATKACPI driver and hotkey-related utilities" and "ASUS Wireless Switch (Wireless Console3) Utility" from the utilities section of the ASUS G75VW download site.

Hope this helps!


11-25-2013, 10:31 PM
I've never seen any bluetooth icons or even unknown devices with the yellow question mark that in the Device Manager.
I've tried using the Fn+f2 key combo but it only toggles my wifi on/off. I have installed the ATKACPI driver and hotkey-related utilities and ASUS Wireless Switch Utility, but the console does not work.


Thx for trying though :D

11-25-2013, 11:00 PM
Thanks for the screenshot.
You may want to confirm the sales specs for your unit if possible, but it sounds like your version of the wireless card may not come with bluetooth.
Check this older thread if you're interested http://rog.asus.com/forum/showthread.php?29705-g75vw-bhi7n07-Bluetooth (apparently I had a G75VW version before without bluetooth too, but I only have the G75VW model with wireless and bluetooth right now).

If necessary, you may want to consider getting a USB bluetooth dongle?

11-26-2013, 12:34 AM
@cl-Albert has the answer :)

11-26-2013, 12:39 AM
@cl-Albert has the answer :)

Thanks to your help rewben :) .

11-27-2013, 06:53 PM
Thank you Albert! You've been a great help!