PDA

View Full Version : USB connectivity problem



zaedas99
11-24-2013, 03:01 AM
Hello everyone.

First of all, i'd like to say that i simply love my new laptop. The dual fan system is keeping the laptop cool as hell!

Sadly, i now have a problem of usb connectivity. Usb devices, such as a mouse or a usb key, are fine and are working like a charm. External hard drives, on the other hand, quickly disconnect after writing a few GBs of files, and often cannot connect at all to the laptop.

Mind you, it's a very annoying problem, and if i cannot fix it, i'm afraid i'll have to return the laptop :/. I'm pretty sure though that this is all caused by a driver issue. (which should be possible to solve)

If it can helps the troubleshooting, i have formatted the laptop as soon as i received it with windows 8 (in other words, it's a clean install with nothing on it from asus). All drivers compatible with my hardware were installed (i used the ASUS website for that).

My model is the G750 JW.

My External hard drive is 3.0 ready, and my power plan on my laptop is high performance.

If any of you could help me resolve the issue, it would be great!

Thanks

s.ferra
11-24-2013, 10:30 AM
I removed Genesys USB Mass Storage Device from the installed programs and it seems to have solved the problem.

zaedas99
11-24-2013, 03:19 PM
Thanks for the suggestion s.ferra,

I have removed the program as well, restarted, but sadly, it did not fix my problem. My Hard Drive has a lot of difficulty to connect and stay connected

zaedas99
11-24-2013, 04:15 PM
I think i have found a solution.

I uninstalled the driver "Intel(R) USB 3.0 eXtensible Host Controller - 0100 (Microsoft)" and restarted. Windows 8 then installed his default driver, which turns out that it's simply an older version of "Intel(R) USB 3.0 eXtensible Host Controller - 0100 (Microsoft)".

In other words,

Windows update caused the problem. (It actually tried to update that driver to a newer version via 'optional updates'). Simply do not update to that version, as everything is working fine without it.

Thanks for those who tried to help me.

nairdat
11-24-2013, 07:02 PM
dude youre a genius this solved my problem as well i also have wifi problem if you encountered this problem as well and have a solution i'm thankfulll

post in here

http://rog.asus.com/forum/showthread.php?40401-G750JW-wireless-problem&country=&status=