PDA

View Full Version : Asus 7970 Matrix Platinum Burn - Burned?



FiskNor
11-25-2013, 03:56 PM
Hello People of the interwebs!

I have done a great sin! While messing around with my system I decided to tru the GPU Tweak functions. While playing around I found the default gaming profile option and decided to press BURN. I did this without backing up the flash. GPU Tweak asked me to restartt, and so I did. Upon booting I could not see any faults or errors. After logging in on the other hand! The screen went black and white in a striped fashion. I now nknew I had done something foolish. Upon checking the forums I saw plenty warnings about the Burn button. Many warnings!

What I have tried so far!
- Pressing safe-mode on the card upon restart, while off, while booting and while active. No go!
- Booting PC in safemode and tried opening GPU tweak. Got informed that i missed som DLL files, GPU Tweak could not start.
- Reinstalled GPU Tweak - Same error/issue
- Reinstalled GPU Tweak and Display Drivers from original CD
- Tried flashing vBios. Did not work as I had the wrong bios.
- Cried
- Enabled iGPU and reset the system to earlier savpoint - Windows system Restore
- Read all forumpost I could find. No resolve

Error message from GPU Tweak - Fail to load dlls. Please install VGA driver

Is there any hope to fix this?

B0UJI
11-26-2013, 03:47 AM
Heya if you run up the iGPU you can probably get the BIOS off techpowerup and flash it that way

FiskNor
11-27-2013, 12:21 PM
Heya if you run up the iGPU you can probably get the BIOS off techpowerup and flash it that way

Hi! yepp, got iGPU, and have tried to flash, but none of the vbioses worked. I have resolved the issue myself by uninstalling all amd drivers and GPU Tweak, and uninstalled the AMD HD 7900 Card driver from Device manager. I powered down my system, removed the 7970 card, and booted the system. Powered down again, installed the card, booted up and installed the newest drivers from the website. Have not reinstalled GPU Tweak and don't think I will.

Thanx anyway Bouji!

B0UJI
11-28-2013, 03:05 AM
No worries! Yeah i would avoid GPUTweak my experience has been pretty bad with it and my Matrix. To be honest the sensors it opens up that you can't see in Afterburner or GPU-Z are basically useless unless you are "LN2" or Hotwiring. Really disappointing actually, I have an MSI 280x I picked up to crossfire and GPU-Z shows proper VRM and Memory temp and voltage readings clear and concise whereas the Matrix tells you tons of random **** but no succinct "What is the damn VRM temp!"

qwerty491
12-13-2013, 11:08 PM
FIX (HAPPENED TO ME AND I FIXED IT)
If like me you downloaded the GPU Tweak software thinking it wouldn't distort your GPU BIOS when you clicked the burn button don't worry.
All you need to do is turn off your computer and push the safe mode button on the graphics card so it shows a green LED.
They turn your computer on and boot into windows.At this point the card MATRIX LED should be flashing green.
If like me you deleted GPU Tweak thinking this would fix it when you log in you need to re-download it and let it restart your computer.
The graphics card should still be flashing Green. If your pc does't turn on after reset turn it on and log in. Then open GPU Tweak and it
will ask you if you want to reset your Graphics card. Click yes and this will reset the BIOS and the card will be restored to full working order.
Hope this help everyone who thought that GPU Tweak could be trusted and like me DELETE IT AFTER THIS.

HiVizMan
12-14-2013, 12:21 PM
Thank you for posting the fix.