View Full Version : Keyboard problem with my G53SX

11-26-2013, 08:24 AM
hello everyone
I'd rather come on this forum in other circumstances but I unfortunately got a problem on my laptop G53SX
My DC Jack has been damaged and repaired in a computer store, and then I took the opportunity to add an SSD and 4Gb RAM
Next, the BIOS has been flashed, the origin hard driver was formatted and windows 7 installed on SSD

Since all drivers are installed and up to date there is no conflict of driver and keyboards and notepad are recognized in the device manager.
Keyboard allows me to access the BIOS (del), navigate and confirm (directional arrows and F. ..) but when i get in Windows, nothing works!

Did somebody already get this problem ?

Thank you in advance
and sorry for my poor english ! Forgive me i'm a frog hum ... french !

11-26-2013, 05:35 PM
Welcome to the forums!

Can you clarify if just the 'Fn' keys don't work like 'Fn'+'F5'/'F6' for screen brightness and 'Fn'+'F11'/'F12' for volume, etc., or you cannot type any letters and numbers as well (did you type the post above with your notebook keyboard?)?

Anyway, if the problem is just with the 'Fn' keys, make sure you don't see any yellow question marks in device manager and install the "ATKACPI driver and hotkey-related utilities" from the 'utilities' section of the ASUS G53Sx download site http://www.asus.com/Notebooks_Ultrabooks/G53SX/#support_Download

If necessary, you may also want to check the keyboard in Windows Safe Mode (or a DOS prompt if a boot drive is available?).

Hope this helps!

11-26-2013, 06:20 PM
I write this message and the previous one with the virtual keyboard ...
Fn5 Fn6... Doesn't work also ! no symbol letter or number is available,only at the beginning with Del to access to the Bios and after i can use the arrows and F9 and every options available on the Bios !
i already tried to update ATKACPI.... with no result ! My next and only option is to install windows once again maybe ?

11-27-2013, 12:15 AM
'F2' should be used to get into the G53Sx bios if anybody cares.

If you need to type the Windows product key before you install Windows, you should be able to check the keyboard (numbers and letters?) at this step.
Otherwise, if you reinstall Windows, check the keyboard before you install anything else since it should be working for English Windows at least.

Just trying to determine if there is a hardware or software related problem with your keyboard.

12-07-2013, 10:05 PM
Sorry for my late answer but i had a hard planning this last days ....

About windows, when i register, i choose the option who allowed me to register in the 30 next days and add my key with the virtual keyboard...
After that, one of my friend try to boot the laptop with linux on USB key and the keyboard wasn't able to work , the only way to use the keyboard for me is at the beginning when i push the power button to access the bios or the windows recovery system, but my laptop was formatted and i have no recovery point ...
The notepad also don't work, and the 2 pins or plugged in different place on the motherboard so i don't think it's a question of material but a software problem

The device manager is ok about keyboard and notepad !

If you need any other information, i'll give you !!! and thank you to help me in return

12-10-2013, 12:23 AM
I may be wrong, but if your keyboard doesn't work during the Windows installation to enter the product key (assume it wasn't working, so you had to use the virtual keyboard) or with linux (assuming the keyboard would normally work with your notebook and version of linux you tried), it still makes me think you may have some kind of hardware or maybe bios issue although you may not want to fool around with the bios right now.
It's not too clear since your keyboard still works in the bios, but maybe only some keys are working.

Anyway, I don't have more ideas right now, so you may want to look into the hardware or bios later if you cannot get better suggestions to solve the problem. Your local ASUS service center should be able to help check the problem, and if you're still under warranty, you may want to arrange this before the warranty expires.

Also, if it helps, you might consider using an external USB keyboard until you can find a better solution?

Good luck!

12-12-2013, 02:41 PM
I buy a USB wireless keyboard who works good !
There's something weird because the keyboard and the notepad plug or not on the same spot on the motherboard
Also, the laptop is out of warranty so it's not valuable to send it to ASUS.

Do you know if there's a keyboard controller on the motherboard ( physically chipset ??? ), in that case, maybe he was damage when i open the laptop ...

My last solution is to use the laptop as a desktop computer with HDMI connexion to TV and wireless keyboard and mouse

12-12-2013, 06:20 PM
Glad to hear you could compare with a USB keyboard and that the USB keyboard is working!

There should be circuitry to control the keyboard although I'm not sure if it's a separate chip, but since it's solid state with no moving parts, I would check other things first unless you happen to have a loose screw in the notebook.

Anyway, did you say you opened the notebook before?
If possible, you may want to try to carefully reconnect the keyboard cable to make sure it is installed well and be very careful with the plastic keyboard latch which is easily broken and pretty much impossible to replace without changing the entire motherboard if you want to reconnect the keyboard again (if you don't have a safe way to do this, it may be better to skip this step although if you plan to use an external keyboard, it may not be a concern for you).
Not sure if you have an easy and cheap way to try another G53SX keyboard (or if it is worth it to send back for out-of-warranty diagnostics to find out if just the notebook keyboard is bad?), but just another possibility to consider.

Yes, if it's better, you may want to consider converting the system to a desktop computer.