PDA

View Full Version : Game Lag issues after upgrading to windows 8.1



Kirtan
11-29-2013, 05:41 PM
Nearly a month ago i updates my system to Windows 8.1 ,
after few days when i was playing this game, i noticed some lags in between ,

For example when i play GTA 4 on my lappy , the roads wont load, sometimes the building wont load, this was not the issue when i was on Win8 , now when i play NFS games too , in between the game will nearly freeze at high speeds,

i have upgraded everything till now, so m i missing something here?

PLease help me with this one , i cant play laggy games lol.

also i am always plugged in , so there is no issue of power.


Thanks ,

and Happy Turkey Everyone. :)

hmscott
11-29-2013, 08:19 PM
Nearly a month ago i updates my system to Windows 8.1 ,
after few days when i was playing this game, i noticed some lags in between ,

For example when i play GTA 4 on my lappy , the roads wont load, sometimes the building wont load, this was not the issue when i was on Win8 , now when i play NFS games too , in between the game will nearly freeze at high speeds,

i have upgraded everything till now, so m i missing something here?

PLease help me with this one , i cant play laggy games lol.

also i am always plugged in , so there is no issue of power.


Thanks ,

and Happy Turkey Everyone. :)

Not all the drivers for our G750 laptops got updated for Windows 8.1 yet. Although I am not seeing any problems, it could be related to your issues.

You might look for OEM drivers for 8.1 for your LAN/Wifi hardware. I pulled a driver from a newer Asus motherboard using the same 802.11ac hardware as the G750JX, but now with the G750JH I haven't felt a need to look for newer drivers.

I needed to unzip the Asus driver and dig into the folders to find the non-Asus Setup program to try to do the install, the Asus Setup program didn't want to install on the G750JX, and then I used the Device Manager and Properties on the Wifi card to update the driver from the folder. Sometimes you need to be creative to get things to work :)

Let us know if you fix the problem with a newer Windows 8.1 driver, where you got it, and how you installed it.

Here is my posting from the situation I mention above:
http://rog.asus.com/forum/showthread.php?38627-When-will-the-Windows-8.1-Drivers-become-available&p=324799&viewfull=1#post324799