View Full Version : DNS server not responding ?

12-03-2013, 01:13 PM
Hello everyone

Im having a bit of problems with my new rog notebook. Every time I connect via wifi I can stay online for a few minutes, if im lucky around ten. Then I lose my connection and it mentions ( limited ). My other computers and wireless devices remains connected tho, just the laptop that disconnects, when I run a troubleshooting it comes back with dns server not responding.

Any idea why only my laptop is doing that?

When I bring it at work, my laptop runs smoothly and nothings wrong, it does that only at my home and at certain friends house.

I thought it could be a faulty router?

Any advices?

Myk SilentShadow
12-03-2013, 01:24 PM
Hey there, love the screen name ;)

Can you try something for me please? open command prompt as admin and enter this command

ipconfig /flushdns and then ipconfig /registerdns

Then exit the command prompt and see if it has any effect.

12-03-2013, 05:47 PM

Well It did run for a longer time, went nearly an hour without any disconnection. It did disconnect at some point and troubleshooting came up Dns server not responding.. :(

Wondering if I should send my laptop back to asus, or if its really a router problem, I have no clue

Any idea what else I could try?

12-03-2013, 05:47 PM
You already ruled out the laptop by bringing it to work. What troubleshooting method did you use, the Windows based one?

If it is a DNS, it is not a disconnect, but rather name resolution to the IP. You can test connectivity by pinging a server via the IP address.

Run -> cmd -> ping

If this succeeds, then it is only DNS; if this fails, look at the AP.

What is your DNS information when you do 'ipconfig /all' ? Also, if you couldn't ping, try pinging the default gateway listed in here as well.

12-03-2013, 06:06 PM
What web browser are you using?

It would also be beneficial to set your DNS servers in the router to google's public dns .


12-03-2013, 10:42 PM
@ Watchguard

I used the windows troubleshooting, tried to ping the and and its says request timed out, what do you mean by looking at the ap?

As for my dns information when I type ipconfig all, it gives me

Do I need to try placing the dsn 1 and 2 in my router still seeing I couldn't ping?

12-04-2013, 12:06 AM
With DNS of, your router is performing what is known as DNS forwarding. You are sending DNS requests to your router and it is in turn queuing up DNS servers, typically your ISP DNS servers in situations like this.

Since you tried to ping, which doesn't use DNS, and were unsucessful, this means you lost connectivity to the AP (Access Point) and its not just DNS. In this context, I am saying AP is the wireless unit you are connecting to, which can be your router. Where you able to ping your router ( Do you know what 802.11 setting you are using (b/g/n/ac) and if you are on 2.4mghz or 5ghz?

12-04-2013, 01:31 AM
I was able to ping the router, Im on 802.11ac on 2.4

Would it be maybe a good investment to buy perhaps a more reliable router? Using a dlink dir-615 atm

12-04-2013, 01:32 AM
For some reason now just retried ping from and it worked... weird

12-04-2013, 12:42 PM
Is there any other options for me to explore or is it pretty much it?

Switching internet provider next week, which by default will come with another router, Ill see how it goes.

Thanks for all the help everyone, much appreciated :)

12-04-2013, 09:30 PM
If you can ping, but not ping www.google.com, this is DNS.

If you cannot ping OR www.google.com, this is connectivity.

AC is on 5GHZ only, so could you verify which one you are on? As a poster prior to here mentioned, you can change your DNS settings on the router. Refer to your device's manual on how to do this. You can also modify the properties of your Wireless NIC to use specific DNS servers.

12-10-2013, 04:03 AM
Well after switching internet provider my laptop works fine, just thought id write it on here if anyone experiences anything like I did and seemed to have tried everything, the provider might be the problem..

Still wonder how the provider can **** up something like this lol

Thanks to everyone who helped :)