PDA

View Full Version : Asus G75VW - average time taken for servicing?



echineko
12-04-2013, 06:45 PM
Hi guys,

I've been using my G75VW for about 6 months so far, but recently I've had a problem where it hung randomly while in use, and from then onwards it did not boot up again (black screen, no sounds indicating Windows is actually starting up).

I took it to the local service center here in Kuala Lumpur, and after 3 weeks I still haven't heard back from them. Is this normal, how often does it take usually? Also, given that I've had my laptop for less than a year, would I actually have been able to ask for a replacement? I wasn't advised of this option at the service center, and now I'm wondering if I should have just asked for a new unit >.<

I'm really missing the laptop right now, because it's not just a gaming machine, I have my freelance business-related material on it as well.

Any help/guidance/past experience would be helpful.

rewben
12-05-2013, 12:34 AM
@echineko,

i assume you goto the one at lowyat plaza. the service duration most probably depends on what issue the laptop has, the traffics (incoming service requests), needs of parts, etc. since you have sent it in, it's better for you to call them regularly on the status. (don't wait for them to call you; usually this waiting part will not work well)

the one thing that i always suggest people to do when you wanna send in a laptop for servicing: do not leave your data in it. find a way to back them up. it's your data. only you know how important they are. others don't. sometimes it's a windows issue that can be resolved with a simple windows restore.

echineko
12-05-2013, 01:17 AM
Hi rewben,

I'm guessing you're from around these parts? Heh. Well, in this case data is the one thing I don't have to worry about, I had just got an SSD to upgrade the laptop (the struggle with finding a downloadable ISO of the OEM Windows 8 is another story altogether ;p ), so I've already moved everything needed off the laptop. I even mentioned to the service center they can go ahead and reformat my old HDD and install the OS fresh into the SSD.

Now I just need the laptop back so I can start using it for my freelance work again, the other laptop I have at home is comically underpowered comparatively

I have called them, and they mentioned they were waiting on a replacement GPU from Taiwan, but I really don't think it would take that long to get a part? Might be wrong though.

PS. I noticed in your tag it says you have Windows 8 pro on your machine did it come with the laptop or did you buy it separately? I'm guessing a separate purchase?

@echineko,

i assume you goto the one at lowyat plaza. the service duration most probably depends on what issue the laptop has, the traffics (incoming service requests), needs of parts, etc. since you have sent it in, it's better for you to call them regularly on the status. (don't wait for them to call you; usually this waiting part will not work well)

the one thing that i always suggest people to do when you wanna send in a laptop for servicing: do not leave your data in it. find a way to back them up. it's your data. only you know how important they are. others don't. sometimes it's a windows issue that can be resolved with a simple windows restore.

rewben
12-05-2013, 02:19 AM
@echineko, yes i am from the same part of the world as you :)

oh replacement of parts usually will take longer time than normal servicing (from what i've read, it might take longer). however i still think you should follow the case up from time to time.

ps. the w8pro was an USD14.99 upgrade from stock w7hp hehe

Pitcher@asus
12-05-2013, 02:58 AM
we will contact local service center to take it.

rewben
12-05-2013, 06:37 AM
now thanks Pitcher@asus!

echineko
12-06-2013, 05:43 AM
we will contact local service center to take it.

Thanks Pitcher, rewben for your assistance so far. Albert has also contacted me, I guess I'll sit tight and hope for an update soon.

Cheers,
Echineko

rewben
12-06-2013, 09:02 AM
sweet :)

echineko
12-14-2013, 05:58 AM
Well, I finally got it back, everything seems to be working . Thanks for the help, all!