PDA

View Full Version : Turbo button doesn't appear to work anymore



brettt777
12-06-2013, 07:18 PM
Since I updated to Windows 7 Ultimate, my turbo button doesn't seem to work anymore. Before I would get the little gif on the screen telling me that I'm in turbo mode or not in turbo mode, but it doesn't come up anymore. The other buttons seems to work; the light dimmer and display mode selector. I know that certain add-on Asus applications are necessary for some of these functions to work. I thought I re-installed all of them but apparently I missed something. Anyone know specifically which one of those apps makes the turbo function work?
Interestingly, I was looking at CPU-Z and watching the core speed to see if anything was changing when I pressed the turbo button. All the core speed ever does is jump between 1728mhz and 2394mhz, and it does this randomly. Pushing the turbo button has no affect on it. I thought I remember this speed dropping down to somewhere in the 700mhz range when the CPU is idle...?

cl-Albert
12-06-2013, 08:20 PM
When you change the brightness or volume though, do you also get the onscreen display to tell you the levels, or does it just change the settings without telling you more (and do you remember if it did before?) ?

Anyway, it sounds like you have one of the G73 models from your flashing battery light post, and you may want to tell us the exact model if necessary, but if you haven't installed the "ATKACPI driver and hotkey-related utilities" from the 'utilities' section of the ASUS download site (search by your G73 model to find the correct downloads) http://www.service.asus.com/#!downloads/c1wax use it to see the onscreen display for the brightness and volume.

I haven't worked with the G73 too much and don't have one around to check, so you may want to wait for more replies, but your turbo button may not work with only the ATK driver installed and I'm guessing the turbo button settings are related to the Power4Gear Hybrid Utility which you may want to get too if necessary from the 'utilities' section.

Well, hope this gets you going in the right direction, or you can get some better suggestions.

brettt777
12-07-2013, 07:01 AM
I have a G73JH series. The on screen displays for volume, brightness, keyboard brightness, touchpad and wireless function all work normally as well as display mode. The only one that doesn't work is the turbo button. It use to but since the Windows upgrade it hasn't worked. So I'm sure it's just a driver or app that I'm missing, I just don't know which one.