PDA

View Full Version : G750JX doesn't detect power adapter



drivelikebrazil
12-12-2013, 02:54 AM
I just got my G750JX-TB71 last week and everything seemed fine, but today I plugged it in and it no longer indicates that the adapter is plugged in. No charging light, can't boot with the battery out, nothing. I'm probably going to RMA tomorrow, but has anyone else had this problem? If someone has a fix, then I'd rather do that than return it.

wrangler
12-12-2013, 03:07 AM
I know this seems basic, but it happened to me once -- is the cord plug firmly inserted in the adapter?

drivelikebrazil
12-12-2013, 03:38 AM
Lol, yeah it is. Took it out and firmly pressed it back in several times to no avail. Just got off the phone with ASUS support and he had me remove the battery, unplug, and then hold the power button down for 30 seconds. That got it to power on while plugged in with no battery, but we couldn't get the charging light to come on when we booted it back up with the battery back in. Still just draining away. :/ Looks like it's time for a return :(

Pitcher@asus
12-12-2013, 04:45 AM
do you have friend have same G serious laptop. it yes, you can use your friend adapter to try it, if still can not charger, please send to service center to check it.

wrangler
12-12-2013, 05:36 AM
Lol, yeah it is. Took it out and firmly pressed it back in several times to no avail. Just got off the phone with ASUS support and he had me remove the battery, unplug, and then hold the power button down for 30 seconds. That got it to power on while plugged in with no battery, but we couldn't get the charging light to come on when we booted it back up with the battery back in. Still just draining away. :/ Looks like it's time for a return :(

It was worth a shot. When it happened to me, it wasn't something I thought of right away, as it looked okay; it just wasn't seated well.

hmscott
12-12-2013, 07:18 AM
Lol, yeah it is. Took it out and firmly pressed it back in several times to no avail. Just got off the phone with ASUS support and he had me remove the battery, unplug, and then hold the power button down for 30 seconds. That got it to power on while plugged in with no battery, but we couldn't get the charging light to come on when we booted it back up with the battery back in. Still just draining away. :/ Looks like it's time for a return :(

drivelikebrazil, this happened to my G2S long ago, and ever since then I always purchase an extra power adapter just in case - the laptop is shortly worthless once the battery drains... Asus adapters have otherwise been reliable, never had another one fail, but you never know what might take one out - so I always keep 2 around.

I hope they fedex one to you ahead of the RMA, it only seems fair :)

cl-Albert
12-12-2013, 08:32 PM
This may be a bit of a longshot (and too late?), but if it wasn't mentioned already, make sure your power outlet is working okay, try another power outlet, or try another device at that outlet to check it, etc.

Also, if you are using a power strip, make sure it hasn't been accidentally switched off (I talked to a customer before that had this happen and I believe the cat was the suspect in question for causing it).

Anyway, thought I would run this by you.