PDA

View Full Version : CG8480 graphic card upgrade problem! help needed please! thanks you!!!!



sphere_s
12-14-2013, 03:15 PM
hey there peeps.

having trouble upgrading my graphics card for my 1 year old ROG desktop.

breakdown of my com:

Desktop :
ROG 8480
PSU : 500W
intel(r) core (TM) i7 -3770k CPU @ 3.50 GHz
16GB RAM
operating system 64-bit, x64 -based processor
windows 8.1
graphic car: GeForce GT 640

(wanting to upgrade to leadtek GTX 650 TI boost)

recently bought a LEADTEK GTX 650 TI BOOST.
However my computer is unable to read my graphics card and there is no signal to the monitor(DVI), but the card seems to be running fine. i have place back my old graphic card and the computer is able to receive signal to the monitor.

a friend of mine took it home to test it out on his DIY built computer. card seems to be running fine without any problems.

does the problem have anything to do with the bios? or does ASUS ROG not allow changing of graphic card for this model of computers?

sherman
07-10-2014, 05:24 PM
hey there peeps.

having trouble upgrading my graphics card for my 1 year old ROG desktop.

breakdown of my com:

Desktop :
ROG 8480
PSU : 500W
intel(r) core (TM) i7 -3770k CPU @ 3.50 GHz
16GB RAM
operating system 64-bit, x64 -based processor
windows 8.1
graphic car: GeForce GT 640

(wanting to upgrade to leadtek GTX 650 TI boost)

recently bought a LEADTEK GTX 650 TI BOOST.
However my computer is unable to read my graphics card and there is no signal to the monitor(DVI), but the card seems to be running fine. i have place back my old graphic card and the computer is able to receive signal to the monitor.

a friend of mine took it home to test it out on his DIY built computer. card seems to be running fine without any problems.

does the problem have anything to do with the bios? or does ASUS ROG not allow changing of graphic card for this model of computers?
HEY! have your problem been solve?