View Full Version : G73jh Crucial C300 256gig won't show up??

09-10-2011, 11:36 PM
EDIT: Ok. Talked to Crucial again and went throughout some options I tried. If you can see the drive in the bios and see the drive in windows disk management, but can't install to it. You don't do a format on the drive and assign a letter to the drive. You need to "Delete Volume" from in disk management. Don't do anything else. Once that was done, the drive showed up for install and worked perfect. No issues so far and this thing boots in 15sec now. Loving it!! Thanks for helping guys!

Has anyone updated their Hd to a ssd? I have a C300 and I can't install windows to it. First tried using restore disks. Took an hour and said successful, but after reboot it wouldn't boot. Kept getting choose proper boot device and reboot. Took drive out and reformated in my desktop and got it ready for install again and put back in my G73 and put a win7 disk in and tried that. When it comes to the point to pick hard drive and make partitions, drive won't show up. If I browse for drivers to load, it shows it there but won't show to install on. The G73 sees it in the bios. I've tried both achi/IDE and same thing. Ide won't work at all.

Any ideas? Does the g73 not like sata3 drives? Shouldn't make a diff. I'm lost now and can't figure it out. Asus support couldn't help either.

09-11-2011, 02:04 AM
Crucial should have a utility to force wipe it, so it starts over clean and its memory aligned properly. Also make sure you are using the current firmware.

09-11-2011, 01:28 PM
Ok. They didn't mention it to me Friday. They just told me to update the firmware and do a power cycle. I will call them again. Thanks.

09-12-2011, 02:33 PM
So after talking with Crucial this morning, they said that there is no utility to realign memory. They also told me that if I can pull that drive out and put in my desktop and install, there's nothing wrong with the drives state. They are telling me that it has to do with the laptop. How the DVD drive talks with the Hard drive. It mite be that the 2 channels can't talk with each other the way they need to. As in the DVD drive may be connected to a sata port but be running on a channel as in the IDE and cant talk with the channel the SSD is on. They told me to ask asus for a sata driver for the laptop. I looked on Asus's site for a sata driver and don't see any for my G73JH. There are none. The other thing they told me is to find a utility that will allow me to put my Win7 disk on a usb drive and try to install like that. I'm not sure of that utility or what it's called. If anyone has used or know what utility this is, please inform me.


09-12-2011, 07:19 PM
1) Make sure the BIOS has the SATA controller set to AHCI mode.

2) Windows 7 comes with an AHCI SATA driver. The system comes with the Intel RST SATA driver installed as well.

3) The SATA ports for the HDD and ODD are SATA II ports. You should have no issues using all three.

4) Plug the SSD in yor desktop, and delete any partitions on it, and then put it into your JH. Run Win 7 from the DVD drive. The MS AHCI driver should work to get Win 7 installed. If not, you can download the Intel RST F6 driver pack, and put them on a USB stick, and load them during Win 7 Install.

09-15-2011, 12:15 PM
Well I've tried about everything and still no luck. I can pull up the drive in windows and use it or format it, but now trying to install windows even on my desktop the drive wont show up as a usable drive. I've never had any problems or issues with it showing up on my desktop pc. Never needed to load a driver or do anything special. Could doing the firmware updates to the drive have caused this? I'm lost now. Maybe this drive needs to be sent back to crucial.

I did put my 500gig drive that came in my g73 in the second(left) Hard drive slot and the C300 in the Main(Right) and both drive show up and are usable in windows, but still can't install to it.

09-15-2011, 04:02 PM
First I would look to see if it's in the device manager. If it's there then you might need to rescan from the disk management page. You can get there by right-clicking on "my computer" and going to manage.

09-15-2011, 06:03 PM
That's where I go to format the drive. Under control panel/Admin tools/Computer managment/storage/disk managment. I can format the drive, but now when I try to install it doesn't show up as a usable drive. In either my laptop or desktop now.

09-15-2011, 07:43 PM
It must be assigned a drive letter and you'll want to make sure that it isn't trying to use the same drive letter as something else (especially removeables).

09-16-2011, 11:44 AM
I will try assigning a drive letter to it when I get home and see if that helps. What worries me is that it's not showing up when trying to install on my desktop now. I've never had to assign a drive letter before. Maybe it had a drive letter before when I had the OS on it. I've had Win 7 on it before and booted to the disk and reloaded windows a few times. Maybe the firmware wiped the drive letter away.

09-24-2011, 01:05 PM
Solved. Edited first post.