View Full Version : Realtek HD audio not found, HD Audio Controller cannot start Error Code 10

09-11-2011, 03:05 AM
I've installed Windows 7 x64 Professional in GPT/UEFI boot mode, I've installed all the drivers but I have no sound via the internal speakers.

The Sound icon in the corner indicates "No Audio Output Device Installed", I'm getting a "This Device Cannot Start. (Code 10)" On the High Definition Audio Controller and no Realtek devices are showing under Audio Devices.

This is my 2nd clean install of Windows 7, I've done doctorate level research on registry fixes, tried several different suggestions of drivers and software hacks, tried using the drivers from my Asus Crosshair V which has a very similar setup but nothing has worked. The nvidia sound installs and works fine but not the onboard sound.

I booted with a Live Kubuntu CD and audio output via the internal speakers worked fine, I've been working on this now for 13+ hours and hoping someone here can help me out and allow me to keep what is left of my sanity.


09-11-2011, 03:41 AM
If you haven't installed Driver Sweeper 3.1.0 or later, please do so. Run the Realtek uninstaller. Boot to safe mode, and run Driver Sweeper for the Realtek drivers. Delete all components / registry entries found.

Your UEFI boot may not be allocating hw resources properly for your audio chip, and it is conflicting with another device. You could also disable UEFI and boot up and see if the Realtek will install, then go back to UEFI and see if it's cleared. (My UEFI experience is limited currently)

09-14-2011, 01:47 AM
Sorry for the delay on a reply and thank you for your response, damn cable company decided they were going to audit and accidentally disconnected mine.

I tried all the suggestions but nothing worked and I'm convinced there has to be a bug in the UEFI for the G53 series. I went ahead and installed a normal MBR BIOS install of Windows 7 and confirmed working sound. Once I did that I converted it to GPT/UEFI and the sound immediately quit working.

I just gave up on this laptop booting GPT/UEFI and settled with the legacy Windows MBR/BIOS as it isn't a huge deal I just like to stay ahead of the curve, I guess not on this system.

Thank you for the reply though :)

12-03-2011, 01:10 AM
I have the exact same problem on my G53SW - audio was working fine before I enabled the UEFI in BIOS ( for my clean windows install onto an SSD)
I too was hoping to use UEFI to its fullest. Any hopes for a FIX for this?

Incidentally, I notice that EXPRESSGATE disappeared completely under UEFI... pressing the expressgate button just starts up windows now (the boot seems a bit faster than with the power button, less POST lag?)