PDA

View Full Version : G750 Win 8.1 hanging on Shutdown FIX



hmscott
12-25-2013, 02:24 AM
Update: The hang was traced to BT, and the good news is it isn't the BT driver per se, it is the BT features that get turned on every time you update the BT driver.

I usually disable all of these because I know I don't want them on, but the last time I did a Wifi update the BT update came along in the package and I didn't take the time to go through the BT options dialogs to disable everything.

Via the systray BT icon => Settings - turned off everything I don't want on, and quick reboot came right back :)

BT features turned off:
1) Options Tab => Notification "Alert me when a new Bluetooth device wants to connect"
2) Share Tab => Turned off "Allow remote devices to browse, send, and receive pictures, music, and other files"
3) Share Tab => Turned off "All remote devices to use the printer connected to your computer"
4) Sync Tab => Turned off "Allow Bluetooth devices to send you PIM items..."

A BT driver update shouldn't change your BT user preferences - especially ones that open up your security!

Anyway, not sure which one causes the hanging, but I don't want any of them on anyway :)

----------------------------------------------------------------------------------------

These instructions on disabling Hibernation and Fastboot aren't the cure for slow shutdowns, but they aren't a bad idea anyway - at least for me my boot time goes from 5 seconds to 10 seconds, and I gain back 24GB of C drive space.

Good news, I just turned off Fastboot in the BIOS, after already disabling Fast Startup in Power Options, and immediately my hang at shutdown/restart problem vanished. :)

The other good news is that I regained 24GB of disk space by turning off Hibernation.

Here is how to do it. Disable Hibernation in Windows to disable Fast Startup, then go into the BIOS and disable Fastboot in the BIOS.

Disable Hibernation in a cmd shell - Right click and Run as Administrator:

c:\ powercfg -h off

That will disable Hibernation and also disable Fast Startup in Power Options as it depends on Hibernation to work.

Now go into the BIOS and Disable Fastboot.

That is all. You should now be able to restart/shutdown without a long delay.

After disabling Hibernation, Power Options => "Change what the power buttons do":

31718

Nehmia
12-26-2013, 05:28 AM
you should never disable hibernation in Windows 8 or 8.1, it is used for the Fast Boot feature

hmscott
12-30-2013, 04:02 AM
you should never disable hibernation in Windows 8 or 8.1, it is used for the Fast Boot feature

I always turn off Hibernation, with an SSD boot drive I don't want to give up 24GB of space just for a slightly faster boot time. Even a cold boot only takes 9-11 seconds, what am I gaining by an increase of 5-6 seconds in boot time when I am losing 24GB of SSD space and waiting 2-3 minutes for a restart/shutdown?

Faba002
12-30-2013, 05:24 PM
Nice work you fixed this problem
I dit today a clean instal with this and the windows8.1 boot problem is gone
but you may add also that everyone need to download the WLAN 8.1 driver and Bluethoot 8.1 driver from the asus site becaus windows 8.1 instals after upgrade a strange version of the 2 and they slow down back the restart I removed with ccleaner the 2 drivers and dit a instal from the asus site drivers now, also I am happy with the 24 GB extra disk space on my SSD + with the fast boost off it is still very fast now only a fix for some video drivers for the 3D screen and then i can finnaly start a game on this thing

hmscott
12-30-2013, 08:21 PM
Nice work you fixed this problem
I dit today a clean instal with this and the windows8.1 boot problem is gone
but you may add also that everyone need to download the WLAN 8.1 driver and Bluethoot 8.1 driver from the asus site becaus windows 8.1 instals after upgrade a strange version of the 2 and they slow down back the restart I removed with ccleaner the 2 drivers and dit a instal from the asus site drivers now, also I am happy with the 24 GB extra disk space on my SSD + with the fast boost off it is still very fast now only a fix for some video drivers for the 3D screen and then i can finnaly start a game on this thing

Faba002, good to know about the Wifi/BT driver updates needed after 8.1 update, and I think you just did let everyone know :)

You can also gain back more space by disabling paging by setting the pagefile size to 0. The more unnecessary ssd/disk IO you can disable the better your gaming experience is - nothing else competes for IO requests.

Faba002
12-30-2013, 08:34 PM
Ho oke thanks but i still cant play games ... with this old drivers .. can you tell me what version your running i cant play any new game here ;s

hmscott
12-30-2013, 08:37 PM
I don't have a 3D screen and I have the Asus OEM install of the OS upgraded to 8.1, so I download directly from Nvidia. 331.82 is the version I am using.

IDK if it is possible, but you might try installing just the base video driver, without the 3D stuff, and see if that works. Don't even install the Audio stuff yet - use the speakers/headset for now.

Faba002
12-30-2013, 08:50 PM
yea i tried that one already I costum instal and only the display driver , and again the problem first i tought it was the 3D all but it is now realy the Display driver self .. i dont know what cousing the problems the last thing what i can try is , removing everything from Nvidia and instaling only the driver for the display and patch it to the latest version I hope that wil work .. that i can do finnaly something

Oliver007
12-30-2013, 09:35 PM
I want to make a BIG BIG thanks to Faba002
I just put Windows 8.1 and make all the update, so I make lot of reboot
And just after installing the "optional" update, I had the Long reboot on my G750JH-4103H (not 3D)
I passed from 10 second with SSD to 2,30 mn
I tought it was a screen drivers issue because of the black screen
I'd just download the WLAN and Bluetooth drivers on ASUS, uninstall the "optional update W8.1" ones, make a ccleaner and finally reboot before install them. And the SPEED reboot is now there again !!
Thank you Faba002

Perhaps there are multiple slow reboot issues, but people who have put W8.1 + update need to try this.

Faba002
12-30-2013, 10:42 PM
No thanks its also thanks hmscott I got my one booting fast
so it are now the drivers, the fast boot on bios so lots of problems on this machien
i see you have the non 3D version .. you dont know anything about a fix for the 3D screen drivers ?

greetz

Oliver007
12-30-2013, 10:55 PM
arg, no sorry , I can't help you on this and got no more issue on my laptop

sotipay
12-30-2013, 11:39 PM
Faba try uninstalling nvidia stuff like geforce experience and download the vga driver from here http://support.asus.com/Download.aspx?SLanguage=en&m=G750JW&p=3&s=521 then install using clean install option. Reboot then download and install geforce experience from nvidia site then run program and it will prompt for upgrade to new drivers. Download and install thru geforce experience. You should have 331.82 driver after that, allowing you to play latest games. At least thats what I did and we both have 3D screen so it should work. Good luck!

Faba002
12-30-2013, 11:54 PM
Faba try uninstalling nvidia stuff like geforce experience and download the vga driver from here http://support.asus.com/Download.aspx?SLanguage=en&m=G750JW&p=3&s=521 then install using clean install option. Reboot then download and install geforce experience from nvidia site then run program and it will prompt for upgrade to new drivers. Download and install thru geforce experience. You should have 331.82 driver after that, allowing you to play latest games. At least thats what I did and we both have 3D screen so it should work. Good luck!

I Will try that but you have a JW model and I a JX model your link is to JW drivers can i use those ?

sotipay
12-31-2013, 12:00 AM
Im pretty sure you can use them since the hardware is the same gtx 770m and its the only model there that has the 8.1 drivers

Faba002
12-31-2013, 12:03 AM
Im pretty sure you can use them since the hardware is the same gtx 770m and its the only model there that has the 8.1 drivers

oke thank god for this information i let you know if it works I try tomorow its very latet right now
so i remove everything from Nvidia I instal the Driver from your model with clean instal , do i need to uncheck everything like 3D and sound ?
after that i instal geforce experience from the nvidia site and let it upgrade on geforce experience and do i need to do there a clean instal or a instal over it ?

thanks !

sotipay
12-31-2013, 12:23 AM
No need to uncheck 3D and sound, just choose clean install and install everything. Upgrade using geforce experience and use clean install if the option is there.

kingfish
12-31-2013, 05:44 AM
hi hmscott, i did as what you have instructed but still have issues on restart and shutdown :(

hmscott
12-31-2013, 06:33 AM
hi hmscott, i did as what you have instructed but still have issues on restart and shutdown :(

kingfish, I have also had a reverse of fortune, and I am also getting the slow shutdown again :(

Strange that the problem goes away both times I have done this, first with just the change in Windows, and then again immediately after I disabled Fastboot in the BIOs, but it came back both times within 24 hours. I rebooted dozens of times in between - with joyous immediacy :)

I am debugging via Windows Event Logs and have solved several annoying errors, corrupt updates for apps, DCOM permissions, and still in the middle of that. I think that is what is coming up on a regular basis daily that is putting me back in the slow shutdown.

I would suggest looking at these URL's and your own logs to see what you find:

Fix Microsoft Windows Update Issues
http://support.microsoft.com/gp/windows-update-issues

Go to Post #5 - it isn't as bad as it looks - I have finished 2 of the 6 I have to attend to :)
http://www.eightforums.com/performance-maintenance/11951-numerous-event-id-10016-errors-win-8-pro-64-bit.html

If these efforts don't provide a solution, I will get something together to see what is running while it is sitting there, black screen, randomly blinking disk IO, and see what I need to uninstall / fix.

I may not get time to finish this debugging before I need to get back to work tomorrow, so please do debug on your own in parallel...

hmscott
12-31-2013, 10:42 AM
Guys, my laptop is once again rebooting /shutting down without delay... I hope it finally stays that way. :)

It seems to be the result of fixing individual problems as in post #18 above, and this effort to get a single clean Nvidia driver installed. I had 3 drivers installed and couldn't get a clean install without disabling the internet so that Windows wouldn't slide a new driver in underneath while I was trying to do a clean install - see the details in the post in the link below.

Read the first paragraph for the summary, and the balance is the supporting / download info.

Post #38
http://rog.asus.com/forum/showthread.php?41844-new-nVIDIA-Driver-from-ASUS&p=356178&viewfull=1#post356178

kingfish
12-31-2013, 07:42 PM
thanks much brother, HAPPY NEW YEAR!!!