PDA

View Full Version : Sabertooth Z87 No Keyboard When Doing a Win 7 System Restore



gootch
12-26-2013, 03:02 PM
Hi

I am trying to do a System restore Win 7 64 Bit. When I boot into the restore program I have no control over keyboard or mouse both wired USB so obviously I cannot continue because i cant give any input I have tried booting from a USB key Win 7 disk and a system image and cant go further because of no keyboard or mouse. I tried changing a few settings in the usb bios settings without luck.

Thanks Andy

Chino
12-26-2013, 03:08 PM
Welcome to the ROG forums, Andy.

Are your keyboard and mouse connected to the USB 2.0 ports? Also, please list the exact brand and model of your keyboard and mouse.

gootch
12-26-2013, 05:42 PM
Welcome to the ROG forums, Andy.

Are your keyboard and mouse connected to the USB 2.0 ports? Also, please list the exact brand and model of your keyboard and mouse.

Thanks for the reply Chino My keyboard is a logitech k120 and mouse is a hp 5188-6230 when I loaded os for the first time i had a wireless usb mouse and everything worked fine. Also I am using the USB 2.0 Ports.

Thanks again Andy

Chino
12-26-2013, 06:06 PM
Can you verify that you are running the latest BIOS for your motherboard? If not, download it to a FAT32 formatted USB pendrive and update your BIOS through the EZ Flash Utility in the BIOS.

gootch
12-26-2013, 06:18 PM
I seem to be in business. I loaded the dafaults F5 in the BIOS ans I have a mouse os is loading now. I will report back after its done.

Thanks Andy

gootch
12-27-2013, 02:14 AM
Everything working well. This was my first build and overall it went real well. Ill never buy a desktop computer again.

Thanks