PDA

View Full Version : Reminder to all SSD owners. Please disable optimization aka defrag.



khmergod
12-27-2013, 02:37 AM
I have had my laptop or two weeks and finally figured out that Windows 8 has been "optimizing" my drives. I have "5" drives. My raid 0 is 4 drives C=OS, f=data, then 2 other partitions recovery and restore. My secondary drive is a Samsung Pro. Make sure to turn off defrag by searching "dfrgui" and disabling auto optimization. That is all. You are welcome my rogers.

Praz
12-27-2013, 02:47 AM
Properly configured Win8/8.1 doesn't defrag SSDs. They are optimized instead which send the Trim command to the drives.

Myk SilentShadow
12-27-2013, 02:48 AM
If you ran the Windows Experience Index, it would have disabled Defrag for you automatically.

khmergod
12-27-2013, 03:14 AM
I've run the index 5 times before checking then dfragui. It didn't disable it.

Nehmia
12-27-2013, 06:03 AM
wrong, all the Windows 8.1 optomization does is send to TRIM commands to the SSD and not actually defrag it!

Go figure!

khmergod
12-27-2013, 12:48 PM
wrong, all the Windows 8.1 optomization does is send to TRIM commands to the SSD and not actually defrag it!

Go figure!

I have windows 8. After disabling optimization, I checked if trim was still on using the DnD query disabledeletenotify and it said trim was still in effect. I'm so confused now....

Praz
12-27-2013, 02:13 PM
Drive optimization has no affect on Trim after delete. As noted above if the system is properly configured the drive will be seen as a SSD. Identified as a SSD a scheduled defrag will run the optimization instead of defrag and Trim the drive. No need to disable defrag for the SSD.