View Full Version : G75VW 3D Vision, Built in emitter not working?

12-30-2013, 11:33 PM
I recently purchased a refurbished 3D model of the G75 from Newegg, only to find that the SATA controller in it was completely bonkers, and that it did not come with the 3D vision glasses that were included at retail. After an RMA, I was completely happy with my replacement... until now, that I finally have my 3D vision glasses, and am out of newegg's RMA window.

No matter what I do, no matter what driver version, windows version, install method, or anything else, will the built in infrared emitter turn on or be recognized, leaving me with what I consider to be a 1600$ brick, as I purchased this machine specifically for it's built in 3D capability.

Before I am bombarded with mundane and helpless questions, Yes, I do have the proper model, even though it did not include the glasses. The emitter is next to the webcam, and has the same '3D' logo that appears when hitting the ROG key next to the power button to toggle it on and off.

I've heard that many displays with built in emitters seem to have issues starting them without a power cycle, so I've also tried doing full battery removal for 15m a few times. I've also messed around with the bios as much as possible with no luck.

The display is listed as Generic PNP in the device manager, but it runs at 120hz, and is the Samsung SEC5044.
There is no listed device for the infrared emitter.
I have attempted to use all of the available Asus video drivers, and the latest nvidia reference drivers, on windows 7, 8, and 8.1, each with a clean wipe with DDU inbetween ( https://forums.geforce.com/default/topic/550192/geforce-drivers/display-driver-uninstaller-ddu-v9-9-2-released-12-20-13-/ ). I have also tried each of these installs with my glasses plugged in.

The 3D setup wizard will not allow me past the first step unless I use the Discover option, even while attempting to use an emulator for the 3D vision emitter. ( http://forums.overclockers.co.uk/showthread.php?p=22264499 )

I have narrowed my options down to sending my machine to Asus, which is a scary prospect. Disassembling the machine to see if the cable for the emitter is unplugged, which is also scary, since I can not find any diagrams for the display, or to find an external 3D vision emitter used on ebay or something, which defeats the purpose of paying a premium for a machine with a built in emitter in the first place.

I'm not sure what I'm asking for, since I already have my choices pinned down, and none of them are sounding that exciting. I've been forum hopping for the past few days without any kinds of answers anywhere on the internet. I bought the computer in October, and never registered with Asus for warranty, as I assume I can not with a refurb.

Help, someone, please :( I still have payments to make on this thing for the next 10 months, and it doesn't do the one thing I bought it for.

12-31-2013, 12:15 AM
Sorry to hear those units haven't been working better for you and had some thoughts below.

1. I may be completely wrong about this, but if you had to RMA and wait to get that second unit from New Egg (and get your own 3D glasses), consider checking with New Egg again just to find out if there is anything more that can be done on their end.

2. If you want to send me a PM at cl-Albert with the serial number of your current unit, I'll check if my system has any information about the repair history of your unit.
I might be able to get an idea if something may have been done wrong at the repair office before you try taking it apart.

Anyway, hopefully others have better suggestions, but feel free to let me know if there is anything I can help with.

01-02-2014, 09:56 PM
Newegg has decided to offer me a store credit, but now no longer carries the G75. Are any of the new 750 models 3D ready? This (http://www.newegg.com/Product/Product.aspx?Item=N82E16834216023) is the only 3D Vision machine I can find on their store, and I'd hate to break my brand loyalty for such an ugly machine. :<

01-02-2014, 10:42 PM
That's great Newegg could offer you another option at least.
Unfortunately, it doesn't sound like we have gone with any 3D ready models for the G750 series in the U.S. and Canada as far as I know if you're not interested in attaching an external monitor, but hopefully someone can let me know if I'm wrong about this.
If you're able to go with the G75VX, look into getting the G75VX-DS73-3D model, but didn't see it on Newegg's site.

Also, wondering if I should even mention this, but if you check the ASUS G75VW download site, bios 223 for the G75VW mentions fixing a 3D bug with the Samsung panel, but not sure that it will solve the problem you are seeing, or is worth the risk of a bad bios flash even if it is (I may worry too much, but just want you to be aware of this possibility which will cause your system to stop working completely).
Guess it would be nice if you could get something in writing from Newegg that you can still return the unit if the bios flash fails as unrealistic as this may sound.

Otherwise, if anybody else has run into this issue with the earlier bios versions and solved it with the 223, it would be great to hear from them.

01-03-2014, 01:25 AM
I can confirm that the BIOS is running version 223, it was one of the first things I checked (and the only thing I can check, now that the hard drives are wiped.) It's sad to go, because I've been wanting this computer since the day it was launched, but store credit was my only option, and like you noticed, they have just completely removed all of the G75 models from inventory. :(

Hopefully no one else runs in to the problems I did, and if there are any other refurbished newegg buyers that have this issue, remind them that the listing (http://www.newegg.com/Product/Product.aspx?Item=N82E16834231328) for the item says "3D Vision Kit Included" and that you didn't receive one. I'm sure they'll be more than happy to tell you that this is completely your problem until you scream at a manager for 45 minutes about how you can't test for a defect if the necessary hardware isn't included.

Best of luck to all of you ROG peeps, this was the best laptop I was never supposed to have.

07-17-2014, 10:24 AM
I have the same problem with emitter. But in my case:
1. I have Asus g75vx
2. Nothing happens when I press the "ROG button"
3. I've bought it new 1,5 years ago
4. It worked until I reinstalled Win 8.

First of all, my SSD failed and Win 8 on it was gone (unfortunately the recovery disks were lost). I've bought another SSD, replaced it and installed new original WIn8. Had some problems with installing drivers and Asus programs (some of them told that I have a non-Asus notebook), but for now only one problem left: win 8 can't see my 3d emitter.

Tried different video drivers, but nothing happened. My display is Generic PNP @ 120hz and there is no "unknown devices" without drivers.

Please, help me fix it, I'm sure it's not a hardware issue, but the drivers (or lack of some utilities).

08-07-2014, 05:14 AM
Problem with 3D fixed, everything is fine ;)