PDA

View Full Version : Optimizer recognizes ssds as hard disk drive after 8.1 upgrade



khmergod
01-01-2014, 03:58 AM
Upgraded to 8.1 and my optimizer doesn't recognize ssd raid. What do?

hmscott
01-01-2014, 04:28 AM
Upgraded to 8.1 and my optimizer doesn't recognize ssd raid. What do?

Start a cmd shell as Administrator:

C:\WINDOWS\system32>winsat disk
Windows System Assessment Tool
> Running: Feature Enumeration ''
> Run Time 00:00:00.00
> Running: Storage Assessment '-ran -read -n 1'
> Run Time 00:00:00.19
> Running: Storage Assessment '-seq -read -n 1'
> Run Time 00:00:02.67
> Running: Storage Assessment '-seq -write -drive C:'
> Run Time 00:00:02.39
> Running: Storage Assessment '-flush -drive C: -seq'
> Run Time 00:00:00.97
> Running: Storage Assessment '-flush -drive C: -ran'
> Run Time 00:00:01.03
> Disk Random 16.0 Read 264.56 MB/s 8.0
> Disk Sequential 64.0 Read 876.00 MB/s 8.4
> Disk Sequential 64.0 Write 460.86 MB/s 8.1
> Average Read Time with Sequential Writes 0.419 ms 8.2
> Latency: 95th Percentile 2.081 ms 7.6
> Latency: Maximum 15.499 ms 7.9
> Average Read Time with Random Writes 0.382 ms 8.7
> Total Run Time 00:00:07.63

C:\WINDOWS\system32>

Then try optimizer again :)

khmergod
01-02-2014, 04:44 PM
Start a cmd shell as Administrator:

C:\WINDOWS\system32>winsat disk
Windows System Assessment Tool
> Running: Feature Enumeration ''
> Run Time 00:00:00.00
> Running: Storage Assessment '-ran -read -n 1'
> Run Time 00:00:00.19
> Running: Storage Assessment '-seq -read -n 1'
> Run Time 00:00:02.67
> Running: Storage Assessment '-seq -write -drive C:'
> Run Time 00:00:02.39
> Running: Storage Assessment '-flush -drive C: -seq'
> Run Time 00:00:00.97
> Running: Storage Assessment '-flush -drive C: -ran'
> Run Time 00:00:01.03
> Disk Random 16.0 Read 264.56 MB/s 8.0
> Disk Sequential 64.0 Read 876.00 MB/s 8.4
> Disk Sequential 64.0 Write 460.86 MB/s 8.1
> Average Read Time with Sequential Writes 0.419 ms 8.2
> Latency: 95th Percentile 2.081 ms 7.6
> Latency: Maximum 15.499 ms 7.9
> Average Read Time with Random Writes 0.382 ms 8.7
> Total Run Time 00:00:07.63

C:\WINDOWS\system32>

Then try optimizer again :)

thanks bro. that worked pretty well. except my recovery partion can not be optimized anymore, but everything else is good.

hmscott
01-03-2014, 05:52 AM
Glad it work, don't know why, it was found accidentally by someone at some point, and passed on since. You would think there would be an actual command directed at setting the state, but so far noone has reported one.

The recovery partition shouldn't need optimization, unless you are participating in OS Recovery Competitions ;)

khmergod
01-03-2014, 04:37 PM
Glad it work, don't know why, it was found accidentally by someone at some point, and passed on since. You would think there would be an actual command directed at setting the state, but so far noone has reported one.

The recovery partition shouldn't need optimization, unless you are participating in OS Recovery Competitions ;)

lol ok ok. It's just that i'm very anal about everything. All of my partitions except the recovery one is "optimized since date xx/xx/xxxx. They are all the same except that recovery partition drive that won't "optimize". Not a big deal. I appreciate your help as always.