PDA

View Full Version : G73Jh not booting



c4an1d3
01-02-2014, 04:11 PM
I own a standard G73Jh with only RAM upgrade to 10 GB. Recently, I've been having alot of problems with it. Firstly, with the processor overheating and secondly with the flickering, horizontal lines, dead pixels and even messed up colors of the display. I also noticed that there was less air leaving the cooler fans. In one of the forums i read that the display problem may be due to the cable being either faulty or improperly connected. So, i decided to check the connections and also clean up the inside of the notebook. I followed the official disassembly guide from Asus. I didn't have any problems with the disassembling. I went all the way to the bottom of the motherboard and thought about checking out the processor. Didn't have any problems there either. But when i put everything back together and powered it on, it was a disaster! All the lights, including NUM and CAPS, were on. The display was completely dead. After a while the fans would start with full speed and nothing else happens. The battery indicator work fine. If i press and hold the power button when running on battery, the notebook turns off. But when the charger is connected, it powers on by itself. If i press and hold the power button, the notebook keeps restarting and the fans even stop working. I noticed that the hard disk is not accessed and the wlan indicator stays off.
And, FYI, i never touched the internal battery of the motherboard.
It would be really great if anyone could help me out with the problem. I desperately need the notebook to work.

Pitcher@asus
01-03-2014, 02:51 AM
please check your dissaamebly are correct and all spare part is not break, damage or crush when you install back.

c4an1d3
01-05-2014, 05:48 PM
Can you tell me what the possible reasons of this problem might be?