View Full Version : www.asus.com - problems with drivers download page

01-02-2014, 06:05 PM

I'm trying to open Asus's driver download page, but i cannot get it to work since Asus changed the site layout.
I know that Asus's site is slow and unresponsive as hell, but this is just ridiclius.

I was wondering if anyone else is experience similar problems.
I tried different browsers in my laptop, I tried different laptop, desktop and even a phone, and the problem still persists.

When i go to the site, it loads slowly. I click on support, and it opens the page slowly, i write g750jx in search bar, and it opens the page. Everything works to this point. Then i click on "Please select OS" bar, and it does not open the list from wich u could choose OS type (win 8.1 64bit).

I will paste some screenshoots...


01-02-2014, 06:18 PM
it's not only you. it has been messed up and buggy and slow since the release of Windows 8.1 in October.

Worst Driver Support Team = ASUS Drivers Team

I posted a thread on these forums complaining that the Win 8.1 Drivers are not complete and empty since 2 months and so far only the G750JW got the drivers and they're not full yet. still missing the updated virtual camera and LifeFrame and many other things

01-02-2014, 08:54 PM
Have been seeing the same thing for the past few weeks.

Might be due to the holiday season and people updating all their shiny new ASUS toys?

01-02-2014, 11:55 PM
i have windows 8 and i have been experiencing the same problems..pages load very slow and then recently i noticed driver download page doesnt work i mean when you click the drop down arrow it won't open..i tried everything else too different laptops browsers etc. doesn't work..don't they give a crap about their website?

01-03-2014, 05:34 AM
As I mentioned a few postings before, the error goes away if you keep trying, wait a few minutes if you get frustrated. Sometimes, like right now, it all just came right up cleanly the first time :)


01-03-2014, 10:18 AM
Strange thing is that if i use the link that hmscott posted, and change the model to JX the page loads with no problems.

Then i went to the page by google search, and it wont load, i have opend both pages in separate Chrome windows, the one that hmscott posted works and google search does not!

I wil post the working link if anyone needs it:

Maybe there is probems with differnet pages. Im from EU, and i think that the EU site isnt working, and the site that hmscott posted is from USA... Just a tought... I think this cause looking at the site form hmscoot clearly look different than mine...

Thx for the link hmscoot!