View Full Version : The Wicked Bluetooth Problem. I need help!

01-03-2014, 11:26 AM
First off, I'm sorry if this issue has come to a timely end and I'm just dredging up old stuff. I've spent the last couple of hours, scouring forums, google, etc. trying to find a solution to the issue I'm having.

Here's the details I believe you'll need to help me out::

Asus Model - G74SX-TS71
Windows 7 Home Premium SP 1


Atheros Bluetooth Bus - Date: 7/20/2011 . Version:

Bluetooth Module - Date: 9/27/2011 . Version:

Microsoft Bluetooth Enumerator - Date: 6/21/2006 . Version: 6.1.7601.17889

Qualcomm Atheros AR9002WB-1NG Wireless Network Adapter - Date: 7/24/2012 . Version:

Okay, now here's the problem in full.
I purchased this laptop a few years back. I can't remember if I purchased the "Optional" Bluetooth Built-In. I'm not tech savvy enough to figure out how to check this.

I've had no reason to use the BT function until recently as I've gotten back into MMO gaming and we like to use Ventrillo. I have a Blue Ant VT headset that I purchased for my Galaxy S3 and decided that I'd like to use it for comms in Ventrillo.
While attempting to pair the device, my laptop never found it. So began my hunt to fix the problem.

I've downloaded and upgraded every driver and software I've found that people have posted to be the problem for them. It hasn't solved my issue though. Mine still only states "Searching for device...."

I've turned my PC on to BE discovered and my phone found it easily, but it won't pair to it.

I've also gone into "Services > Bluetooth Services" and made sure it was Start and on Automatic. I've also tried the FN + F2 and toggled the Bluetooth on. (Doing this turns my wireless internet off, in case this helps.)

So, before I; Uninstall/Reinstall everything, download more stuff, or give up and buy an unnecessary dongle, I ask you more tech savvy people, can you help me?

Myk SilentShadow
01-03-2014, 01:18 PM
Hello there and welcome to the ROG Forums. Have you tried renaming the Bth.inf(found in C:\Windows\inf) file to BTH.bak and then installed your drivers again?

01-03-2014, 08:05 PM
This is a new one. I'll uninstall all the drivers and do this. Will update with the outcome.

01-03-2014, 08:50 PM

This was the outcome. As you can see, the driver is now unknown device. The driver I installed was directly from the Asus site at this link: http://support.asus.com/download.aspx?SLanguage=en&m=G74Sx&p=3&s=336&os=30&hashedid=LUFmeP8fwFruEdH7

Under Bluetooth, I installed the Atheros selection.

01-03-2014, 10:08 PM
I deleted the .bak file and placed the ini back. I then uninstalled the drivers and installed the Azurewave option from the link in my above response. This is what I've gotten now and it makes me believe that I do in fact have bluetooth built in.


I attempted to pair my Blueant T1 headset and the pc still did not find the device to pair. So, I still have the Peripheral drivers that are unknown. There are a lot of people that state they have the solution, but I'd rather wait here before doing anything to these 2 drivers.

When I try to update the drivers it states that "Windows could not find the software."

01-05-2014, 09:50 PM
Bump. Still haven't figured out a solution to this problem.

01-07-2014, 06:25 AM
Come on someone. This issue has got to be solvable, right? The unknown devices state that the software is missing. So is this telling me that I need to find an install disk for the Blueant T1 or does this mean that I just need to manually find a software that's on my PC already?

I've seen numerous posts/guides/how-to's on solving the peripherals, but they all involve creating more Ports (COM & LPT). I don't know if this is the correct course.

01-08-2014, 03:57 AM
I had a similar problem trying to pair to blue tooth speakers. I fixed it by downloading the bluetooth drivers from toshiba drivers not the atheros, asus or windows ones. There was a problem that when trying to pair the laptop and the speakers there needed to be a security passscode entered which Windows doesn't give an option to enter it. It might be the same problem. It was caused by Windows 7 software rather than the drivers.

I'll try to find the link and post here for you where i found the solution.

hope this helps.

01-08-2014, 04:26 AM
actually it wasn't toshiba (that was to get windows 7 for a wireles ac card I bought before intel had released the drivers for it!).

It was the broadcom package here - http://www.broadcom.com/support/bluetooth/update.php

this is thanks to chigwell who posted the solution on the windows 7 forum:

01-08-2014, 11:34 AM
After reading the provided article, I gotta say that this isn't the issue I'm having. I will give the Broadcom drivers a try, because at this point, it won't hurt to try. Will post an update after installation and testing.

01-09-2014, 04:24 AM
Good luck.
It sounded like the same issue with my speakers just that you were looking for to connect headset.

01-24-2014, 11:31 AM
Installed the Broadcom drivers from post/reply above. Did not work. But, I believe I have found the problem. Not sure if it will work, but I recall when first getting PC, I attempted to connect my phone via bluetooth. The PC picked it up and installed the drivers, but nothing ever came from that. One of the drivers was the Atheros Bus or Atheros Bluetooth Bus. Can't recall from the top of my head.

Going to uninstall everything related to bluetooth and pop in the driver CD that came with laptop. From there, I'll try the appropriate drivers from the so many recommended.

If this doesn't work, then I'm just buying an ASUS bluetooth dongle for 20 bucks and calling it a day.

01-24-2014, 01:46 PM
I agree it is a driver problem. I also think Windows fubared your driver at some point. Uninstall all BT drivers (in Device manager and Programs if there.) reboot. Re-install Asus BT driver. reboot. Let us know.. :) I had the same problem with mine. Worked fine, then all of a sudden errors in Device manager and in Printers/Devices. The re-installation DID fix it. I'm careful not to let Windows update those drivers.