PDA

View Full Version : Picked up Crysis, getting screen tearing. :c



Darnassus
01-14-2014, 04:17 AM
Me again,

I have a Chi Mei screen

770m NVidia ( DRIVER VERSION: 311.82 )

Playing Crysis on ... MAXIMUM SETTINGS! (lol)

And I get horizontal screen tearing.

Is there a way to fix this? Or is this Chi Mei again / Nvidia driver?

Any thoughts / recommendation.

cronik916
01-14-2014, 07:13 AM
u need to cap the frames per second the game renders at at like 59.4 if your resolution is 60hz. should fix it. or use 3d controlled settings in nvidia control panel to force vsync on. trust me i cant deal with that **** either so this is what i do if the ingame vsync wont actually do what its supposed to. cheers

Darnassus
01-14-2014, 09:57 AM
u need to cap the frames per second the game renders at at like 59.4 if your resolution is 60hz. should fix it. or use 3d controlled settings in nvidia control panel to force vsync on. trust me i cant deal with that **** either so this is what i do if the ingame vsync wont actually do what its supposed to. cheers

Yep I figured it out myself. But I didn't think it was JUST Vsync, I also threw on tripple buffering.

ZiggZagg
01-15-2014, 05:46 AM
Darnassus... hello. I felt (after reading the above posts) as if I should chime in and tell you how my machine is working which is perfectly. A lot of what I've read on this and other forums about the g750 laptops is that many folks would swear that a certain 'brick&mortar" retailer which shall remain nameless is selling "lesser quality" machines so as to facilitate lower competitive selling prices. I understand this to mean that the laptops passed muster at the factory but barely.
I bought my 750jx online from a retailer that has been selling ASUS machines of all configurations for some years. They did any upgrades I wanted, did a burn-in and loaded/removed pertinent/unneeded bloatware. I waited for nearly a month for it to be delivered but it was worth it.
Every game I've loaded on it works great and all at ULTRA or MAX settings; these include Crysis 3, Metro "last light", skyrim and believe it or not EGOSOFT'S X3 Rebirth. The only alterations I made were to add a WD 1tb 7200 rpm SATAIII Black HDD in my second bay and filled up my fourth RAM slot with an 8GB stick to round up to 20gb. Everything is working with no glitches which really does make me wonder why there are so many discrepancies/complaints about these laptops............................I almost bought from the nameless B&M I mentioned above. Man I'm so happy I didn't.
I'm sorry to read about the difficulties many seem to be having. ROG is good....ROG is wise.

ZZ

PS- My laptop came with an AU Optronics screen and not a CHI MEI. It does seem at times ASUS does play a little hopscotch to find suppliers that can keep up with their demand. My machine according to AIDA64 Extreme software I use was manufactured 8-19-13 so I don't get the difference in screen brands???

ZZ

Nate152
01-15-2014, 08:20 AM
Crysis came out in 2007 and I think it still looks as good as a lot of the new games today. The shaders setting really puts a hit on performance. 311.82 is a pretty old driver. Go to Nvidia.com and download the latest driver 332.21. It is WHQL and you should notice a nice performance increase. When installing do a custom install and check the only box that says perform a clean installation. My favorite part of that game is shooting down the helicopters and on the ship at the end.

ShadyStan
01-15-2014, 02:56 PM
Hello Darnassus,

I've got a G75VX (with a GTX 670MX graphics card) with Crysis 1 as well as other games installed on it but I get zero screen tearing. In order to be able to play it fully maxed out with 16xq anti aliasing (I get an average of 30 fps) I’ve done the following:
- Overclocked my GPU with MSI Afterburner (+135/+1000). I don't know if the 700 series graphics cards can be overclocked manually though.
- The game is installed on my SSD but as far as I know that makes for faster loading times and doesn’t boost fps;
- Installed the latest WHQL graphics driver directly from the Nvidia site;
- In the Nvidia Control Panel I’ve set the Power Management Mode to “Prefer maximum performance” but haven't touched V-sync or Triple buffering as I use the in-game V-sync option. So are you sure you have installed the latest Crysis 1 updates - patch 1.2 and hotfix 1.2.1 ?
I’m not sure whether I have to adjust “Maximum pre-rendered frames” for Crysis 1 but let someone more informed say what they think about it. For now it is at the default value.
Of course my laptop is always plugged in and always use Power4Gear High Performance when playing games.
Although the game feels a bit heavy in some situations, with these settings it is perfectly playable fully maxed out except for most of the battles in Reckoning Part 3 (towards the very end of the game) where I had to turn anti-aliasing off so that I could get playable fps.
I always play Crysis 1 in the 64-bit mode with DirectX 10 enabled. I think Crysis 1 doesn't support DirectX 11.