PDA

View Full Version : G73sw screen/artifact issue - Help needed :)



kafufle
09-18-2011, 01:02 AM
So i've had my G73sw for a couple of months now and i've noticed that after about 10 minutes of playing some games (Halo 2, Half Life 2 LC, Need For Speed World, got it in Bioshock too once) that the screen goes all haywire and anything that is black turns into these red dots/artifacts. I instantly thought when it first happened that my graphics card (GTX 460m) was busted, but when I connect my laptop through to my HD LCD tv via HDMI, the dots/artifacts disappear completely on the TV. Yet they are still all over the laptop screen.

Here a picture of what my laptop screen looks like.
http://imageshack.us/photo/my-images/825/18092011673.jpg/
So im not sure whether it's a overheating issue, or a faulty screen but any advice would be greatly appreciated :D

Also, sometimes if the screen goes red, if i just move the screen up and down or hold in a position the dots go away, but as soon as i let go, they come back...

So yeah, if anyone has any clue what the issue is, please let me know :)

dstrakele
09-18-2011, 03:36 AM
Sounds like you're overheating. You could check the GPU temp with RealTemp or SpeedFan and if this is the case, follow instructions in the sticky thread on overheating:

http://www.asusrog.com/forums/showthread.php?946-G73JH-GPU-Overheating-Observations-and-Suggestions-(Read-This-First)

Good Luck!

Chastity@ASUS
09-18-2011, 08:50 AM
I would hazard to say that the controller on the lcd panel may be going, usually a precursor to getting a PSOD or your LCDV cable has gotten loose a bit. I would RMA it to have a tech check it. You can use a local ASP site if you want.