PDA

View Full Version : G74SX + Steelseries Xai Mouse = Boot issue during bios stage



Zackarak
09-18-2011, 02:06 PM
Hi,

When I have the Steelseries Xai Mouse plugged in. The laptop takes forever to pass the BIOS stage where you see the Asus Logo. The G73SW had the same issue.

Unplugging the mouse and plug it in after windows is loaded works but it's a hassle. Disable USB legacy fixes this but then no USB accessories will work in BIOS.

This issue is appearently a known issue http://faq.steelseries.com/questions/166/My+computer+gets+stuck+at+BIOS+stage+during+the+bo ot+for+a+few+minutes+when+the+Xai+is+connected.

So maybe Chastity can speak with the ASUS people so they can look for a fix in a future BIOS update?

Chastity@ASUS
09-18-2011, 08:30 PM
No offense, but after reading their page, and how it's prevalent over multiple manufacturers' products, I would hazard to say that maybe the XAI mouse is not being 100% compliant, and needs a firmware update. I'll forward the issue to Gary, tho. :)

Zackarak
09-18-2011, 10:51 PM
No offense, but after reading their page, and how it's prevalent over multiple manufacturers' products, I would hazard to say that maybe the XAI mouse is not being 100% compliant, and needs a firmware update. I'll forward the issue to Gary, tho. :)

Thanks!
It seems to boot up faster by using the USB 3.0. Using any other USB port would result in a freeze at the bios stage for about a minute. Using USB 3.0 the freeze last for about 5-10 seconds.

As of now I'm using the Xai with USB Legacy disabled. Only downside is I can't use my USB keyboard until Windows is loaded.

grungeboy2
09-18-2011, 10:53 PM
Hi,

When I have the Steelseries Xai Mouse plugged in. The laptop takes forever to pass the BIOS stage where you see the Asus Logo. The G73SW had the same issue.

Unplugging the mouse and plug it in after windows is loaded works but it's a hassle. Disable USB legacy fixes this but then no USB accessories will work in BIOS.

This issue is appearently a known issue http://faq.steelseries.com/questions/166/My+computer+gets+stuck+at+BIOS+stage+during+the+bo ot+for+a+few+minutes+when+the+Xai+is+connected.

So maybe Chastity can speak with the ASUS people so they can look for a fix in a future BIOS update?

what usb device would you possibly need to use before the OS boots?

Hideaki
09-19-2011, 08:39 AM
Somewhat related, is there any way to tell the BIOS not to try booting from an external (USB) HDD since that adds an unnecessary 30 seconds to boot time?

Chastity@ASUS
09-20-2011, 02:43 AM
I spoke to R&D, and apparently the XAI mouse attempts to do BIOS hooks for resources in unorthadox ways, and that's causing the hang issue. Onus would be for XAI to be more compliant instead of everyone modding their BIOS for every model to workaround their methodology.

AKA don't expect a BIOS update on this.

Zackarak
09-20-2011, 05:17 AM
I spoke to R&D, and apparently the XAI mouse attempts to do BIOS hooks for resources in unorthadox ways, and that's causing the hang issue. Onus would be for XAI to be more compliant instead of everyone modding their BIOS for every model to workaround their methodology.

AKA don't expect a BIOS update on this.

Thanks for checking it up.

xeromist
09-22-2011, 07:30 PM
Moved Arhanka's issue to new thread since it is not caused by Xai mouse:
http://www.asusrog.com/forums/showthread.php?4389-G74SX-slow-post-BSOD