PDA

View Full Version : G75 VX Won't Boot (Black Screen)



Atibari
01-23-2014, 04:37 PM
I have this problem going on for some time and it is really annoying. I even sent the laptop the Asus service but they just formatted and send it back so nothing changed.

So the problem is when I press the power button the open the laptop the ROG logo appears then black screen. The lights of hdd etc flashes and fans make noise but no windows log in comes up. In order to turn it up I have to restart it by holding the power button. Sometimes it opens after 1 or 2 restart. Sometimes it doesn't. Also I'm afraid that this hard restart(by power button) is going to harm my hard drives.

I think it is about the nvdia drivers because a fresh formatted state has no problems but since this is a gaming laptop I need the latest drivers. So when I install latest drivers this problem occurs, on every single driver, I just update it as soon a new driver is come out of beta state.

I don't know if it is a driver issue or win8 even some places I read that there was some faulty installation and gpu cables have problems( not sure how certain is tihs it might be a speculation)

As far I can see it is a common thing for G75 laptops, does anyone knows any solution to this or any announcement from ASUS about the nvidia drivers. At this rate one my hard drvies gonna break by resetting 5-6 times a day.

code9523
01-23-2014, 05:21 PM
New drivers from NVidia off site can be not the best way to update! Nvidia says that their drivers are standard drivers for their chip but they may not be optimized for laptops so they can not warranty their stable running. The best way for users is downloading drivers from vendors off sites. For example drivers on asus.com are stable but not to fresh and works fine because they are modified with all specs of laptop. Installing a new version of driver from NVidia.com is a risky way to get new features or productivity but can run not stable!

In your situation you can try to reinstall your os on clean formatted hard drives and try a driver from asus.com or the latest stable driver.

P.S. When you're updating a video driver uninstall all old drivers from NVidia with a registry clean up and set up a clean installation. Do not update drivers by installing them one on one.

Atibari
01-23-2014, 06:40 PM
Thank you for your reply but asus advertise these rog series computers as gaming computers so I think it's not acceptable that these laptops doesn't support latest nvdia drivers but only old and optimised drivers.

code9523
01-23-2014, 07:34 PM
Here it is:

Find Driver for your Application If your application is not listed below or does not have a certified revision of the NVIDIA driver listed, you can either use the certification candidate driver or revert to your OEM/board vendors supported driver. Drivers on nvidia.com do not carry any warranties nor support services. If you would like support, please revert to the driver provided by your OEM or board vendor. - See more at: http://www.nvidia.com/object/quadro-certified-drivers.html#sthash.1lu2SNHg.dpuf

They say it not only for gaming laptops but even for gaming graphic cards which costs like a whole laptop :) They are making silicon chips and they are selling them to vendors and vendors sells them to us... But sincerely no body care about users or updating an old drivers because they are not interested in it! It's significantly more profitable to sell you a new powerful laptop then updating your old one software and let you play another game without paying for it ;)

I'm using the last NVidia driver 332.21from off site in my g55vw with GTX 660m and everything works fine without any problems.
Recipe: Clean installed windows 8.1 and installed latest driver for it.
On my G74SX I do the same but with Win7.

Try to reinstall your os this might help if there is no hardware problems.

Atibari
01-23-2014, 09:48 PM
Driver on my laptops Asus page is version 311 from January 2013. I'm pretty sure I would have serious problems with that old driver.

I also use 332.21 right now and I've been having this problem since August 2013. I always updated to the latest driver which is not a beta since then. I reinstalled it several times, reverted to a working state etc, it always ends up like this if I update my graphics driver. Well at least that's how it seems. I'm upgrading to win8.1 right now, I hope it will do somet

code9523
01-23-2014, 10:12 PM
Try it on win 8.1 I think everything should work fine. Hope it will help if not may be you should try to install windows on second hard drive may be it's problem with it? And the last thing is a BIOS update but its pretty dangerous... At least load optimized defaults in your current bios.