View Full Version : ASUS G75V trackpad suddenly gone haywaire

01-25-2014, 09:30 PM
I have no clue what happened to it. It worked fine last night, but I turned on my laptop this morning and suddenly it's going haywire.I have to click something multiple times for it to click, the cursor insists on highlighting everything, I can't try to switch tabs without the cursor trying to movie it to a new tab, etc..
I've tried multiple things after searching on google. I tried just restarting my laptop, then re-installing the driver (which is synaptics), then performing a system restore, all which have not worked. Not to mention I pretty much know jack squat about laptops. Any help would be much appreciated.

01-26-2014, 03:51 AM
Hi Harumi, Welcome to the ROG community. I'm not sure what the trackpad is but if it is a usb device you could try it in another usb port.

01-26-2014, 07:23 AM
Thanks! The trackpad isn't a usb device, it's part of the laptop. I guess I'm using the wrong terminology, but it's the square below my keyboard that's used to move the cursor and has the two rectangles below for left click and right click. I can't think of anything that would have caused damage to it either.