PDA

View Full Version : G750 Auto contrast is driving me nuts!!



kidfromhell
01-28-2014, 08:55 PM
I guess everyone knows about the issue I'm talking about and we'll proceed.

I have a G750JX-DB71 and I've been facing this issue right from the day I received my laptop. I've done tons of research and still the problem was unsolved. Changed Windows Power Management Settings, NVidia Dynamic Contrast Enhancement Settings, Stopped Sensor services using services.msc, uninstalled Power4Gear Hybrid and changed power plan settings as well. That's it when I switch to battery, this problem starts again. Even now whilst typing this, the contrast has changed causing a pain.

Finally, I did a CLEAN installation of Windows 8.1 and sigh, it's still there. But didn't install P4G and all. I'm with Nvidia driver of 327 I guess. I dunno what to do. Even when switching tabs in Gmail, the contrast changes due to the theme applied.

Finally, I contacted ASUS and they have provided me a RMA. As I'm new to USA, I do have some issues in sending my notebook to them. Issues in the sense, I can't travel to FedEx office carrying this monster packaged in a box. So this is my last try and I've brought the issue again to you guys. If it's possible do help me, or else I have to send it I guess. I dunno how much time will they take to process and send it as my entire studies depends on this one. I can't wait for long. I'm also worried that they might send me a refurbished one if they can't sort this issue out.

Also as I don't have any P4G and such, I begin to guess that I might have got a faulty display. Is it so? Do you guys advice me to go for RMA?

Update: Video added!

https://vimeo.com/87343067

Thanks Pat for the clip!


***** PERMANENT SOLUTION*****

ADVANTAGES:

You'll lose this contrast issue, FOREVER!!!

DISADVANTAGES:

You'll end up using a very old (6 months I guess) NVIDIA Graphics Driver so you might lose out on bugs and patches, performance improvements etc.

STEPS:

1. Go to Asus 750JX driver download page.
2. Select Win 8 x64 for the OS (Not 8.1)
3. Download this VGA driver (NVIDIA Version V9.18.13.1193 - The first one)
4. Install (When installing check custom install and select 'clean install')
5. Reboot
6. And voila, the problem is gone forever.
7. Don't forget to go to GeForce Experience and uncheck all the automatic updates or this sneaky little software might update you to new drivers silently and you'd have to repeat the steps again.


THIS IS THE PERMANENT SOLUTION, FOR NOW UNTIL NVIDIA RECOGNISES THIS AND FIXES IT. SO THIS HAS A FAIR SHARE OF DISADVANTAGES AS WELL!!

Thestroj
01-28-2014, 10:43 PM
Im no expert but try these things first before you go for RMA.

1. Uninstall Splendid...
2. go to "Power Options" - Display - Enable adaptive brightness - sett it to "OFF"
3. Reinstall GPU drivers
4. Reset your color managment profile (system default is (sRGB IEC61966-2.1)
or try to make your own.
(make an seperate account and make changes there first, colour settings are stored separatley for each user!)
You can find very color correct profile in the forums if u search for it...

Before you make any moves with RMA try things above.

The first two steps are almost for sure the thing ure talking about.

Let us know how it goes!

kidfromhell
01-28-2014, 11:04 PM
Thanks for the reply.
1. I haven't installed it at all. (I can't find it in Control Panel so I highly guess that I didn't install it)
2. It's already set to OFF.
3. Re-installed. It prevails.
4. I don't have the idea on what it is. Could you help me out by explaining it in detail?

damiramida
01-28-2014, 11:33 PM
Try this:
Nvidia control panel
Adjust Video colour settings
How do you make colour adjustments?
With Nvidia settings
advanced
dynamic range full (0-255)
uncheck dynamic contrast enhancement and colour enchancement

I had the same problem as you and this resolved my problems.
I hope this will help you.

kidfromhell
01-29-2014, 12:42 AM
Mine is already at Full DR, turned off DCE and CE :)

All my settings are 'Use NVidia...'. All are at default values.

Still.... :(

Darnassus
01-29-2014, 07:40 AM
Splendid's official name is "Asus Splendid" so it's under A at the top of your uninstall list, in case you didn't see it and want to check again.

I think I know what you mean by your adjustment.. I've noticed that my screen when I go to black, to white, it slightly brightens up over 1 second.

Is this what you mean? I think you shouldn't turn it off as I have a feeling it's healthy for your monitor in terms of color transition. That's my own little theory on it though.

How exactly does it annoy you? Does it change drastically when doing nothing?

kidfromhell
01-29-2014, 02:21 PM
No, it's not there. I've double checked it :)

Yeah, that's it. The same problem. When am in ROG forums it turns dark as hell, and when moving to Google it's whiter. I'm not mentioning it as a problem, but it's kinda irritating when you see the color transition. When watching movies, it turns black as the file is about to open, and it's good when the playback starts and again turns dim when there's dark scenes or screen goes black for a minute.

How come they implement a service without being able to stop it? That's what irritates me. As already told, I've done everything. The last resort I could do is to uninstall Nvidia driver completely. Maybe that'll stop it I guess because it's the only piece of display related program in my notebook. Sigh :( If I do that, then becomes a bulky ultrabook/netbook without being able to play games! :D

tugrul
01-29-2014, 06:05 PM
i know excatly what you feel. At the beggining i started with uninstaling the spelndid, hoping to end this auto contrast thing. Especiall
while watching films color pallet at human faces really irritating. İt doesnt seem natural while under this effect. U can try this like watch films
with fullscreen with borders and after that do it fullscrren with borderless. U can see the diffrences on human skins color adaptation and its not nice.

kidfromhell
01-29-2014, 11:39 PM
Exactly. I feel the same as well. It's really a pain. Did you get rid of it?

Thestroj
01-30-2014, 08:03 PM
To check if you have ASUS SPLENDID installed go under C or D drive (most likley the one with the OS on it) go under program files and then under asus folder and try to search for asus splendid!

If u cant find it, then go crazy and install it and the uninstall it... LOL it might help....

For the color managment go under Control Panel - Color Managment - An then try to play or DL the color profile from this forrum and apply it. Under the forums post u will find all the instructions to do that!

The way u described the problem its ASUS Splendid for sure.
Did u already uninnstall it?

It was installed in your laptop for sure, all g750's come with loads of stupid bloatware. So if u didnt remove it it must be there.

try this and report back...


Here is the link for the color profile. Before u do anything READ THE POST AND ALL THE LINKS. DO YOUR RESEARCH!

http://rog.asus.com/forum/showthread.php?36153-Personal-Color-Profile-for-the-Chi-Mei-173HGE&highlight=color+profile

Then make a new account and make the changes there first. And if u see what u like then do it on your main account!

kidfromhell
02-01-2014, 01:32 AM
I don't have it :) Lol :D

I've already mentioned that I did a clean install of 8.1, so I am damn sure that I didn't install it.

I tried the color profiles and only the colors look great. The problem still persists. I guess it has nothing to do with Auto Contrast.

Thanx for the info, skeptical on whether to send this for RMA or not!! Tried everything I could find.

Darnassus
02-01-2014, 01:49 AM
It's funny, the volume control kind of does the same as the screen, it sort of.. 'auto / slow' transitions.

Thestroj
02-01-2014, 10:49 AM
I was wondering.

Kidfromhell did u install all the drivers from ASUS support site for you model. U might wanna try...
Or try to reinstall windows, or maybe try to use the recovery option if u did make one before doing an clean install...

Dunno m8, would love to help but realy dont know what you could do!
Did u try to delete P4G? try it... u mentioned that u made new power profiles already...

Maybe try to install Splendid and see what will happen...
Hope u solve the issue, about RMA, nut sure...

Take care

kidfromhell
02-01-2014, 05:13 PM
:D I'll explain what I did :)

I did a clean install of 8.1 from the T*** forum by following their entire tutorial. They have provided the drivers as well in their webpage. So I used them to install and not from ASUS page. I almost installed all the drivers from them except the graphics alone. I directly downloaded from NVIDIA page and installed. And also, I left all the ASUS related video related drivers (Splendid, Color Patch, P4G) so I DONT have them. The only ASUS drivers I have is USB Charger Plus, Virtual Camera and ATK. So based on your above post, I tried installing Splendid. But the one in JW page is updated, so I downloaded from there and installed it. It made the issue worse. So uninstalled it as you said. Still my problem persists.

I suddenly thought of installing NVIDIA drivers from ASUS site, so went ahead and installed from there. It's 311 version. After installing (clean install), rebooted and the PROBLEM WAS GONE!!! I knew it already. Now tried installing 334 Beta (not clean) and the problem came again. Rebooted and again installed 311 (clean), the problem was gone. But now installed 334 (clean) and again the problem came. So this is certainly with recent drivers from NVIDIA. 311 is much older, I dunno if I can stay with that!!

kidfromhell
02-01-2014, 05:19 PM
Now installed P4G from JW page, nothing changed!

kidfromhell
02-04-2014, 12:43 AM
I was wondering.

Kidfromhell did u install all the drivers from ASUS support site for you model. U might wanna try...
Or try to reinstall windows, or maybe try to use the recovery option if u did make one before doing an clean install...

Dunno m8, would love to help but realy dont know what you could do!
Did u try to delete P4G? try it... u mentioned that u made new power profiles already...

Maybe try to install Splendid and see what will happen...
Hope u solve the issue, about RMA, nut sure...

Take care

I guess you got it!! :)

Darnassus
02-04-2014, 05:34 AM
P4G? What's that? And oh my god the brightness is driving me nuts now, too.

Darnassus
02-04-2014, 05:52 AM
Ah Power 4 Gaming.

kidfromhell
02-04-2014, 02:05 PM
P4G? What's that? And oh my god the brightness is driving me nuts now, too.

Power4Gear :D :)

Darnassus
02-05-2014, 09:14 AM
Any fix yet? It's actually really severe. ':f

kidfromhell
02-05-2014, 02:33 PM
Any fix yet? It's actually really severe. ':f

Yeah, here as well. Other than reverting to old NVIDIA drivers, there's no other way I guess :(

I'm skeptical to send this for RMA. Dunno what to do!

Darnassus
02-06-2014, 01:13 PM
Seems to go away if you go to NVidia panel > Adjust Desktop Color Settings then click "Use NVidia Settings" then change back.

kidfromhell
02-06-2014, 01:57 PM
Seems to go away if you go to NVidia panel > Adjust Desktop Color Settings then click "Use NVidia Settings" then change back.

I tried everything, it's of no use.

But now, IT'S GONE!!!

I'll tell you what I did. I'm using the latest beta drivers. I installed P4G and uninstalled it. Did a restart as well. Still the problem was there. I lost hope.

Suddenly, I thought of decreasing my system's start-up time, so dived into Task Manager and reviewed the start-up items. There was a process named igfxpers.exe and there was no description of the service. So googled it and found that it was related to Graphics and disabling it won't cause any problems and also it'll use much memory it seems. So went ahead and disabled it. I wanted to know if the system worked properly after disabling the service, so restarted and Whoa, the problem is gone. Damn happy :) I'll change the thread and title after testing it for a day or two :)

Thestroj
02-06-2014, 05:12 PM
I had the same problem... i just unninstalled splendid and P4G, and the Nvidia drivers, and power profiles... and the problem went away...
I used a program for uninstaling all the drivers cause uninstalling from control panel didnt help...
I think the program i used was DRIVER FUSION... but not sure...
Something in my gut tells me that this auto contrast is linked with Splendid, P4G (power profile and Nvidia drives... maybe with all three together.. ASUS programs did some funky **** on my laptop... then i got rid of them all... :D

This is gonna sound funny, but i had HP laptop before, with wich i didnt have ANY PROBLEM AT ALL.
G750 realy is a beast, but there are thos small thing that ruin it for me... :(

Now im running the latest drivers with no problems at all...

tugrul
02-06-2014, 07:14 PM
I had the same problem... i just unninstalled splendid and P4G, and the Nvidia drivers, and power profiles... and the problem went away...
I used a program for uninstaling all the drivers cause uninstalling from control panel didnt help...
I think the program i used was DRIVER FUSION... but not sure...
Something in my gut tells me that this auto contrast is linked with Splendid, P4G (power profile and Nvidia drives... maybe with all three together.. ASUS programs did some funky **** on my laptop... then i got rid of them all... :D

This is gonna sound funny, but i had HP laptop before, with wich i didnt have ANY PROBLEM AT ALL.
G750 realy is a beast, but there are thos small thing that ruin it for me... :(

Now im running the latest drivers with no problems at all...

what i "P4G" no idea. U seem like installed like a clean win 8. Not with garbage Asus utilities. huh?

Edit by cl-Albert: "P4G" is the ASUS Power4 Gear utility.

PatRaven
02-06-2014, 07:42 PM
A few more steps forward… I too have the same problem. I bought the G750 in early December and basically I regret buying it from day two (I didn’t notice the problem the very first day due to excitement). Everything is fine as long as you are connected via the AC adapter. Disconnected running on batteries only, you get this weird behavior of dimming the screen when it’s dark and vice versa when there are bright images on the screen. I do not like it at all...

- It does not work with any of the Energy saving setting as recommended by some.
- I have tied several drivers but nothing helps.
- I have tried all recommendations regarding the settings under the Nvidia configuration…
- I have tried to stop the 3Dvision services some mention will fix the problem.
- I have uninstalled Splendid, Re-installed Splendid and uninstalled it again trying all sorts of settings
- The same with Power 4 Gaming… Everything!
- Tried the Color profile trick some mention. No luck!
- Nothing helps!

Currently I am on 327.23 due to that it removes some flickering in dark grey areas =)

Anyway I was sooo tired about it so I have simply tried to forget about even using it running on batteries for more than just surfing the web.
But then I run into this post, which didn’t really give any further clues. But it made me go into a new search for some answers. I run into a post saying that on some models you could turn off the Ambient Light Sensor by pressing Fn + A. It didn’t help since it doesn’t seem to be valid for the G750. So I played around with the Brightness Fn + F5-F6, The backlit keyboard Fn F3-F4, The turn off screen Fn+F7 and some other buttons. Suddenly the problem was gone! What!? Yeah so I tried to understand what I did but couldn’t figure it out. I turned off the computer and the problem re-appeared. Hmmmm… I tried some combinations and the problem was gone again. At one point I couldn’t even solve the problem, so I thought I was out of luck again. But I am quite stubborn so I was on it today again. And listen carefully. Only press Fn+F7 which makes the screen turn off and dim down the backlit keyboard. When it’s completely black press Fn+F7 again to turn it on. The problem with the screens auto contrast is gone. For me it’s totally gone! Until today! FxxK! Hmmm but pressing the Fn+F7 + some other combinations fixes the problem after some trial and error. But it re-appears if you turn off the computer.

So I tried inactivating igfxpers.exe mentioned today. Nope! Does not help me =/

I hope my findings with the function keys might help some of you and maybe help us all come to a final resolution to the problem.

Peace // Pat!

CruiserX
02-07-2014, 06:05 AM
Fn+F7 adds more blue to it.. Makes it worse!! :(
My suggestion is uninstall all Asus bloatware then install new drivers and use NVidia color profile setting...

Thestroj
02-07-2014, 03:30 PM
Just a thought...

Try uninstalling/reinstalling/different verison ATK Package related programs...
When uninstalling programs or drivers use third party programs to get rid of them completley...

I wish someone wih more knowledge would look into it...

READ THIS:
What is ATK Package?
This package installs the software ATK Hotkey Driver and other ASUS drivers and software with various laptop models. It is pre-installed with new laptops and required to run various optional functionality. It is a set of utilities that will enable the functions of the button Fn on your keyboard. ATK packages are bundles of ASUS utility/driver software.

This utility enables the PC to communicate with all the attached hardware devices. ACPI will power-down the CD/DVD drive when not in use and also manages configuration settings such as defining hot-keys and more complex tasks like 3D graphics and overclocking without hardware modification.

Included unities are for the following functionality:
- Hotkey
- TouchPad
- Ambient Light Sensor
- Keyboard Ligh
- On-Screen Display

ATK is derived from ASUS’s official company name, ASUSTeK Computer Inc.

Copied and pasted from:
http://www.shouldiremoveit.com/ATK-Package-5811-program.aspx

PatRaven
02-07-2014, 04:00 PM
CruiserX mentions NVidia color profile setting etc. Does not work for me! By the way Fn+F7 does not do anyhting regarding the actual colors besides disabling the fading.

Additionally I now unistalled the ATK package. Does not work for me either...
Now my Fn+F7 method does not work either due to that the ATK package includes the Fn keys...
I will install the latest ATk and see what happens... I'll be back

Br,
Pat!

PatRaven
02-08-2014, 08:54 AM
I was on ATKPackage_Win81_64_VER100030. Uninstalled! No change!
Installed ATKPackage_Win81_64_VER100031. No change! Unistalled!
Installed ATKPackage_ASUS_Win7_8_VER100026. No change besides that the method using Fn+F7 works again (not every time but most often)...

kidfromhell
02-10-2014, 02:15 PM
Nothing works. Uninstalled everything. If the graphics driver is uninstalled or downgraded to 311 (The one in JX page), then it's solved. Even stopping the service was just a temporary solution. One time it's gone then reappears the next restart. It's gone whilst am typing this maybe after a restart it' may come again.

No permanent solution is available until now. Uninstalled everything. Only Win 8.1 is left, maybe if I delete that too it might go I guess. I dunno what is ASUS actually thinking. Sending it for a RMA doesn't help I guess. I may end with a refurbished laptop. So I'll better stick to this for now. This is my first ASUS and gaming notebook I ever bought and this display gives me a pain :(

KoolASUS
02-10-2014, 10:36 PM
i had that too, but it disappeared when i uninstalled power4gear. i am on "normal" Windows power settings.
btw, i'm still on stock 311.83 drivers.

tugrul
02-12-2014, 04:08 PM
a lot of ppl suffering this auto contrast thing including me. Why the hell no official answers here for the solutions. People used desktop pc years do not want a screen like this. We dont want auto contrast and wana disable it. Asus should answer our questions and solve it. We are trying to be a fortune teller here. İ tried many thing even deleted my factory win 8 and installed clean 8.1.. Where are you asus.

Darnassus
02-13-2014, 02:28 PM
Nut sure why but I'm not getting it anymore. It's weird.

Thestroj
02-13-2014, 06:57 PM
Seems like G750 series are possesed with a strange dispay malfunction ghost of type 1...

Time to call ghost busters!

noone
02-14-2014, 05:23 AM
Firmware version?

PatRaven
02-14-2014, 04:38 PM
I am runnig 208. I can see that there´s a 209 version but it just says "Fix WHQL issue for win 8.1", whats that?

By the way my trick mention before using Fn+F7 doesnt work anymore either =/ But thats no big problem. The BIG problem is that I simply want this idiotic Autobrightness to stop once and for all and I cant. Does anybody really like that feature? ASUS, where are you?

Skat137321
02-14-2014, 05:00 PM
ASUS is too busy working on Win 8.1 drivers for G750JX/JH

The autobrightness thing has a mind of it's own. It only works when it feels like, I can't understand and it really makes me want to sell this thing if the problem doesn't get sorted :/

tugrul
02-17-2014, 01:22 PM
there is a settings at the power options about adaptive brightness but even i disabled it there is no changed with this crap monitor effect.

PatRaven
02-18-2014, 08:14 PM
Is the ambient ligth sensor a hardware thing or is is just software only controlled? If its hardware, does somebody know where is the sensor actually located? I tried covering the camera but no chnge there at least... No change covering the power button either =)))

kidfromhell
02-19-2014, 11:43 PM
Is the ambient ligth sensor a hardware thing or is is just software only controlled? If its hardware, does somebody know where is the sensor actually located? I tried covering the camera but no chnge there at least... No change covering the power button either =)))

I guess it's software controlled! If it were hardware, then Asus have screwed us perfectly. We guys have tried everything. I see no proper solution for this. This display is one of the worst due to this.

cl-Albert
02-20-2014, 12:28 AM
Is the ambient light sensor a hardware thing or is is just software only controlled? If its hardware, does somebody know where is the sensor actually located? I tried covering the camera but no chnge there at least... No change covering the power button either =)))

Still trying to understand this issue, but as far as I know, the G750 notebooks don't use an ambient light sensor since you can only brighten or dim the keyboard light manually.

Was thinking one way to check for the presence of an ambient light sensor is to check the (screen?) brightness before you turn off the lights and check the brightness again (using Fn+F5/F6 or other ways to see the brightness level?) to see if it changes and responds to ambient light?

Not sure if this problem only occurs on certain models or configurations, but don't notice it on my G750JW test unit, so trying to get more information as below.
Feel free to ignore or respond to whatever you like and whomever you like if you're hoping to work with others.

1. It's probably a bit overkill, but there's a support template for people to fill out at this thread if anybody is interested, and feel free to skip any unnecessary items although I'd like to get at least the model and find out if you are still using the ASUS Win8 image:
http://rog.asus.com/forum/showthread.php?43595-Support-Template-please-fill-this-out-when-reporting-a-bug-or-issue!&country=&status=

2. It's not clear to me what is meant by 'auto contrast', so hoping to get some clarification for this, but wondering if everybody is referring to the display brightness level changing which can normally be done using the Fn+F5/F6 keys?
Also, just want to make sure nobody is referring to the flickering screen issue which has been discussed before, or else we can dig up those old threads.

3. We might discuss this in a separate thread if necessary, but there are settings to change the screen brightness when switching Power4 Gear modes or between either battery and AC, so feel free to start a new thread to discuss this issue (assuming it's different from this issue?) if interested.

4. If there is a video posted with the problem or anybody can post one, it's a good idea so we can be sure we're all talking about the same problem.

5. Sorry if it sounds like I'm minimizing the problem, but for the people who see the issue, does it seem like something everybody would complain about this problem if they had it, or it's something some people may just 'live with'?
Basically, just trying to get an idea if all or many of the G750 units are having this problem and if not, what is different about those units that have the problem.

Well, hopefully we can solve it whatever the situation is and others will have better ideas if I don't have the solution.
If anybody wants to 'work on it', I'm happy to look into it more at least, but for those that want to work with their local ASUS service center or send in the unit, this is another option to consider since some problems can be more easily solved when our repair department gets their hands on a unit (intermittent issues are usually tougher to catch and solve though).

amitabhbansal
02-21-2014, 05:13 AM
i was also having this pain but now it is solved permanently, i have just updated the NVIDIA Driver 334.89 and its fixed, try this

kidfromhell
02-21-2014, 06:06 AM
i was also having this pain but now it is solved permanently, i have just updated the NVIDIA Driver 334.89 and its fixed, try this

I'm on 334.89 and I can pretty much confirm that it's not. It's gone temporarily for you.

Asta666
02-21-2014, 07:24 AM
Hello,

I have also the same problem when I'm on battery.
When I'm on the power supply, no problem.

I have reset the bios, upgrade driver with 334.89, etc. ... but the problem persists :(

Skat137321
02-21-2014, 08:08 AM
My problem seems to have disappeared after switching back to the default refresh rate.

@Asta666 Try checking the adaptive brightness setting in Power Options

Asta666
02-21-2014, 08:43 AM
this option is disable, refresh rate is by default... but always the same problem
It's very strange

Skat137321
02-21-2014, 09:21 AM
In that case: I've ran out of options. I must admit that this whole thing is a strange phenomenon and I tend to believe that it's caused by the OS, not the hardware itself.

LE: Nope, the problem has returned but pressing fn+f7 resolved it for now.

CruiserX
02-22-2014, 03:28 AM
Installed New Nvidia WHQL Drivers - 334.89 for a change to check if issue gets solved. However the intermittent issue still persists. Still a pain in the a**. The new Driver is good and running smooth three days. Tried multiple restarts and shutdowns, no high boot time problem noticed.

hmscott
02-22-2014, 04:15 AM
This happened to me early on, but it was a setting that I enabled in the Nvidia control panel using Nvidia Color settings, it makes available an "Adaptive Contrast enhancement". As soon as I disabled that, the seemingly random screen dimming went away, and I haven't seen it since.

33632

The effect also happened outside of movies / video, even on the desktop.

PatRaven
02-22-2014, 02:44 PM
cl-Albert,

Thanks for your interest in solving this problem :D
Here are my answers to your questions;

1.

Bios version: 208
CPU: i7-4700HQ
Memory amount in GB: 16GB
GPU: nVidia GTX 770M
SSD/HDDs/Optical drives: SSD 180, HDD 750 (2 partitions)
AC Adapter: original ASUS 180w adapter
Operating system: Win8.1 64-bit
Original ASUS factory image or clean install? Original factory Win8 upgraded to Win8.1 through Store
Microsoft Activated yes/no? YES
Drivers Installed (include version and especially any non-ASUS approved notebook drivers): Nvidia driver (327.23). I have tried both older and newer including the latest as well using clean installs. No change!
Any third Party temp/voltage software installed: No
System Overclocked (provide details)? No
Any hardware upgraded? Yes, Intel SSD 520, 180GB as primary, a perfect clone from the original HDD.

2.

No it’s not the manual brightness control. It works fine! No, it’s not the flickering, which I am very well aware of as well (I have read the threads). That’s a different topic mention in many other posts.

3.

I have tried all settings in Power 4 Gear. I tried different versions and made complete uninstalls. No change! Currently it’s not installed. I do not know if Power 4 Gear leaves some unwanted registry settings after an uninstallation that might affect the behavior, something worth checking further perhaps…!? I do not know how though =)

4.

Sure… It is not very beautiful but here is a video.

https://vimeo.com/87343067

First with the adapter in (works nicely). Then without the AC adapter. Notice that the screen dims down when I move the white window out of the picture. Also notice that the start menu fades up when I open/close it. And then finally on AC adapter again (No problem!). Note: I use Classic Start menu 4.0.4 since I do not appreciate Windows 8 as-is very much.

5.

Yes, if you work with images (more or less professionally) you really cannot work running on batteries since you cannot trust what you see in terms of the colors. Basically you have no idea of how the pictures actually look like. I believe many have the problem but haven’t realized it (yet!). Since some say that the problem is solved using the Adaptive brightness setting under power settings and some say its solved using the Nvidia setting I am sure it’s probably solved on their end. For me it’s not solved. Seems like I am stuck in limbo, just like the other guys posting in this thread :(

Br, Pat!


Hmscott,

No change what so ever using that Nvidea setting. I have tried several driver versions with/without that checked and there is no change here!

Br,
Pat!

Edit by cl-Albert: Pat, thanks for taking the time to provide those details.

Skat137321
02-23-2014, 10:46 AM
That is exactly what everyone in this topic is complaining about. Thanks for the clip PatRaven!

Darnassus
02-23-2014, 06:29 PM
That's the one. Funny thing is, I've only had it for one day, ever since I've not had it anymore. I've fiddled with something..

kidfromhell
02-23-2014, 07:50 PM
You should be really lucky. Except one or two hours/day, I have them all the time :(

Skat137321
02-23-2014, 08:03 PM
I actually found this solution on apple forums and I'm testing it atm. The issue seems to have disappeared for now.



I've been searching for a fix for this problem for ages and I figured out a fix that works for me and maybe it'll work for you.

1. Open Device Manager (Right click in the bottom right corner of the screen, click Device Manager)
2. Expand the Monitors
3. Right click on "Generic PnP Monitor" and choose Disable
4. Reboot

I have an early 2011 MBP with a Radeon 6750M and Windows 8 Pro installed with Bootcamp 5 and Catalyst drivers for reference.

SOURCE (http://forums.macrumors.com/showpost.php?p=17436229&postcount=6)

kidfromhell
02-23-2014, 08:23 PM
I actually found this solution on apple forums and I'm testing it atm. The issue seems to have disappeared for now.

Skat, I did this just now but I can't report the results right now as my notebook is plugged in. I'll report back when the charging is complete.

Now for the issues, after I disabled it ATK doesn't work properly wrt brightness. It can't be adjusted using the Fn+F5/F6 keys. I tried repairing ATK and reinstalled as well but of no use. I think it has something to do with PnP. You can adjust it in Power Options though.

EDIT: You CAN"T CHANGE the Brightness at all. Whatever you do, it stays in FULL BRIGHTNESS. Be prepared :)

I tried changing in Power Options but it couldn't be found at all. So used Mobility Center and though the option was found and can be changed, it won't make any difference.

Skat137321
02-23-2014, 08:47 PM
Seems you are right, no more brightness adjustments after disabling the monitor :)

I've reinstalled the Generic PNP Monitor and rebooted. Still no problems with the display dimming on dark backgrounds. Anyone wanna bet how long it will take for it to reappear?

On other hand, is it safe to say that it's a monitor driver related issue? Maybe Asus will be kind enough to help us with a driver for that and maybe they can get it done sooner than it takes them to make win 8.1 drivers for G750JX/JH

hmscott
02-23-2014, 10:05 PM
Hmscott,

No change what so ever using that Nvidea setting. I have tried several driver versions with/without that checked and there is no change here!

Br,
Pat!

Pat, I think I found it, as you describe the problem only on Battery, but ok on AC Power, it looks like it is the Power Plan setting "Enable Adaptive Brightness" in "Advanced Settings", but it may only be visible in Windows 8.1, as I don't recall seeing it before now.

It is in the Display Section of Advanced settings for the current Power Plan, mine is Balanced (Active). And, I hadn't looked at it before, so it is still at defaults, which is Off for Plugged in and On for Battery :)

33677

You may need to update to Windows 8.1 to adjust it without a registry hack.

Here is the registry entry for Windows 8.1

33678

I figured there must be something to tweak in Windows 8.0, so did a google search, and found lots of help :)
https://www.google.com/search?q=windows+8.0++%22Adaptive+Brightness%22.+r egistry&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a&channel=sb#channel=sb&q=windows+8.0++%22Adaptive+Brightness%22+registry&rls=org.mozilla:en-US:official

This one comes up on top, comes from a good source - XDA Developers site - and has 2 levels of registry tweaks - you probably want to right click edit on the registry patch files to see what the payload is before applying them.

http://forum.xda-developers.com/showthread.php?t=2570895

Per typical there are lots of iterations of the tweaks, and that is why this patch would work, but it isn't the most user friendly - which is probably why Microsoft put in the simple On/Off option in Windows 8.1.

moreLightNight looks interesting:
33679

If it was me I would check out more of the sites for a simple On/Off solution without tuning any of the other display parameters. But, that might not exist for Windows 8.0

Here is a list of articles on Adaptive Brightness.
http://www.windowshelpzone.com/thread/how-to-disable-adaptive-brightness.html

Please let us know which one you finally decide is the best :)

kidfromhell
02-23-2014, 11:49 PM
Seems you are right, no more brightness adjustments after disabling the monitor :)

I've reinstalled the Generic PNP Monitor and rebooted. Still no problems with the display dimming on dark backgrounds. Anyone wanna bet how long it will take for it to reappear?

On other hand, is it safe to say that it's a monitor driver related issue? Maybe Asus will be kind enough to help us with a driver for that and maybe they can get it done sooner than it takes them to make win 8.1 drivers for G750JX/JH

Negative, Skat. The problem persists even after disabling PnP :(

PatRaven
02-24-2014, 04:41 PM
hmscott,

I am running 8.1 already and I do have the settings available under Power options. But it does not matter if I turn them off. Tried and failed many times!
I tried the registry hack but theres no change in the behaviour. I tried some other hacks as well, no change!
Yeah, there is a lot of forums with threads about this problem and none of the ones I have found has solved the problem.

One thing I have noticed is that in 8,1 the setting Brightness should be available via the charms menu. In my 8,1 its not there!

33822

That switch is missing in my windows 8,1. So does anyone have a hack for that? :cool:

I also tried disabling the monitor pNp. Does not matter either! The adaptive brightness is still on! :(

Br,
Patrik

Skat137321
02-24-2014, 06:19 PM
I am also missing that option.

My problem disappeared after uninstalling the monitor from device manager, so until it decides to start bugging me again I can't really try any other fixes.

PatRaven
02-24-2014, 08:59 PM
Skat137321,

If I uninstall it, the pnp monitor is back after a restart. If I disable it, it stays disabled! But neither of these changes affect the auto brightness.

What other changes have you made e.g. turned off services, or other tweaks regarding this common problem?

Br,
Pat!

PatRaven
02-25-2014, 05:36 PM
Ok, this is silly but I have a new approach using the fn buttons I talked about earlier.

1. Start the computer with the AC adapter connected (important it seems).
2. Sign into windows
3. Pull out the AC adapter
4. Hold fn and press F3 four times (dims the currently fully lit keyboard)…. Continue to hold fn
5. Press F4 four times (turn on the keyboard light fully again)…. Continue to hold fn
6. Press F7 (turns off the screen) – Let it turn of and dim down the keyboard light.
7. Let go of fn
8. Press fn again and then F7 (turns on the screen) – Let it turn on and let the keyboard light turn on fully.

Now check the auto brightness. It is finally off! For me (currently) it works 95% of the times.

Yeah I know the procedure is long and I am sure it can be shortened. I just remembered the exact sequence when I suddenly managed to turn the autbrightness off and therefore wrote it down just like above…

So does this approach work for any of you?

Br,
Patrik

kidfromhell
02-26-2014, 02:58 AM
Woah, my head is spinning. Good one Pat, lemme try and let you know asap :)

cl-Albert
02-26-2014, 10:45 PM
Ok, this is silly but I have a new approach using the fn buttons I talked about earlier.

1. Start the computer with the AC adapter connected (important it seems).
2. Sign into windows
3. Pull out the AC adapter
4. Hold fn and press F3 four times (dims the currently fully lit keyboard)…. Continue to hold fn
5. Press F4 four times (turn on the keyboard light fully again)…. Continue to hold fn
6. Press F7 (turns off the screen) – Let it turn of and dim down the keyboard light.
7. Let go of fn
8. Press fn again and then F7 (turns on the screen) – Let it turn on and let the keyboard light turn on fully.

Now check the auto brightness. It is finally off! For me (currently) it works 95% of the times.

Yeah I know the procedure is long and I am sure it can be shortened. I just remembered the exact sequence when I suddenly managed to turn the autbrightness off and therefore wrote it down just like above…

So does this approach work for any of you?

Br,
Patrik

Reading this procedure reminds me that the later version of the ATK driver automatically dims the keyboard, so wonder if this other issue could be related to the atk driver too.

For any G750JX owners running Win8.1 and seeing the problem ATK driver V1.0.0031 is now posted on the ASUS G750JX download site along with the other Win8.1 drivers if you want to try them:
http://support.asus.com/Download.aspx?SLanguage=en&m=G750JX&p=3&s=521

Also, from what I saw PatRaven and kidfromhell who are both seeing the problem on battery power appear to both have the G750JX model and are running Win8.1, so just wondering if anybody is seeing this problem with a different model and a different version of Windows.
Would be great to get the vga driver version too in case this matters.
Curious what happens when the original ASUS Win8 image is reinstalled if anybody has an easy way to try this.

Anyway, if we can't isolate/duplicate the problem, our main office isn't going to be able to catch or fix it, so any help with this would be appreciated!

I am obs
02-26-2014, 11:32 PM
Hello,

I had this problem on my g750jw.

While the laptop was running. I unplugged the ac charger and waited a few seconds. Then plugged it back in.

The dimming stopped. Hasn't come back. Fluke ?

kidfromhell
02-27-2014, 07:38 PM
Reading this procedure reminds me that the later version of the ATK driver automatically dims the keyboard, so wonder if this other issue could be related to the atk driver too.

For any G750JX owners running Win8.1 and seeing the problem ATK driver V1.0.0031 is now posted on the ASUS G750JX download site along with the other Win8.1 drivers if you want to try them:
http://support.asus.com/Download.aspx?SLanguage=en&m=G750JX&p=3&s=521

Also, from what I saw PatRaven and kidfromhell who are both seeing the problem on battery power appear to both have the G750JX model and are running Win8.1, so just wondering if anybody is seeing this problem with a different model and a different version of Windows.
Would be great to get the vga driver version too in case this matters.
Curious what happens when the original ASUS Win8 image is reinstalled if anybody has an easy way to try this.

Anyway, if we can't isolate/duplicate the problem, our main office isn't going to be able to catch or fix it, so any help with this would be appreciated!

I'm already on ATK .0031 and from my POV I hope NVIDIA is the culprit here and has to be blamed! No other solution has been found yet, so used my only solution I have.

Reverted back to the damn old vga driver present in JX page (Windows 8 page, not 8.1). Problem solved, FOREVER but sticking with 6 month old driver and have horizontal lines.

PatRaven
02-27-2014, 08:17 PM
cl-Albert,
I was running 1.0.0026 when i wrote the instruction, but I just tried 1.0.0031 (again) and it also works with the instruction. Note: This is not a solution as you have to do it every time you start the computer. And you cannot do it without first having the AC adapter connected to start with.
Hmmmm…. I used the ASUS Backtracker to make a W8 copy on a 16GB USB-drive. Do you know if the backup is a 8 version or if it might just as well be 8.1 depending on when you make the backup? I can’t remember exactly when I did the backup you see… I might consider reinstalling that backup on a separate HDD. But on the other hand I think there’s actually something wrong driver-wise, see e.g my comment to kidfromhell below…


I am obs,
I guess you do not have the same problem as we do. The dimming has never been a problem when connected to the AC adapter, it the other way around.


kidfromhell,
I must somehow have missed it in a previous post, but now I went back to the ASUS site and downloaded an old driver, which I haven’t tested before. The 311.93 version. Is that the one you mean? I was very surprised to find out that the problem seems to be totally gone. No dimming at all when unplugged and I can even start without having the AC adapter connected =) Yeah!!! Now were talking! =) I am a bit skeptical by nature so please give me a day or two since I haven’t tested it thoroughly but so far so good… So is it Nvidia after all?
I haven’t seen any horizontal lines (yet) but I haven’t looked for them either… I have plenty of headache from the dimming issue.

Br,
Pat!

kidfromhell
02-27-2014, 09:34 PM
kidfromhell,
I must somehow have missed it in a previous post, but now I went back to the ASUS site and downloaded an old driver, which I haven’t tested before. The 311.93 version. Is that the one you mean? I was very surprised to find out that the problem seems to be totally gone. No dimming at all when unplugged and I can even start without having the AC adapter connected =) Yeah!!! Now were talking! =) I am a bit skeptical by nature so please give me a day or two since I haven’t tested it thoroughly but so far so good… So is it Nvidia after all?
I haven’t seen any horizontal lines (yet) but I haven’t looked for them either… I have plenty of headache from the dimming issue.

Br,
Pat!

Yes, that's the one. I've already mentioned before that this works, but it's damn old. I already knew it is NVIDIA's fault. Don't worry Pat, the solution is permanent if you can live with the old driver!

cl-Albert
02-28-2014, 07:35 PM
cl-Albert,
Hmmmm…. I used the ASUS Backtracker to make a W8 copy on a 16GB USB-drive. Do you know if the backup is a 8 version or if it might just as well be 8.1 depending on when you make the backup? I can’t remember exactly when I did the backup you see… I might consider reinstalling that backup on a separate HDD. But on the other hand I think there’s actually something wrong driver-wise, see e.g my comment to kidfromhell below…


Pat, ASUS Backtracker should only save the factory recovery partition which would be Win8 if your notebook came with it originally even though you created the back-up in Win8.1.
If you want to spend the time and trouble, I'm curious if you will see the problem going back to the ASUS factory Win8 image, installing the important Windows updates (but not upgrading to Win8.1 yet), and installing the newer nVidia driver that you've seen problems with before installing anything else at all.

If everything is still okay with that newer nVidia driver in Win8, try upgrading to Win8.1 before installing anything else to check if the problem is still there.

Although the issue appears related to the newer nVIdia driver, I'm wondering if there are other things (Win8.1?) or software (ASUS Splendid, ASUS Power4Gear, or third parts etc.) that are related to it too.
Assume you guys must have tried the Win8.1 nVidia driver V9.18.13.2683 posted on the ASUS G750JX download site, but it's something I need to try out with my G750JW unit (uses the same driver) if you're seeing the problem with it (you can wait for me if you prefer?).

Maybe there aren't a lot of people who are running on battery in Win8.1 with the newer nVIdia driver that are bothered by this, but expect more people to complain if it was a common issue, so just wanted to check if there could be more differences in your's and kidfromhell's configurations that it may be related to.

PatRaven
03-01-2014, 08:37 AM
Pat, ASUS Backtracker should only save the factory recovery partition which would be Win8 if your notebook came with it originally even though you created the back-up in Win8.1.
If you want to spend the time and trouble, I'm curious if you will see the problem going back to the ASUS factory Win8 image, installing the important Windows updates (but not upgrading to Win8.1 yet), and installing the newer nVidia driver that you've seen problems with before installing anything else at all.

If everything is still okay with that newer nVidia driver in Win8, try upgrading to Win8.1 before installing anything else to check if the problem is still there.

Although the issue appears related to the newer nVIdia driver, I'm wondering if there are other things (Win8.1?) or software (ASUS Splendid, ASUS Power4Gear, or third parts etc.) that are related to it too.
Assume you guys must have tried the Win8.1 nVidia driver V9.18.13.2683 posted on the ASUS G750JX download site, but it's something I need to try out with my G750JW unit (uses the same driver) if you're seeing the problem with it (you can wait for me if you prefer?).

Maybe there aren't a lot of people who are running on battery in Win8.1 with the newer nVIdia driver that are bothered by this, but expect more people to complain if it was a common issue, so just wanted to check if there could be more differences in your's and kidfromhell's configurations that it may be related to.


I had my share of fun yesterday and restored the factory image on an empty HDD. Yes, as you say it was Windows 8.0 on it. After installation I did the following:

- Uninstalled Power 4 gear, since I have read that it overrides whatever profile you select under energy settings. I could most probably have changed the unplugged profile in Power 4 gear, but I did not try.

- I turned off Adaptive brightness in the energy profile (high performance)

- I checked if I could spot any dimming when unplugged using the factory set Nvidia driver 311.93. No dimming. Also there was no dimming if I turned on the computer without the AC adapter.

- Then I installed (clean install) the latest Nvidia 334.89 WHQL version. And the dimming was there instantly when unplugged, no matter what energy setting applied.

So for sure it seems that it does not matter if you are on Windows 8.0 or 8.1, the problem persists.

I hope you make some interesting findings :)

Ps. I made sure that I used a black desktop background and white windows so that its extremly easy to see the fading going on...

Skat137321
03-01-2014, 08:45 AM
Skat137321,

If I uninstall it, the pnp monitor is back after a restart. If I disable it, it stays disabled! But neither of these changes affect the auto brightness.

What other changes have you made e.g. turned off services, or other tweaks regarding this common problem?

Br,
Pat!

Patraven,

Sorry about the late reply, been traveling in past week.

This is what I've done in order to get rid of the nasty auto contrast issue:

1. Uninstalled the Generic PNP monitor, it got reinstalled after a reboot;
2. Adaptive brightness option set to off from power settings;
3. Using the latest Nvidia drivers (updated from Nvidia site), atk v. 1.0.0030, no Asus Spledind or Power4Gear;
4. Settings from the Nvidia control panel, as well as the refresh rate, are all set to default and I can post a screenshot with them if you think it helps ;
5. The Sensor Monitoring service is set to automatic start.

The problem still reappers at times after I wake the laptop from sleep but it goes away after a restart.

PS: I don't know if it's worth mentioning but I'm having ASUS GPU tweak installed and my card clocked to 900/5400 and I'm using Win 8.1 Pro

PatRaven
03-01-2014, 03:00 PM
Patraven,

Sorry about the late reply, been traveling in past week.

This is what I've done in order to get rid of the nasty auto contrast issue:

1. Uninstalled the Generic PNP monitor, it got reinstalled after a reboot;
2. Adaptive brightness option set to off from power settings;
3. Using the latest Nvidia drivers (updated from Nvidia site), atk v. 1.0.0030, no Asus Spledind or Power4Gear;
4. Settings from the Nvidia control panel, as well as the refresh rate, are all set to default and I can post a screenshot with them if you think it helps ;
5. The Sensor Monitoring service is set to automatic start.

The problem still reappers at times after I wake the laptop from sleep but it goes away after a restart.

PS: I don't know if it's worth mentioning but I'm having ASUS GPU tweak installed and my card clocked to 900/5400 and I'm using Win 8.1 Pro

1. Check!
2. Check!
3. Check! I used the V9.18.13.2683 from 2013.10.28, which is the latest 8.1 driver
4. If I make a clean install I assume the Nvidia settings are also default!? Are they not?
5. Check

Did not work! No change!

Differences as follows;

I do not want to over clock my card and I just assume that installing ASUS GPU Tweak without changing anything would affect the behaviour, so therefore I do not have it installed. I am not able to test with Windows 8.1 Pro =/

Darnassus
03-01-2014, 06:56 PM
Day.. 16 or something. Still can't replicate the issue when I prodded my JX a couple of times. No idea what I did.

Novadash
03-01-2014, 07:34 PM
Has anyone had the issue completely resolved? I'm also desperate about this -_- and I haven't found any solution at all for months now.

kidfromhell
03-02-2014, 03:09 PM
Just one solution. Revert back to the very old NVIDIA driver from JX Win 8 page (311.93 one). That solves this permanently, but you won't get good frames in games as the driver is very old. If you can live with that and I do.

PatRaven
03-03-2014, 08:59 AM
Yep, the only thing that helps for sure is the old 311.93 driver. I am keeping my fingers crossed and wish that someone (like ASUS perhaps) comes up with an easy OFF tweak for all of us with this annoying problem, so that we also can >>enjoy<< the G750 power with the latest GPU drivers...

Novadash
03-03-2014, 09:59 PM
Is FPS affected a lot?? I'd rather live with the autocontrast than with constant low fps
Just a note: I don't really play games other than LoL or some online games so idm fps drops in new games such as BF4, etc.
P.S.: Any1 know where i can get a link to the driver? I can't seem to find one that doesnt last 3 hours to download I'm using windows 8.1

PatRaven
03-04-2014, 08:18 PM
Is FPS affected a lot?? I'd rather live with the autocontrast than with constant low fps
Just a note: I don't really play games other than LoL or some online games so idm fps drops in new games such as BF4, etc.
P.S.: Any1 know where i can get a link to the driver? I can't seem to find one that doesnt last 3 hours to download I'm using windows 8.1

Yes, by using an old driver you can lose a lot of FPS as well as miss out on a lot of fixed glitches. On the other hand it’s unlikely that you do any hardcore gaming on batteries, right? So you may update to the latest drivers if you do not use it on batteries! If you use it on both batteries and via AC adapter its no fun at all having to switch between the OLD driver just because you can’t stand the annoying adaptive brightness and then switch back because you also want to take advantage of the latest driver when you play games :mad:

TiberiusX
03-06-2014, 12:44 AM
Here is my 2 cents worth and how I got rid of the auto contrasting on my G750 JH. I have been following this thread and have been stable for two days now with multiple reboots. First I had already uninstalled Splendid utility due to color distortion issues but I still have Power for gear
installed, also I did turn off auto screen brightness in the advanced settings of Power for gear and have the latest driver installed through Nvidia Geforce experience (driver 334.89).

Opened Nvidia control panel
opened "adjust video color settings"
clicked radio button for adjust with the Nvidia settings
advanced tab
dynamic range (Full 0-255)

**Now here is where I noticed that the dynamic contrast enhancement was not check marked as being enabled so I,

clicked box to enable
hit apply
clicked again to uncheck box,
hit apply again,
closed Nvidia control panel and rebooted.....

Voila, no more auto contrast for two days now.

Hope what worked for me works for others and thanks for all who contributed to this thread with their own processes and ideas.

**By the way, the latest Nvidia driver is working perfectly for me.**

tugrul
03-08-2014, 04:48 PM
Here is my 2 cents worth and how I got rid of the auto contrasting on my G750 JH. I have been following this thread and have been stable for two days now with multiple reboots. First I had already uninstalled Splendid utility due to color distortion issues but I still have Power for gear
installed, also I did turn off auto screen brightness in the advanced settings of Power for gear and have the latest driver installed through Nvidia Geforce experience (driver 334.89).

Opened Nvidia control panel
opened "adjust video color settings"
clicked radio button for adjust with the Nvidia settings
advanced tab
dynamic range (Full 0-255)

**Now here is where I noticed that the dynamic contrast enhancement was not check marked as being enabled so I,

clicked box to enable
hit apply
clicked again to uncheck box,
hit apply again,
closed Nvidia control panel and rebooted.....

Voila, no more auto contrast for two days now.

Hope what worked for me works for others and thanks for all who contributed to this thread with their own processes and ideas.

**By the way, the latest Nvidia driver is working perfectly for me.**
didnt work
i must say i have been disappointed with this 750 JH samsung panel screen. Despite its a exclusive product.

kidfromhell
03-09-2014, 04:39 PM
Phew all is good with the 311.93 downgrade. Suddenly today the problem came back and the display became ugly. I was terrified and thought that the downgrade might could be a temporary solution. Being doubtful, I checked GeForce Experience and this sneaky little software updated my drivers silently in the background to 334. OMG, downgraded again to 311 and unchecked all the driver updates. So, problem solved again.

******* SO THIS IS THE PERMANENT SOLUTION*****

Thread OP updated!!

PatRaven
03-16-2014, 10:40 AM
Phew all is good with the 311.93 downgrade. Suddenly today the problem came back and the display became ugly. I was terrified and thought that the downgrade might could be a temporary solution. Being doubtful, I checked GeForce Experience and this sneaky little software updated my drivers silently in the background to 334. OMG, downgraded again to 311 and unchecked all the driver updates. So, problem solved again.

******* SO THIS IS THE PERMANENT SOLUTION*****

Thread OP updated!!

Yeah sure it’s permanent but I hope we agree that it’s still an interim solution until Asus fixes the problem. Using half a year old drivers really isn’t a solution in my opinion. It would be interesting to know if someone has sent their G750 for inspection at Asus end, and what then Asus replied!?

Bjarke
04-22-2014, 06:20 PM
Bump... Seriously... Bump! This is the most enoying feature ever.
And why does it even make it darker when it's dark, and brighter when it's bright... Shouln't it be the other way around?

RogJohn
04-24-2014, 01:44 AM
im having the same problem! done everything that is posted here and the only thing that work was to use the old graphics driver which is unbelievable considering this problem can be solved "note: just like what lenovo did with a patch but doesnt work on asus" FPS dropped and very f'in annoying

pokerface
04-24-2014, 02:42 AM
I have a G750JX with the 3D glossy screen and I never noticed any issues, can anyone explain what exactly is the issue and how to reproduce it?

sfullert73
04-25-2014, 09:41 PM
Hate to mention it to you 750 guys, but I've got a G55VW. Exact same problem, with no solution but to roll back drivers. GREAT.

Alternatively, however, this allows one to realize that the problem is Nvidia and their new drivers, for sure.

tugrul
04-26-2014, 11:55 AM
i had this problem too. İ tried many many things to get rid of it. Using jh with 3D version. But after i sent machine to the service (3 times)
they sent it to me back and the problem was gone. Actually i deleted their factory win 8 and installed clean win 8,1 from iso. Then installed latest grpahic driver and atk package still problem was gone no ****en auto contrast anymore. İ think its from nvidia drivers who reveal it and the solution it. İ suspect at the beginning from atk packages but i install them too. try not to install it or install the idffrent nvdia drivers.

PatRaven
04-27-2014, 03:04 PM
i had this problem too. İ tried many many things to get rid of it. Using jh with 3D version. But after i sent machine to the service (3 times)
they sent it to me back and the problem was gone. Actually i deleted their factory win 8 and installed clean win 8,1 from iso. Then installed latest grpahic driver and atk package still problem was gone no ****en auto contrast anymore. İ think its from nvidia drivers who reveal it and the solution it. İ suspect at the beginning from atk packages but i install them too. try not to install it or install the idffrent nvdia drivers.

Tugrul,
Do you know what they did or didn’t do the first and second time compared to the third time? Did they make a factory install (system restore) when you got it back from service each time, or only the third time? If it is a hardware problem which they actually solved the third time it makes sense that it also worked when you made a clean install. I wonder since some of us have already tried installing clean 8.0/8.1 and the problem persist. So maybe they actually made something drastic the third time?!
Br,
Pat!

RogJohn
04-28-2014, 02:33 AM
Tugrul,
Do you know what they did or didn’t do the first and second time compared to the third time? Did they make a factory install (system restore) when you got it back from service each time, or only the third time? If it is a hardware problem which they actually solved the third time it makes sense that it also worked when you made a clean install. I wonder since some of us have already tried installing clean 8.0/8.1 and the problem persist. So maybe they actually made something drastic the third time?!
Br,
Pat!

I am also curious on how you solve your problem pls provide a comparison on your hardware and software (display monitor, graphics card, laptop drivers, installer package etc) before and after the third "rma".

also question how do you adjust the contrast of onboard graphics it seems too bright when im on battery, im using the old driver that is provided here (running on g750jx db17).

PatRaven
05-07-2014, 06:35 PM
To maybe make this a little more interesting to solve, I offer now a U.S. $ 150 reward to the person who first solves this problem! The problem is considered resolved when the "auto brightness" / "adaptive brightness" / "screen dimming" or whatever the name is, do not occur on an affected G750 (my own) when running NVidias latest drivers (337.50) without a power adapter.

The first one who posts a working solution in this thread can claim the reward. I will send the money to you using PayPal. Yes, I promise!

For your information none of the mention posts in this thread until now works! So you better come up with a better solution =)

Good luck,
Pat

Note: Not sure if I am allowed to offer a reward. Let me know if thats against the forum rules. If it is against the rules I will remove this post.

Skat137321
05-07-2014, 07:49 PM
Asus should start paying us for having to put with this crap.

Mine works ok until it wakes up from sleep, but a restart fixes it for me. I have no ideea where the discussion went after I stopped posting but I still am inclined to think that a driver for the monitor could solve some of the cases.

Suggesting to use the VGA driver from Asus's website is a complete bullsh*t. How the hell are you supposed to use a 6 mo driver on a gaming laptop?! Not to mention the other outdated drivers.

kidfromhell
05-07-2014, 08:44 PM
It's time since this thread was brought up. In the meantime, I'd like to add some info on what'll nVidia'll respond to this issue if you bring it to them, as I've done it last month.

Excerpts from the chat are below:

https://app.box.com/s/obt9fp7h2qodyp7399nb

Sorry for the pics, I dunno how to delete them! Just have a view at the doc alone!! It has the entire conversation!!

Bjarke
05-08-2014, 12:57 AM
Thanks for sharing your conversation with NVidia,
So what they are saying is, we need to contact the once who manufactured our video card, as they are the once that have modified it?

...That's asus right?


And thanks PatRaven for putting a reward on this problem!

hmscott
05-08-2014, 02:01 AM
Has anyone tried setting the dimmed brightness the same as the normal brightness, as well as disabling Adaptive Brightness in their active Power Plan Advanced options?

Power Plan => Advanced Settings => Display Settings - scroll down in list to find them at the bottom?

Here are my settings, and I don't have any adaptive brightness problems...

36478

Someone mentioned that there seemed to be 2 tiers of brightness settings. When they set the brightness first at normal brightness, and again after the dimming took effect they could then set the brightness there too - this is what I thought of when I heard that.

Give it a try, it might work :)

pen2guin3
05-08-2014, 06:23 AM
Yep ---- same problem here (G750jx). I don't know about anybody else but $2,000 bucks (give or take) is a lot of money to me. It sucks ass that we have to learn to live with this until ASUS/NVIDIA even acknowledges this "as a problem". The work-a-round of installing a out of date driver is not only bull**** but "UN-Acceptable" for a $2,000 laptop. I'm also having problems with my keyboard whereas while typing - stroked keys are not registering. Strike 2 for ASUS........!!!!!!!

PatRaven
05-08-2014, 05:31 PM
Skat137321,
Your idea with the monitor driver does not work for me. But I like the idea. How come we have a generic PnP monitor driver instead one from e.g. Chi Mei? Is it even possible to get a Chi Mei driver, I have not found any so far… I have tried all generic drivers in Windows 8.1 and no change!

kidfromhell,
Thanks for sharing the conversation, too bad that ASUS did not have a solution for the problem. I am pretty sure they must have run into this problem several times by now.

Hmscott,
Power plan: No, tried so many times before and does not work!
Two tier: Nope, no luck with that.

:(

Br,
Pat

ThatGuy_ZA
05-21-2014, 04:29 PM
I know this is a fairly old thread but this issue is really driving me mad. Does ANYONE have a cure for it? Apart from your favourite hammer...

kidfromhell
05-21-2014, 05:21 PM
Woah, this thread has gained much replies after my last post but I didn't receive any notifications. Too bad :(

You're welcome fellas but we're stranded right now and NVIDIA have stepped back safely. I dunno how to proceed with it, so ended the conversation.

No hmscott, nothing works.

Bjarke: Yes. They're pointing out ASUS.

ThatGuy_ZA: No solutions, as of now. Except the one in OP.

I've updated to latest drivers and started to live with it. Cursing my notebook every now and then when the contrast changes.

hmscott
05-21-2014, 10:04 PM
No hmscott, nothing works.

kidfromhell, this problem is so strange, I have never had it, I have all the visible settings set to disable Adaptive Brightness for Windows and disable Adaptive Contrast in the Nvidia control panel, and I just spent 2 full battery cycles recently to see if I can induce it, and it doesn't happen.

What I am saying is I would be happy to compare system settings, registry and otherwise, so we can find the difference between my system without Adaptive Brightness problems, and your system which does.

There are some of my registry entries for AdapativeDisplay
36873

kidfromhell
05-22-2014, 01:54 AM
What I am saying is I would be happy to compare system settings, registry and otherwise, so we can find the difference between my system without Adaptive Brightness problems, and your system which does.

Here it is hmscott, but I highly guess that it remains the same for both of us.

36880

hmscott
05-22-2014, 02:20 AM
Here it is hmscott, but I highly guess that it remains the same for both of us.
36880

That is the same registry entry I posted, and the numbers are the same :)

If you think it would be helpful to compare the rest of the Adaptive Brightness registry settings, you use snipping tool to capture just the region of interest into a jpg, and do the same for the other Adaptive Brightness entries. Expanding that one and the other 4 in that area would be a start.

Update: I am running 337.50 BETA

cl-Albert
05-22-2014, 05:08 PM
@hmscott, kidfromhell, sorry if I missed it, but do you also want to compare vga driver versions since it sounds like the issue is related to this as well?

Oh, I guess if you can solve it from the Windows registry side, we may not really need to worry about the vga driver version used, but might still be good to know what everybody is running?

PatRaven
05-22-2014, 06:17 PM
Great that you keep the thread running. Hopefully will find a suitable solution in the end.

My input for today...
I deleted all entries (the whole hierarchy) below HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AdaptiveDisplayBrightness including AdaptiveDisplayBrightness folder and then restarted. No difference at all! So I guess the problem is located elsewhere. Or some imporant Key is missing under \AdaptiveDisplayBrightness.

Br,
Pat!

hmscott
05-23-2014, 12:31 AM
Great that you keep the thread running. Hopefully will find a suitable solution in the end.

My input for today...
I deleted all entries (the whole hierarchy) below HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AdaptiveDisplayBrightness including AdaptiveDisplayBrightness folder and then restarted. No difference at all! So I guess the problem is located elsewhere. Or some imporant Key is missing under \AdaptiveDisplayBrightness.

Br,
Pat!

That's a good point, removing the registry tree made it recreate the tree with defaults in use. Did you notice if the recreated values are now different, if anything was added or not recreated?

PatRaven
05-23-2014, 02:49 PM
That's a good point, removing the registry tree made it recreate the tree with defaults in use. Did you notice if the recreated values are now different, if anything was added or not recreated?

I exported the entries first. Then deleted. Then restarted. No change. Imported back the entries. Windows does not recreated these entries automatically. Maybe you can export your KEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AdaptiveDisplayBrightness tree and attached it here so that we can try using your setup, or at least compare the two!? If they are identical I think we must look elsewhere for the problem. Maybe an export of all Nvidia entries could be helpful as well but we could try that later. I am not sure if maybe the GPU tweak tool allows you to export all Nvidia settings or if there is another tool available for that. I assume that there must be tons of Nvidia settings, not necessarily stored in a single tree structure...

hmscott
05-25-2014, 09:21 AM
PatRaven, there are two major AdaptiveDisplayBrightness registry tree's, here are both as .reg.zip files, let us know if it helps :)

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AdaptiveDisplayBrightness
36961

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\ Windows NT\CurrentVersion\AdaptiveDisplayBrightness
36962

Bjarke
05-26-2014, 12:24 AM
YAaay it woorked! After so many attempts :) Thank you so much!


PatRaven, there are two major AdaptiveDisplayBrightness registry tree's, here are both as .reg.zip files, let us know if it helps :)

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AdaptiveDisplayBrightness
36961

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\ Windows NT\CurrentVersion\AdaptiveDisplayBrightness
36962

hmscott
05-26-2014, 12:52 AM
YAaay it woorked! After so many attempts :) Thank you so much!

Bjarke!, that's great! What did you do to apply the .reg files? Did you reboot in between? Any other helpful details that would help others apply the fix?

gazzacbr
05-26-2014, 06:12 AM
FYI, just checked the regsitry entries mentioned above.
my windows 8.1 has the folders with some entries in (although i dont have the brightness problems).
my windows 7, using all the same drivers, has the folders but they are empty.
is it a windows 8 'feature' ?

oh, and its 'changed' from windows 7 (nice one micro$oft)
adaptive backlight i have the choice of none, 1 low to 5 high.
36998

PatRaven
05-26-2014, 05:16 PM
PatRaven, there are two major AdaptiveDisplayBrightness registry tree's, here are both as .reg.zip files, let us know if it helps :)

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AdaptiveDisplayBrightness
36961

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\ Windows NT\CurrentVersion\AdaptiveDisplayBrightness
36962

Hi hmscott,

I deleted both trees. Imported your two regfiles. Restarted. No change!
I also compared the files with my own (as I exported them to start with) and theres no difference in them...
I was getting real exciting sine Bjarke said it worked, but for me it does not work. Same behaviour as before =/

hmscott
05-26-2014, 11:53 PM
Hi hmscott,

I deleted both trees. Imported your two regfiles. Restarted. No change!
I also compared the files with my own (as I exported them to start with) and theres no difference in them...
I was getting real exciting sine Bjarke said it worked, but for me it does not work. Same behaviour as before =/

PatRaven, there must be multiple causes or sources, the search continues :)

PatRaven, it you are serious about this, which I think you are, you could get another boot drive, restore from Asus Backtracker flash drive, and immediately upgrade to the latest 337.88 WHQL driver, and see if the problem shows up - before doing any updates or installs.

Then gradually add things until the problem returns, keeping special attention to updates, and installs, with restore points before each.

You could keep the original boot disk with the problem, and all your configuration intact and swap it in when needing to work - so as to not affect the test drive.

It would be a long tedious process, but in the end you should have a narrowed if not exact cause that can be avoided. I have done this before successfully to find a registry change in particular.

I don't know what else to suggest as a solution, since it is such a multiple cause issue.

PatRaven
05-29-2014, 10:14 AM
PatRaven, there must be multiple causes or sources, the search continues :)

PatRaven, it you are serious about this, which I think you are, you could get another boot drive, restore from Asus Backtracker flash drive, and immediately upgrade to the latest 337.88 WHQL driver, and see if the problem shows up - before doing any updates or installs.

Then gradually add things until the problem returns, keeping special attention to updates, and installs, with restore points before each.

You could keep the original boot disk with the problem, and all your configuration intact and swap it in when needing to work - so as to not affect the test drive.

It would be a long tedious process, but in the end you should have a narrowed if not exact cause that can be avoided. I have done this before successfully to find a registry change in particular.

I don't know what else to suggest as a solution, since it is such a multiple cause issue.

Thanks hmscott,
Currently I have no spare time for trial and error but I might try it later on...

1. Has anybody else replaced their register settings with hmscott's export? Did it work?
2. For your information: Using Backtracker will format all partitions (maybe even all discs if you have two). So make sure you have made a backup of all your important files! (Yes, I tried it myself before so I know that it format both :mad: But at that point I did not go directly with the latest Nvidia driver, so I can’t tell if hmscotts suggested proposal works).

KoolASUS
05-29-2014, 01:25 PM
just a thought. Might be stupid, but....

I have a G750JH. The "official" driver is 311.83 from the Asus site (and it's in a directory on the computer). Available nowhere else.
What if the Auto Contrast trouble is only caused by the fact that you don't use the "Asus" drivers (these specific/tweaked "Asus" files and DLLs), and nothing else ????
I mean, maybe you're only supposed to use the "Asus" driver, and that's it. I don't have AutoDim/Contrast trouble........
In this case, no registry hack would work, unfortunately.

It's an extreme theory, but who knows ? So far there have been no comments from Asus. (same as for some other problems...)

hmscott
05-29-2014, 01:32 PM
just a thought. Might be stupid, but....

I have a G750JH. The "official" driver is 311.83 from the Asus site (and it's in a directory on the computer). Available nowhere else.
What if the Auto Contrast trouble is only caused by the fact that you don't use the "Asus" drivers (these specific/tweaked "Asus" files and DLLs), and nothing else ????
I mean, maybe you're only supposed to use the "Asus" driver, and that's it. I don't have AutoDim/Contrast trouble........
In this case, no registry hack would work, unfortunately.

It's an extreme theory, but who knows ? So far there have been no comments from Asus. (same as for some other problems...)

KoolAsus, I don't have the auto-contrast problem on AC/battery, and I have always been running the latest Nvidia driver downloaded from Nvidia on my JH... I do a Custom/Clean install each time.

Also, since this is a User Support forum, we can't expect Asus to respond directly to the problems posted here. If we can't work out the problem here, then reporting the problem to Asus through a Technical Inquiry is the path to start on to eventually get to an Engineer and a solution.

kidfromhell
05-29-2014, 04:16 PM
just a thought. Might be stupid, but....

I have a G750JH. The "official" driver is 311.83 from the Asus site (and it's in a directory on the computer). Available nowhere else.
What if the Auto Contrast trouble is only caused by the fact that you don't use the "Asus" drivers (these specific/tweaked "Asus" files and DLLs), and nothing else ????
I mean, maybe you're only supposed to use the "Asus" driver, and that's it. I don't have AutoDim/Contrast trouble........
In this case, no registry hack would work, unfortunately.

It's an extreme theory, but who knows ? So far there have been no comments from Asus. (same as for some other problems...)

Nope, even if you download other versions from ASUS, the problem persists. The issue is simple - Download 311.93 from ASUS to solve the issue; download any other version from either ASUS or NVIDIA, custom install, whatever you do, it's there!

kidfromhell
05-29-2014, 04:17 PM
Thanks hmscott,
Currently I have no spare time for trial and error but I might try it later on...

1. Has anybody else replaced their register settings with hmscott's export? Did it work?
2. For your information: Using Backtracker will format all partitions (maybe even all discs if you have two). So make sure you have made a backup of all your important files! (Yes, I tried it myself before so I know that it format both :mad: But at that point I did not go directly with the latest Nvidia driver, so I can’t tell if hmscotts suggested proposal works).

Pat, could you guide me through the process on applying scott's registry settings? I haven't messed up with registry entries before.

PatRaven
05-29-2014, 04:34 PM
Pat, could you guide me through the process on applying scott's registry settings? I haven't messed up with registry entries before.

Sure,
Save hmscotts two .reg files somewhere…

Run regedit.exe (you can e.g. run it from a command prompt or via the Win 8 search field by typing regedit).

1. Go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AdaptiveDisplayBrightness in the hierarchy.
Right click AdaptiveDisplayBrightness and choose export. Save it with some clever name. Then delete AdaptiveDisplayBrightness together with its sub items.

2. Go to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\ Windows NT\CurrentVersion\AdaptiveDisplayBrightness.
Right click AdaptiveDisplayBrightness and choose export. Save it with another clever name. Then delete AdaptiveDisplayBrightness together with its sub items.

Double click on the first .reg files hmscott supplied. Accept everything!
Double click on the second .reg files hmscott supplied. Accept everything!

Restart! Any change? Please report!

If you want to go back to your old settings then delete the two AdaptiveDisplayBrightness trees again and then use your own exported .reg files to restore them. In my case there were no difference between my own exported copies and hmscotts files. I compared the two byte by byte.

Br, Pat!

kidfromhell
05-29-2014, 06:29 PM
Sure,
Save hmscotts two .reg files somewhere…

Run regedit.exe (you can e.g. run it from a command prompt or via the Win 8 search field by typing regedit).

1. Go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AdaptiveDisplayBrightness in the hierarchy.
Right click AdaptiveDisplayBrightness and choose export. Save it with some clever name. Then delete AdaptiveDisplayBrightness together with its sub items.

2. Go to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\ Windows NT\CurrentVersion\AdaptiveDisplayBrightness.
Right click AdaptiveDisplayBrightness and choose export. Save it with another clever name. Then delete AdaptiveDisplayBrightness together with its sub items.

Double click on the first .reg files hmscott supplied. Accept everything!
Double click on the second .reg files hmscott supplied. Accept everything!

Restart! Any change? Please report!

If you want to go back to your old settings then delete the two AdaptiveDisplayBrightness trees again and then use your own exported .reg files to restore them. In my case there were no difference between my own exported copies and hmscotts files. I compared the two byte by byte.

Br, Pat!

Tnx a lot, Pat!

Done as requested, meh, it's still there! So, this doesn't help either.

KoolASUS
05-29-2014, 07:37 PM
Nope, even if you download other versions from ASUS, the problem persists. The issue is simple - Download 311.93 from ASUS to solve the issue; download any other version from either ASUS or NVIDIA, custom install, whatever you do, it's there!
Euh.... that's exactly what I said !
There are NO OTHER "versions" from Asus or Nvidia : I mean the download from the Asus page for YOUR EXACT laptop.
For G750JH and Win8, it's : http://support.asus.com/download.aspx?SLanguage=en&m=G750JH&p=3&s=521&os=36&hashedid=n/a

kidfromhell
05-29-2014, 08:43 PM
Euh.... that's exactly what I said !
There are NO OTHER "versions" from Asus or Nvidia : I mean the download from the Asus page for YOUR EXACT laptop.
For G750JH and Win8, it's : http://support.asus.com/download.aspx?SLanguage=en&m=G750JH&p=3&s=521&os=36&hashedid=n/a

Oh, never mind! There's one in 8.1 x64 page though!

PatRaven
05-31-2014, 08:39 PM
Today I made a completely clean install of Windows 8.1 Pro which I got hold of from a friend, on a spare HDD. No, I did not use the Win 8 restore that came with G750 at all. After installation I downloaded the latest Nvidia driver directly from Nvidia. Problem appeared directly! I then installed the 311.93 version and the problem was gone! Installed the latest driver again and the problem reappeared. F—K. Not that it matter much but I forgot to check which version Windows 8.1 pro installed by default, but it does not matter since an upgrade seems impossible anyway.

My conclusion: Its nothing wrong with windows, energy settings etc. It might be a hardware failure on the G750 or at least a real interesting implementation of the 311.93 version as it apparently works. So back to square one :mad:

Br,
Pat!

hmscott
06-01-2014, 12:25 AM
Today I made a completely clean install of Windows 8.1 Pro which I got hold of from a friend, on a spare HDD. No, I did not use the Win 8 restore that came with G750 at all. After installation I downloaded the latest Nvidia driver directly from Nvidia. Problem appeared directly! I then installed the 311.93 version and the problem was gone! Installed the latest driver again and the problem reappeared. F—K. Not that it matter much but I forgot to check which version Windows 8.1 pro installed by default, but it does not matter since an upgrade seems impossible anyway.

My conclusion: Its nothing wrong with windows, energy settings etc. It might be a hardware failure on the G750 or at least a real interesting implementation of the 311.93 version as it apparently works. So back to square one :mad:

Br,
Pat!

Pat, so right after the install of Windows Pro, the problem did not exist?

I wouldn't go so far as to not blame Windows for this problem, since there are lots of other people on other laptops complaining about this auto contrast auto brightness problems.

https://www.google.com/search?q=windows+8.1+auto+contrast+problem&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a&channel=sb

https://www.google.com/search?q=windows+8.1+auto+brightness+problem&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a&channel=sb

You can check the vbios version on your JX using TechPowerup GPU-Z, mine is a JH, but here is an example - it shows the video bios (and lets you back up the video bios, little chip icon to the right of the version box), and lots of other info.

37244

You can give that GPU-Z info, as text and attach the jpg image to the Technical Inquiry, to Asus and ask Asus if there is an updated vbios that they can give you to update, and explain the problem - ask them for help (I don't recall if you already did that).

Sorry you still have this problem Pat...

kidfromhell
06-01-2014, 04:33 PM
My conclusion: Its nothing wrong with windows, energy settings etc. It might be a hardware failure on the G750 or at least a real interesting implementation of the 311.93 version as it apparently works. So back to square one :mad:

That's one expensive piece of testing you've done Pat, good work! Though felt disappointing with the results, I was expecting the same either. Now to come up with other solution.

And for the vBIOS request scott, will ASUS provide it to consumers like us upon request?

hmscott
06-02-2014, 01:29 AM
That's one expensive piece of testing you've done Pat, good work! Though felt disappointing with the results, I was expecting the same either. Now to come up with other solution.

And for the vBIOS request scott, will ASUS provide it to consumers like us upon request?

Only one way to find out, Ask Asus :)

One of the new G750's, 860/870 got a vBIOS update recently over Asus Live Update, and Asus have provided vbios updates in the past. There are enough people suffering with this odd problem - while a lot of others aren't - if it can be solved with a vBIOS update we should interest Asus in doing that.

If you can find vbios versions in common on laptops that have the problem, and vbios versions that don't have the problem, perhaps an update to the systems with the problem is the solution.

Who is working with Asus right now, or has in the past, on this auto-contrast / brightness problem? This is another step in the diagnostics to figure out a solution through Asus.

Skat137321
06-06-2014, 04:37 PM
Hello again!

I can't really remember what I've done in the past to fix the whole problem but my display works fine until I wake the laptop from sleep. From that point on, the only thing that can get my display working as intended is a restart.

This happens on a G750JX with Win 8.1 Pro, latest nvidia drivers from their website, ATK 1.0.0034 and that's all I have installed in the driver department. Tried several version of ATK Package and I can tell for sure it has nothing to do with it.

hmscott
06-12-2014, 06:01 AM
Guys, while looking at display sleep issues in another thread, I came across this monitoring option in powercfg, that can be run for a time duration, which if run in the background during a dimming event, but shed some light on what is doing it.

C:\Temp>POWERCFG /ENERGY /OUTPUT "longtrace.html" /DURATION 120
Enabling tracing for 120 seconds...
Observing system behavior...
Analyzing trace data...
Analysis complete.

Energy efficiency problems were found.

17 Errors
3 Warnings
24 Informational

See C:\Temp\longtrace.html for more details.

Here is an app that requires a call before shutdown, the PerfectDisk defrag service

System Availability Requests:System Required Request
The service has made a request to prevent the system from automatically entering sleep.
Requesting Service PDEngine

You can also dump low level info on the powercfg not visible in the GUI, that might prove interesting too.

C:\Temp>powercfg /query

....
Subgroup GUID: 7516b95f-f776-4464-8c53-06167f40cc99 (Display)
GUID Alias: SUB_VIDEO
Power Setting GUID: 3c0bc021-c8a8-4e07-a973-6b14cbcb2b7e (Turn off display
after)
GUID Alias: VIDEOIDLE
Minimum Possible Setting: 0x00000000
Maximum Possible Setting: 0xffffffff
Possible Settings increment: 0x00000001
Possible Settings units: Seconds
Current AC Power Setting Index: 0x0000003c
Current DC Power Setting Index: 0x00000000

Power Setting GUID: aded5e82-b909-4619-9949-f5d71dac0bcb (Display brightnes
s)
Minimum Possible Setting: 0x00000000
Maximum Possible Setting: 0x00000064
Possible Settings increment: 0x00000001
Possible Settings units: %
Current AC Power Setting Index: 0x00000053
Current DC Power Setting Index: 0x0000004b

Power Setting GUID: f1fbfde2-a960-4165-9f88-50667911ce96 (Dimmed display br
ightness)
Minimum Possible Setting: 0x00000000
Maximum Possible Setting: 0x00000064
Possible Settings increment: 0x00000001
Possible Settings units: %
Current AC Power Setting Index: 0x00000050
Current DC Power Setting Index: 0x00000050

Power Setting GUID: fbd9aa66-9553-4097-ba44-ed6e9d65eab8 (Enable adaptive b
rightness)
GUID Alias: ADAPTBRIGHT
Possible Setting Index: 000
Possible Setting Friendly Name: Off
Possible Setting Index: 001
Possible Setting Friendly Name: On
Current AC Power Setting Index: 0x00000000
Current DC Power Setting Index: 0x00000000

There is too much more to post.

I haven't seen any discussion here for a while, any updates?

PatRaven
06-12-2014, 06:38 PM
I haven't seen any discussion here for a while, any updates?

No I have been quite busy with other stuff... Thanks for reporting your findings, I will for sure look into them soonest possible.

Br,
Pat!

Dario723
07-09-2014, 11:32 PM
...somebody tried new ASUS driver released 2014.07.04 on ASUS G750JW download site (Version V9.18.13.3788 )?

hmscott
07-10-2014, 04:06 AM
...somebody tried new ASUS driver released 2014.07.04 on ASUS G750JW download site (Version V9.18.13.3788 )?

Dario723, nice find :)

38715

G750JW
http://dlcdnet.asus.com/pub/ASUS/nb/DriversForWin8.1/VGA/VGA_nVidia_Verde_Win81_64_VER918133788.zip

Someone else mentioned this in another thread, but didn't say where they found it, a Verde driver - point release with fixes for specific hardware - he thought it was for the JS model.

38716

And, it's also downloadable from the JS download area, the same source download location:
http://dlcdnet.asus.com/pub/ASUS/nb/DriversForWin8.1/VGA/VGA_nVidia_Verde_Win81_64_VER918133788.zip

I am running 340.43, and don't have the auto contrast bug... so someone else will have to try nVidia_Verde_Win81_64_VER918133788 :)

Dario723
07-11-2014, 02:11 AM
..tried it ...driving me crazy!@#$%^&*...doesn't work, clean install, still dimming at AC, uhhh....at the moment it's the only flaw with my G750JW, the rest is quite close to perfect ...

Hotobeseman
07-13-2014, 06:55 AM
Hey, G75vx owner here. I've read through the entire thread and I can tell you guys that the G75 series suffers the same problem. We've let Asus know about this years ago and they've yet to give us a solution. Whatever display anomaly they put in the G75's they kept in the G750's apparently!

xdon82
07-13-2014, 06:03 PM
so what is the solution ? I have this problem on my G56, but only on battery - strange

angrybird
07-14-2014, 11:43 AM
Yes, I had that too, but it disappeared when i uninstalled power4gear. i am on "normal" Windows power settings.
btw, i'm still on stock 311.83 drivers.
cộng đồng intenet việt nam chuyên về
và lắp đặt internet fpt tại đồng nai (https://internetvietnam.net/dang-ky-lap-dat-internet-fpt-tai-dong-nai.html) một cách nhanh chóng.

Với nhiều năm kinh nghiệm trong lĩnh vực,Cùng với nhiều trương tŕnh khuyến măi và hậu măi hấp dẫn dành cho khách hàng đă sử dụng dịch vụ của chúng tôi đă và đang làm hài ḷng những khách hàng khó tính nhất trong lĩnh vực Camera Quan sát .
Ngày nay ai cũng biết một hệ thống cảnh báo sớm qua hệ thống lắp mạng fpt b́nh dương (https://internetvietnam.net/dang-ky-lap-dat-internet-fpt-tai-binh-duong.html) đă giúp đỡ trong cuộc sống hàng ngày như thế nào , Sau đây Camera Viễn Đông xin được điểm sơ qua một số lợi ích mà hệ thống Camera mang lai :
- Giúp cảnh báo sớm các rủi ro có thể xảy ra như nạn trộm cắp đang hoành hành , Cảnh báo sớm các rủi ro khác như hỏa hoạn tại các kho ,băi nhằm khắc phục sớm giảm được thiệt hại .
- Giúp quản lư được con trẻ ,Người giúp việc … tại nhà mà không cần sự có mặt của các bậc phụ huynh , chủ nhà ..
- Giúp giám sát được các hoạt động tại các khu kinh doanh buôn bán tại các cửa hàng , doanh nghiệp …
- Giám sát được mọi hoạt động của nhân viên ở bất cứ đâu mà không cần phải có mặt tại chỗ giúp căi thiện được năng suất làm việc từ đó nâng cao doanh số .
Website tham khảo: https://internetvietnam.net/

xdon82
07-15-2014, 03:15 PM
I have uninstalled power4gear too, and I have still this problem. I'm thinking about reinstalling windows and installing only drivers which doesnt exist in Windows Update. I don't know is it worth a try......I think the problem is mainly in Asus drivers, not in Windows

Hotobeseman
07-16-2014, 11:33 PM
To all still lurking this thread, I've found the a solution that works for me.

1. Open nvidia control panel, go to video settings.
2. Check box for dynamic contrast, hit appply.
3. Uncheck box for dynamic contrast, hit apply.
4. Restart computer
5. Go to services (type "services" in search, or Control Panel>System and Security>Administrative Tools>Services)
6. Disbable startup for NVIDIA Display Driver Service, NVIDIA, Network Service, NVIDIA Stereoscopic 3D Driver Service, and NVIDIA Streamer Service
7. Restart computer
[/B][/U]

This doesn't affect game fps at all.
Also, Nvidia Control Panel no longer works and Nvidia drivers no longer update automatically.

My computer settings (things that may or may not matter):
I have the g75vx
I have uninstalled ALL Asus software except Power4Gear
I'm using the color profile from:
http://rog.asus.com/forum/showthread.php?36153-Personal-Color-Profile-for-the-Chi-Mei-173HGE/page5&highlight=color+profile
I'm using NVidia driver 337.88

This fix has worked for 3 days now. If you have any problems with it let me know.

OH YEAH btw his fix only works when you're laptop is plugged in. Once you switch to battery the problem will occasionally come back! spooky

xdon82
07-18-2014, 01:00 AM
the question is, why the hell Asus do not make any drivers fix / udpates ?

Thestroj
07-19-2014, 01:22 PM
I had this issue when u first got the laptop almost a year ago.

But once i use ASUS Backtracker to revert back to stock, the problem stoped, i coupld upload my USB 16GB flash drive to my Google Drive if anyone want's it...

I just reverted back to stock yesterday cause laptop was getting slow, but right now im strugling to update to 8.1.
Somehow my win 8 wont install updates necessary to be able to get 8.1 from Microsoft store... But thats another matter...

xdon82
07-20-2014, 09:59 AM
The problem is solved ;) I wrote down about it in a new thread titled "auto brightness / contras solved" - but it's solution for not all Asus laptops or the one step of the sollution - it's for sure works in G56jr , probably on all with 2 GPUs installed

GottiBoi55
07-21-2014, 03:43 AM
You need to go to services and stop the service, and disable it.
(As in the screen shot below)

xdon82
07-21-2014, 10:19 AM
I have another question. I have G56JR and I want to enable it :) ? how to do it ?

LapinFou
08-09-2014, 01:58 PM
Hi Folks,

It was also driving me crazy. I tried many unsuccessful methods, until I do this one:
http://forums.lenovo.com/t5/ThinkPad-Edge-Knowledge-Base/Random-changes-in-screen-brightness-every-few-minutes-in-Windows/ta-p/915291
and there:
http://www.eightforums.com/tutorials/6042-adaptive-brightness-turn-off-windows-8-a.html
In my case I put both parameters to OFF.
BUT, you must do this for EVERY power plan (Normal, Eco, Power4Gear High Perf, etc...). When I first try (only on High Perf Power4Gear) the fu***g auto contrast was still working. At the end, I tried to apply it to EVERY power plan profile and it was finally gone!!!
Don't ask me why, but it worked for me. :)
I was very skeptical that the problem was coming from this parameter (to me this parameter was only linked with an ambient light sensor), but it looks like there is a direct impact on this very annoying dynamic auto-contrast.

For the record, my laptop is a ROG G750JH (NVidida GTX 780M version) and I did NOT uninstall ASUS Splendid, nor Power4Gear. It is the stock version upgraded to Win8.1 (but using ClassicShell).
My current NVidia driver version is 340.52.

I Hope it can help.

Note: It did resolved the problem when My ROG is plugged on AC supply, but it is still doing the same thing in battery mode.

PatRaven
08-10-2014, 10:14 AM
I have given up any hope of solving this issue. I have never had a problem running with AC adaptor. The problem only exist when running on batteries. I have tried EVERYTHING and the only solution that works for sure is going back to the 311.83 drivers. I have tried vanilla 8.0, upgrading to 8.1. A clean install with 8.1 PRO. Tried most GPU drivers existing and ALL "solutions" mentioned in this thread + many many more. NONE of them solves the problem when running on batteries only. I will check this thread now and then... Maybe someone finally will solve it, who knows. Right now I am pretty tired of the whole issue and I try my best to forget all the headache it have given me.

Br,
Pat!

LapinFou
08-10-2014, 02:42 PM
Hi Pat,

Thanks for your feedback. Maybe I will try to get some support from NVidia on this issue. It is definitely related to the GPU driver. So, they must be somewhere a tick box or a register entry which will fix the problem. I will keep your inform. It is really a shame, because expected this problem, the ROG is one the best laptop for gamers...

p34rp3412
09-29-2014, 09:00 PM
I've been watching this thread a long time and I'm wondering... The i7 CPU in these G750 laptops have HD4x00 graphics built-in, but is disabled somehow. I've seen a few other threads talking about auto-contrast and many of these laptops use the Intel HD graphics. The Intel graphics utility DOES have an option for dynamic contrast, and when enabled, does in fact do exactly what many others on this thread see - no contrast issues when plugged in, but dynamic contrast on battery which is especially noticeable when there's a lot of black on the screen. Is it possible that the older Asus driver correctly disables the Intel GPU whereas the Nvidia drivers do not? Is it possible to force install the Intel HD graphics control panel to disable that "feature?"

sample images of the Intel graphics control panel:
http://superuser.com/questions/414622/how-to-disable-auto-brightening-lcd

mobi
10-30-2014, 06:06 PM
Same problem here. First day with the g751jy and instantly noticed the auto contrast thing. Doesn't happen when plugged in as PatRaven has said.

I've tried changing all power options, editing the registry entries, and uninstalling some ASUS stuff related to the screen but nothing seems to have worked.

Talked to ASUS support and they couldn't help me solve the problem. Hopefully ASUS/Nvidia can shed some light on a fix for this.

Darnassus
11-01-2014, 03:14 AM
I forgot how I got rid of mine.. lol ;D

hmscott
11-01-2014, 04:19 AM
Nyceis fixed his auto-contrast issue with his G751JY by using the .reg files I uploaded:

Nyceis post:
http://rog.asus.com/forum/showthread.php?52651-G751JY-Does-Not-Have-Optimus&p=443984&viewfull=1#post443984

My post with .reg files:
http://rog.asus.com/forum/showthread.php?43315-Auto-contrast-is-driving-me-nuts%21%21&p=403670&viewfull=1#post403670

It's probably worth a try...if nothing else has worked.

bsod
12-11-2014, 07:19 AM
Thanks hmscott for the reg files. Unfortunately I noticed the same issue on my g751jt and nothing has fixed it. Very annoying. Deleting and using your reg files I noticed all "use adaptive brightness" settings get toggled to "On" where as they were off by default. I set them back to off, but no difference either way. Looks like this issue has been going on for years with no real solution.

hmscott
12-11-2014, 05:54 PM
Thanks hmscott for the reg files. Unfortunately I noticed the same issue on my g751jt and nothing has fixed it. Very annoying. Deleting and using your reg files I noticed all "use adaptive brightness" settings get toggled to "On" where as they were off by default. I set them back to off, but no difference either way. Looks like this issue has been going on for years with no real solution.

bsod, it's weird, but yes sometimes the same fix that works for others doesn't work for some. When I took that registry dump I had adaptive brightness disabled - off.

This is how I have it set now:

44139

There are some problems that are endemic to Nvidia across platforms, and across Windows platforms. Doing a google search on Windows 8.1 adaptive brightness comes up with a large cross section of computers with the problem:

https://www.google.com/search?num=50&safe=off&q=windows+8.1+adaptive+brightness&oq=windows+8.1+adaptive+brightness&gs_l=serp.3..0j0i7i30l3j0.8000.9906.0.10112.12.11. 0.0.0.5.139.1182.4j7.11.0.msedr...0...1c.1.60.serp ..6.6.650.WHRqeJBLoNw

But, that is weird behavior that installing those reg files turned it back On for you, when it fixed it for Nyceis, very strange. Did you reboot after applying them?

bsod
12-11-2014, 08:01 PM
I rebooted so much last night I don't even remember if I reboot precisely after applying the fix or not. I now have 2 systems side by side to test one.. going to return one. They're pretty much identical.

From all the searching last night I found that the problem is indeed endemic to all devices that can run on battery on Windows 8, including laptops and MS tablets. I'm not sure what the surface tablets use for their graphics chips, but unlike this Asus, other users have been able to access the auto-contrast toggle either via the Intel graphics driver settings, Dell or Lenovo specific settings, or Surface tablet specific settings.

I was able to run the Surface Tablet Tweak tool
http://www.surfaceforums.net/threads/surface-tweak-tool-for-surface-pro-2-release.8219/
on the Asus, but unfortunately the toggle for "Dynamically adjust contrast ratio on battery" was grayed out. So close.. argh

Interesting to run the banding test though on battery to see indeed there is a decrease in visual fidelity when my g751jt is unplugged.

PatRaven
12-11-2014, 08:56 PM
I rebooted so much last night I don't even remember if I reboot precisely after applying the fix or not. I now have 2 systems side by side to test one.. going to return one. They're pretty much identical.

From all the searching last night I found that the problem is indeed endemic to all devices that can run on battery on Windows 8, including laptops and MS tablets. I'm not sure what the surface tablets use for their graphics chips, but unlike this Asus, other users have been able to access the auto-contrast toggle either via the Intel graphics driver settings, Dell or Lenovo specific settings, or Surface tablet specific settings.

I was able to run the Surface Tablet Tweak tool
http://www.surfaceforums.net/threads/surface-tweak-tool-for-surface-pro-2-release.8219/
on the Asus, but unfortunately the toggle for "Dynamically adjust contrast ratio on battery" was grayed out. So close.. argh

Interesting to run the banding test though on battery to see indeed there is a decrease in visual fidelity when my g751jt is unplugged.

Cool tool! I ahevnt seen that before. Now just let us get it to work on G750-51 as well =) Sorry to say and as you already have read none of the mention fixes works on my G750 except to revert back to the factory gpu 311.83 driver.

Confirmed! The banding is there while using batteries on the latest drivers. I havent bothered to test on 311.83 today but as it works flawlessy I ampretty sure the banding will be gone using it. I will try that another day.

bsod
12-11-2014, 10:14 PM
I forgot to mention that while I was attempting to uninstall my nvidia drivers, I accidentally deleted the graphics card adapter from my devices.
Auto contrast problem solved!
Also when I rescanned for devices, Windows just used its default display driver for the card.
Auto contrast problem solved!

Not a solution, but that suggests that there should be something in the nvidia drivers that should be able to disable the auto contrast "feature"

I was trying to forcibly install the intel HD drivers for the on board chip to possibly access the setting. Not sure exactly how disabled the intel HD chip is, and I couldn't figure out which HD 4X00 drivers to use. both 4700 and 4600 reported my system as not meeting the minimum specs. The system graphics are driven soley by the nvidia card so probably it's probably a dead end anyway

PatRaven
12-12-2014, 07:55 PM
Installed 311.83 and run Surface Tablet Tweak tool and the banding was gone as expected. The tool says that Dynamic contrast is on when I run on batteries but apparently it is actually off.

Yes, theres absolutely something wrong with the Nvidia drivers after 311.83. Well, wrong for us at least =/

iammax
01-10-2015, 07:01 AM
Has anyone found a true solution for this yet?

On wall power it's fine but on battery the brightness dims in certain windows.

I tried many of the things suggested in this topic, but nothing solved it.

My current work-around: When I am on battery, quickly turning off the screen and turning it back on (with fn + F7, I am on a g750jx) makes the problem go away, but only until the next time I plug the computer back to a/c. When I unplug it after that, the problem comes back.

hurleytom
01-22-2015, 11:02 PM
I've found a sort-of solution. If I disable Intel(R) HD GRaphics 4600 in Device Manager, the display doesn't auto-dim anymore. However when I now try to run Nvidia Control Panel it gives the error: "NVIDIA Display settings are not available. You are not currently using a display attached to an NVIDA GPU".

I haven't tried running any games yet to check performance...

iammax
01-24-2015, 04:18 PM
I don't have dual cards, you must be on a different laptop than I am

Darnassus
01-24-2015, 06:31 PM
Is this STILL going on? I thought it was fixed ages ago by some automatic update.. I've not had the problem since, and I did a fresh OS install only a couple of months ago.


Edit: Still happens to me while on battery which is weird. Not when plugged in the wall however.

hurleytom
01-27-2015, 06:54 PM
Edit: Still happens to me while on battery which is weird. Not when plugged in the wall however.

Same here. Only while on battery...

hurleytom
01-27-2015, 07:00 PM
Wow! Just fixed it on battery with number 4 here (already had 1-3 done):
http://www.eightforums.com/tutorials/6042-adaptive-brightness-turn-off-windows-8-a.html

Maxter
01-27-2015, 11:30 PM
Is this STILL going on? I thought it was fixed ages ago by some automatic update.. I've not had the problem since, and I did a fresh OS install only a couple of months ago.


Edit: Still happens to me while on battery which is weird. Not when plugged in the wall however.

I had the 335.23 drivers and it was only happening on battery. I updated to 347.25 and now i happens all the time... poop

RelentlessXJR
02-25-2015, 10:06 PM
To anyone still dealing with this:

This is a feature, not a bug. It is because Nvidia Optimus switches to the integrated graphics of the cpu any time a dedicated gpu is not absolutely required so you have to turn off the iGPU's adaptive setting as well. In order to disable all automatic backlight/brightness/contrast adjustment, you now have to do so in 3 separate places: Nvidia control panel, windows control panel, and intel HD graphics control panel. The intel option is called display power saving technology, and is in the power menu of the Intel HD control panel.

Light
03-04-2015, 01:23 PM
I have the same problem with the contrast. After restarting the laptop the contrast goes super bright, this is a real pain especially when working in dull light or dark conditions when I require lower brightness & contrast settings. When I perform a restart/reboot I find I need to Restore Defaults in the NVIDIA Control Panel and then reset all my preferences for the Adjust Desktop Colour Settings and Apply. I've never met this type of issue before on any other laptop make or model except this ASUS G750JW, which begs the question, how did this obvious issue get missed during testing ?

With reference to the previous post, I cannot find an Intel HD graphics control panel. The Device Manager only shows Display adaptors info for NVIDIA GTX 765M. How is the Intel HD graphics control panel accessed ?

kidfromhell
03-04-2015, 05:27 PM
I have the same problem with the contrast. After restarting the laptop the contrast goes super bright, this is a real pain especially when working in dull light or dark conditions when I require lower brightness & contrast settings. When I perform a restart/reboot I find I need to Restore Defaults in the NVIDIA Control Panel and then reset all my preferences for the Adjust Desktop Colour Settings and Apply. I've never met this type of issue before on any other laptop make or model except this ASUS G750JW, which begs the question, how did this obvious issue get missed during testing ?

With reference to the previous post, I cannot find an Intel HD graphics control panel. The Device Manager only shows Display adaptors info for NVIDIA GTX 765M. How is the Intel HD graphics control panel accessed ?

Woah ,it's been time since I visited this thread and it looks like this issue is getting worse over time. And for your question, the G750 JX/JW series notebooks doesn't come with Intel HD control panel because it's simple - it doesn't have an Intel card and it doesn't support Optimus either. You just have the GeForce Experience/nVidia Card.

Maxter
03-04-2015, 09:14 PM
To anyone still dealing with this:

This is a feature, not a bug. It is because Nvidia Optimus switches to the integrated graphics of the cpu any time a dedicated gpu is not absolutely required so you have to turn off the iGPU's adaptive setting as well. In order to disable all automatic backlight/brightness/contrast adjustment, you now have to do so in 3 separate places: Nvidia control panel, windows control panel, and intel HD graphics control panel. The intel option is called display power saving technology, and is in the power menu of the Intel HD control panel.

I have the G750JW. The integrated video card has been physically disconnected on these models. Only the GTX765m is available. The issue still stands.

Light
03-05-2015, 01:15 PM
Thanks for the responses, most appreciated.

This type of issue/defect and the fact it has not being fixed by ASUS is unacceptable. It suggests a lack of rigorous quality control in their testing procedures. It is such a simply defect to reproduce it should never have made it into the released product.

If ASUS decide not to fix this issue soon I will go elsewhere for my next purchase.

iammax
03-12-2015, 02:17 PM
Still looking for a solution to this... as has been said, it's not an optimus/integrated graphics issue because not all the models have integrated (mine doesn't, and I still have the dimming/auto contrast issue when on battery).

Light
03-14-2015, 01:16 PM
I installed version 311.83 and the issue still exists. In fact the issues exists in every version I've tried.

To reproduce simply perform the following actions:

Open the "NVIDIA Control Panel"

Display -> Adjust desktop colour settings

Use NVIDIA settings

Brightness 0%
Contrast 0%
Gamma 0.50%
Digital vibrance 15%

Apply

Use power button to Shutdown
Use power button to Start

Screen contrast changes from high contrast to lower contrast then high contrast.

Would someone in ASUS support please respond as soon as possible as to why this is happening ?

cl-Albert
03-16-2015, 11:33 PM
I installed version 311.83 and the issue still exists. In fact the issues exists in every version I've tried.

To reproduce simply perform the following actions:

Open the "NVIDIA Control Panel"

Display -> Adjust desktop colour settings

Use NVIDIA settings

Brightness 0%
Contrast 0%
Gamma 0.50%
Digital vibrance 15%

Apply

Use power button to Shutdown
Use power button to Start

Screen contrast changes from high contrast to lower contrast then high contrast.

Would someone in ASUS support please respond as soon as possible as to why this is happening ?

Light, I don't know that this problem is happening for everyone on every G750JW/JX unit, and appears to be rather elusive at this point on the ASUS side as far as I can tell.

Unfortunately, I don't have either of those units around right now to play with, but when I had the G750JW, this issue wasn't noticeable on my unit although I wasn't looking for it if it matters.
By the way curious if the NVidia Control Panel settings you provided are the defaults or what happens if you use the default settings.

Anyway, I'm not so sure that ASUS repair has been able to catch or see the problem, so suggest working with them or your local ASUS support especially if you are still under warranty.
If you can actually show ASUS repair the issue in person, this would probably be best, but if you are able to tell them how to catch the problem, this should hopefully be good enough although they will probably want you to send back your unit for repair.

http://www.asus.com/support/callus

If you haven't looked through all the posts in this thread though, consider checking them as well to see if they can help (remove Power4 Gear, disable adaptive brightness, etc.) for your case.

If ASUS repair is able to catch the issue though, suspect they would first try to erase and reinstall Windows to see if the problem is still there and then update to the latest drivers posted on the ASUS download site (as well as bios which you may not want to fool around with if you don't want to take any chances), so something you may want to consider trying as well if you think it's a good idea (don't remember if people have reported trying these things already, but expect our repair would try them anyway to try to eliminate any software-related issues).

Well, hope this helps and makes sense. Sorry that I'm not able to help more on my end or provide a solution.

Light
03-17-2015, 02:09 PM
Thank you for your response cl-Albert. The settings I have shown are those set by me.

Once the above steps I have described are followed the issue occurs every time. To get rid of the high contrast issue I have to press the "Restore Defaults" in Open the "NVIDIA Control Panel -> Display -> Adjust desktop colour settings, after that I can set Brightness, Contrast, Gamma to anything and the display colours function as expected. However, when I'm working in reduced light or lights out and I need to adjust the Brightness, Contrast, Gamma to lower settings as I have provided in my previous post, then when I Shutdown and then Start the display is overexposed as described above.

I have already done all the things you mentioned, reinstall etc. latest drivers, remove Power4 Gear, disable adaptive brightness, etc. none of them make any difference. I have spent many hours on this issue and it is really simple to reproduce following the instructions I have already posted.

Someone at ASUS simply needs to follow the instructions I have provided to reproduce the issue. I am using a G750JW fitted with the standard GTX 765M.

Aaron44126
03-19-2015, 06:55 PM
Anyone still having this issue? I've been tracking it down and I found a solution that works for me and has not been covered in this thread.

The issue is the power setting for "Adaptive backlight" (*different than "Adaptive brightness"*) which is handled by the NVIDIA driver. For some reason, the GUI to configure this option doesn't always show up in the Windows Power Options. You can do it in the registry.

First, if you are having the issue, try changing your power profile to "High performance" and see if it goes away. The default settings are that you will see this issue always if you are on the "Power saver" profile, on battery only if you are on the "Balanced" profile, and you shouldn't see it at all on the "High performance" profile.

If you want to use the "Balanced" or "Power saver" profile (or a custom profile), you need to make a registry change to get this issue to go away.

Four steps.

1. Search the registry for "aded5e82-b909-4619-9949-f5d71dac0bcc". If you see a key with this name under HKLM\SYSTEM\CurrentControlSet\Control\Power\User\P owerSchemes, see if you have values for "ACSettingIndex" and "DCSettingIndex" under this key. If you do, set them to 0 if they are not already set.

2. Navigate in regedit to "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Power\PowerSettings". Go through each of the keys here and see if you have a subkey named "aded5e82-b909-4619-9949-f5d71dac0bcc". If you find it, drill down to "DefaultPowerSchemeValues", and under each key there, set the "ACSettingIndex" and "DCSettingIndex" to 0.

This registry snippet will set the appropriate values for the default "High performance", "Balanced", and "Power saver" plans, and may help you find the appropriate values to change if you are having trouble following my previous statements. :-)


Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Power\PowerSettings\7516b95f-f776-4464-8c53-06167f40cc99\aded5e82-b909-4619-9949-f5d71dac0bcc\DefaultPowerSchemeValues]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Power\PowerSettings\7516b95f-f776-4464-8c53-06167f40cc99\aded5e82-b909-4619-9949-f5d71dac0bcc\DefaultPowerSchemeValues\381b4222-f694-41f0-9685-ff5bb260df2e]
"DCSettingIndex"=dword:00000000
"ACSettingIndex"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Power\PowerSettings\7516b95f-f776-4464-8c53-06167f40cc99\aded5e82-b909-4619-9949-f5d71dac0bcc\DefaultPowerSchemeValues\8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c]
"DCSettingIndex"=dword:00000000
"ACSettingIndex"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Power\PowerSettings\7516b95f-f776-4464-8c53-06167f40cc99\aded5e82-b909-4619-9949-f5d71dac0bcc\DefaultPowerSchemeValues\a1841308-3541-4fab-bc81-f71556f20b4a]
"DCSettingIndex"=dword:00000000
"ACSettingIndex"=dword:00000000


[Edit] Not sure if my quote worked, it looks like the board added some extra spaces in the word "Control". You should probably track this down manually.

3. Reboot, I guess, to make sure the changes take effect.

4. Profit!

Light
03-21-2015, 04:16 PM
Aaron, I followed all your steps and they didn't make any difference. As soon as a restart is done the auto contrast comes back.

Larkstarr
03-24-2015, 12:37 AM
Anyone still having this issue? I've been tracking it down and I found a solution that works for me and has not been covered in this thread.

The issue is the power setting for "Adaptive backlight" (*different than "Adaptive brightness"*) which is handled by the NVIDIA driver. For some reason, the GUI to configure this option doesn't always show up in the Windows Power Options. You can do it in the registry.

First, if you are having the issue, try changing your power profile to "High performance" and see if it goes away. The default settings are that you will see this issue always if you are on the "Power saver" profile, on battery only if you are on the "Balanced" profile, and you shouldn't see it at all on the "High performance" profile.

If you want to use the "Balanced" or "Power saver" profile (or a custom profile), you need to make a registry change to get this issue to go away.

Four steps.

1. Search the registry for "aded5e82-b909-4619-9949-f5d71dac0bcc". If you see a key with this name under HKLM\SYSTEM\CurrentControlSet\Control\Power\User\P owerSchemes, see if you have values for "ACSettingIndex" and "DCSettingIndex" under this key. If you do, set them to 0 if they are not already set.

2. Navigate in regedit to "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Power\PowerSettings". Go through each of the keys here and see if you have a subkey named "aded5e82-b909-4619-9949-f5d71dac0bcc". If you find it, drill down to "DefaultPowerSchemeValues", and under each key there, set the "ACSettingIndex" and "DCSettingIndex" to 0.

This registry snippet will set the appropriate values for the default "High performance", "Balanced", and "Power saver" plans, and may help you find the appropriate values to change if you are having trouble following my previous statements. :-)



[Edit] Not sure if my quote worked, it looks like the board added some extra spaces in the word "Control". You should probably track this down manually.

3. Reboot, I guess, to make sure the changes take effect.

4. Profit!


WOW, I followed these steps and it worked .. for the most part! I seem to be getting some slight contrast changes still, but it's not NEARLY as bad or noticeable as it was previously, and it could just be my eyes .. hard to break a bad habit.

I registered for the forums just to say thank you, Aaron! You've saved my sanity.

Light
03-24-2015, 12:02 PM
To reproduce simply perform the following actions:

Open the "NVIDIA Control Panel"

Display -> Adjust desktop colour settings

Use NVIDIA settings

Brightness 0%
Contrast 0%
Gamma 0.50%
Digital vibrance 15%

Apply

Use power button to Shutdown
Use power button to Start

Screen contrast changes from high contrast to lower contrast then high contrast.

Would someone in ASUS support please respond as soon as possible as to why this is happening ?

Larkstarr, would you please follow the sequence of events I have outlined above and see if you can reproduce the issue ?
Also which ASUS model and NVIDIA graphics card are you using ?

Thanks.

Malnacid0
03-26-2015, 12:54 PM
Exists a definitive solution for this problem?

I have an Asus N551JQ, and I'm very angry with this problem...

Already I have tried all the solutions I read in this thread, but I still having the auto contrast/brightness.

Light
03-26-2015, 09:20 PM
Malnacid0, I feel the same. It seems ASUS can't be bothered to fix this. You have a completely different machine to the G750JW I have, you have a different graphics card and processor etc. so it seems this issue appears to be widespread across other ASUS machines. I'm so fed up with the lack of support and help from ASUS regarding this issue that I've decided to look into getting a new machine from a different manufacturer, the ASUS will be stripped and the rest will go to be recycled, unless someone at ASUS promises they will take this issue seriously and the issue will be fixed within the next few days.

hmscott
03-26-2015, 11:09 PM
Malnacid0, I feel the same. It seems ASUS can't be bothered to fix this. You have a completely different machine to the G750JW I have, you have a different graphics card and processor etc. so it seems this issue appears to be widespread across other ASUS machines. I'm so fed up with the lack of support and help from ASUS regarding this issue that I've decided to look into getting a new machine from a different manufacturer, the ASUS will be stripped and the rest will go to be recycled, unless someone at ASUS promises they will take this issue seriously and the issue will be fixed within the next few days.

Light, if you google this you will find it isn't only Asus laptops, it is a problem with Windows.

For some reason some people never see this problem - like me - and others just can't seem to get away from it.

Not sure what the factors are that make it keep coming back, and unfortunately though others have tried to work with Microsoft to fix this, all the forum threads at Microsoft I can find all lead nowhere, still the issue exists for some, but not others even on the same laptop hardware.

It would be better to focus your attention on Microsoft, not Asus, Dell, HP, etc.

https://www.google.com/search?q=auto+contrast+on+battery+windows+8&ie=utf-8&oe=utf-8

Light
03-27-2015, 01:12 PM
Light, if you google this you will find it isn't only Asus laptops, it is a problem with Windows.

For some reason some people never see this problem - like me - and others just can't seem to get away from it.

Not sure what the factors are that make it keep coming back, and unfortunately though others have tried to work with Microsoft to fix this, all the forum threads at Microsoft I can find all lead nowhere, still the issue exists for some, but not others even on the same laptop hardware.

It would be better to focus your attention on Microsoft, not Asus, Dell, HP, etc.

https://www.google.com/search?q=auto+contrast+on+battery+windows+8&ie=utf-8&oe=utf-8

hmscott, your search "auto contrast on battery windows 8" is a completely different issue and not related to this issue.
Auto contrast on the ASUS G750JW can be toggled on/off and works as per Windows designed it to worked, it functions on power and/or battery.

I deinstalled the NDIVIA driver and supporting software and the problem still exists but only when using Shutdown.

Would you please do as I have described below to see if you can reproduce this issue.

Open the "NVIDIA Control Panel"

Display -> Adjust desktop colour settings

Use NVIDIA settings

Brightness 0%
Contrast 0%
Gamma 0.50%
Digital vibrance 15%

Apply

Use power button to Shutdown, then wait at least 10 seconds.
Use power button to Start

The screen contrast changes from high contrast to lower contrast then high contrast and stays on high contrast and the colours
are incorrect as per the settings prior to Shutdown.

Then go into the "NVIDIA Control Panel"

Display -> Adjust desktop colour settings

Note, prior to Applying the above colour settings the "Use NVIDIA settings" was selected
now after the Shutdown and Startup the "Other applications control colour settings" is selected.

Thanks.

Aaron44126
03-30-2015, 02:05 PM
WOW, I followed these steps and it worked .. for the most part! I seem to be getting some slight contrast changes still, but it's not NEARLY as bad or noticeable as it was previously, and it could just be my eyes .. hard to break a bad habit.

I registered for the forums just to say thank you, Aaron! You've saved my sanity.

Glad it helped someone.

I still have another machine with this issue that my registry fix above did not help. As others have noted, for some reason the same solution doesn't work for everyone and not everyone has been able to find a solution.

The machine in question is not an ASUS machine, but a Dell Precision M6700 with NVIDIA Quadro K5000M. (Really obnoxious to have this issue in such a high-end machine.)

The common thread seems to be machines with NVIDIA GPUs and no graphics switching. In my case it only affects the laptop internal display, not connected external displays. Also, at least in my case, reverting to a driver older than 325.xx fixes the problem (though this won't be possible with newer GPUs), so this is definitely some sort of software/driver issue and not hardware, and it's not specific to ASUS; it's something to do with the NVIDIA drivers and Windows itself.

325.xx is when they moved up to WDDM 1.3 for Windows 8.1. Sort of hoping it just works itself out when they switch to WDDM 2.0 / Windows 10 drivers (looks like this is happening with 350.xx).

Still looking for another solution to fix my Precision. Hopefully someone else comes up with something yet. :-)

Light
03-31-2015, 08:18 PM
I've done some debugging and the problem seems to be with the two programs below.
When both of these programs are disabled in Startup the Auto/High Contrast issue disappears.

The information below was extracted from CCleaner->Scheduled Tasks

Enabled Key Program Publisher File
No Task ASUS Splendid ACMON ASUS C:\Program Files (x86)\ASUS\Splendid\ACMON.exe
No Task ASUS Splendid ColorU ASUSTeK Computer Inc. C:\Program Files (x86)\ASUS\Splendid\ColorUService.exe

I have tested using the method on how to reproduce the problem in my previous post.
No Auto/High Contrast occurs after a Shutdown or Restart.
The NVIDIA Control Panel->Display->Adjust desktop colour settings "Use NVIDIA settings" stays selected,
it no longer switches to "Other applications control colour settings" after a Shutdown or Restart.

Would someone from ASUS support please investigate the above two programs and ascertain the cause and effect
and provide a fix please. Thank you.

hmscott
04-01-2015, 11:16 AM
I've done some debugging and the problem seems to be with the two programs below.
When both of these programs are disabled in Startup the Auto/High Contrast issue disappears.

The information below was extracted from CCleaner->Scheduled Tasks

Enabled Key Program Publisher File
No Task ASUS Splendid ACMON ASUS C:\Program Files (x86)\ASUS\Splendid\ACMON.exe
No Task ASUS Splendid ColorU ASUSTeK Computer Inc. C:\Program Files (x86)\ASUS\Splendid\ColorUService.exe

I have tested using the method on how to reproduce the problem in my previous post.
No Auto/High Contrast occurs after a Shutdown or Restart.
The NVIDIA Control Panel->Display->Adjust desktop colour settings "Use NVIDIA settings" stays selected,
it no longer switches to "Other applications control colour settings" after a Shutdown or Restart.

Would someone from ASUS support please investigate the above two programs and ascertain the cause and effect
and provide a fix please. Thank you.

Light, that is very interesting, early on I suggested uninstalling Asus Splendid as part of debugging this auto-contrast issue, and I thought people did and said it didn't help.

I still recommend uninstalling Asus Splendid because it messes with the color profile it installs and does a poor job of it. And, many did uninstall it, so I am surprised there are still people out there running it... good catch.

Another excellent reason to uninstall Asus Splendid, at least for you it solved the auto-contrast problem, I hope others try it to see if it stops auto-contrast for them too.

PatRaven
04-06-2015, 08:20 PM
1. I really doubt it has much to do with Splendid as mentioned in the previous post. Splendind was one of the first things I got rid of and after that I have tested everything in this thread and much more. The only 100 % working fix was to use the outdated 311.83 driver. Besides I have also tried using a clean install of 8.1 without any bloat-ware from Asus and for sure Splendid is not installed at all, but still the problem is there from start. I would like to rule out that Splendid cause the problem.

2. A few weeks ago I tried the method mention in the post http://rog.asus.com/forum/showthread.php?43315-Auto-contrast-is-driving-me-nuts!!&p=485089&viewfull=1#post485089 by Aaron44126. I went directly into the registry and zeroed out the mentioned keys. As soon as I pull out the AC adapter there’s a slight dim of the screen, perhaps 5%. But after that it remains stable. I haven’t used my laptop without the AC adaptor as much as I have the last couple of weeks just because I enjoy it now that it seems to work. I haven’t even tried to make any further changes or reverted back to original values. I DO NOT DARE! And the best of all is that I now am running the Nvidia driver 347.52. Woooohaaaa!!! So I advise everybody with an G750JX to try the post mentioned and report back!

Br,
Pat!

Malnacid0
04-06-2015, 09:39 PM
I have fixed this problem unistalling the intel graphics driver, rebooting, and installing this driver automatically with Windows.

Bobert2
04-08-2015, 08:49 PM
Anyone still having this issue? I've been tracking it down and I found a solution that works for me and has not been covered in this thread.

The issue is the power setting for "Adaptive backlight" (*different than "Adaptive brightness"*) which is handled by the NVIDIA driver. For some reason, the GUI to configure this option doesn't always show up in the Windows Power Options. You can do it in the registry.

First, if you are having the issue, try changing your power profile to "High performance" and see if it goes away. The default settings are that you will see this issue always if you are on the "Power saver" profile, on battery only if you are on the "Balanced" profile, and you shouldn't see it at all on the "High performance" profile.

If you want to use the "Balanced" or "Power saver" profile (or a custom profile), you need to make a registry change to get this issue to go away.

Four steps.

1. Search the registry for "aded5e82-b909-4619-9949-f5d71dac0bcc". If you see a key with this name under HKLM\SYSTEM\CurrentControlSet\Control\Power\User\P owerSchemes, see if you have values for "ACSettingIndex" and "DCSettingIndex" under this key. If you do, set them to 0 if they are not already set.

2. Navigate in regedit to "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Power\PowerSettings". Go through each of the keys here and see if you have a subkey named "aded5e82-b909-4619-9949-f5d71dac0bcc". If you find it, drill down to "DefaultPowerSchemeValues", and under each key there, set the "ACSettingIndex" and "DCSettingIndex" to 0.

This registry snippet will set the appropriate values for the default "High performance", "Balanced", and "Power saver" plans, and may help you find the appropriate values to change if you are having trouble following my previous statements. :-)



[Edit] Not sure if my quote worked, it looks like the board added some extra spaces in the word "Control". You should probably track this down manually.

3. Reboot, I guess, to make sure the changes take effect.

4. Profit!

Wow, thank you for discovering this fix.

I had just about given up on this problem for the past couple of years. And today when I accidentally hibernated my laptop again, I thought maybe there was a real solution out by now. After rebooting, I hibernated the laptop again and confirmed that it works.

Here are the things that I tried that DID NOT WORK or at least seemed to work until the next hibernate.

- Disabling Sensor Montoring Service.
- Disabling NVIDIA Stereoscopic 3D Driver Service and NVIDIA Streamer Service.
- Changing Enable adaptive brightness to off on all 3 power plans.
- Adjust video color settings in the NVIDIA control panel and disable Dynamic contrast enhancement and color enhancement.

I can't believe the problem was a hidden setting that could only be found by searching regedit. Quite ridiculous if you ask me.

Light
04-14-2015, 01:54 PM
One of the 2 latest updates from Microsoft caused the return of HIGH CONTRAST on my machine, and I couldn't find a quick way to turn off HIGH CONTRAST.

This is the one responsible: Update for Windows 8.1 for x64-based Systems (KB2958262)

I de-installed it and the high contrast issue disappeared.

Be interested to know what others experience.

PatRaven
04-14-2015, 06:37 PM
One of the 2 latest updates from Microsoft caused the return of HIGH CONTRAST on my machine, and I couldn't find a quick way to turn off HIGH CONTRAST.

This is the one responsible: Update for Windows 8.1 for x64-based Systems (KB2958262)

I de-installed it and the high contrast issue disappeared.

Be interested to know what others experience.

Well that update is from May 2014, so its rather old. I cant find it under already installed updates and its not in Windows Update as an available update. So I have no feedback at all to give you.

Br, Pat!

Light
04-14-2015, 08:20 PM
You're right Pat, I'm not sure what was going on at the time.

Since then I have received a whole bunch of new Microsoft updates and installed them, restarted and HIGH CONTRAST was turned on. I did a Shutdown and waited around 10 secs and then started and no sign of high contrast. Also no sign of update KB2958262 being installed.
Oh well, back to some sort of normality.

Aaron44126
04-30-2015, 02:47 PM
Alright. A consistent solution to this problem is to use an older driver (as mentioned in the very first post). This issue was introduced when NVIDIA released the first WDDM 1.3 / Windows 8.1 drivers, I think the version was 325.xx. No drivers that use WDDM 1.2 or earlier have this issue.

WDDM 2.0 / Windows 10 beta drivers are out now and I plan to test later to see if the problem still exists with these drivers. I won't have time until late this evening, but I will post back with the results. If anyone else would like to test in the meantime, go to this page:

http://www.nvidia.com/Download/Find.aspx?lang=en-us

Pick your GPU, select Windows 10 for the OS and the "Beta" option from the last dropdown.

(I am expecting that these drivers will also work with Windows 7/8/8.1, even though they are labeled for Windows 10, as NVIDIA usually releases unified drivers and one would expect this to continue once Windows 10 is released. Haven't tested it though.)

[Edit]
Nevermind, can't try without Windows 10 installed. Both the installer and the device manager will not take the new driver (under Windows 8.1). Looks like Windows 10 drivers are different enough that there may be a split...
This weekend I might install Windows 10 on a different hard drive and check and see if this issue is still present.

Aaron44126
05-02-2015, 02:44 PM
Update:
Did Windows 10 install with 352.63 NVIDIA drivers and the auto contrast issue did not present itself. Hoping this issue will be fixed after upgrading to Windows 10 final.

hmscott
05-02-2015, 07:44 PM
Update:
Did Windows 10 install with 352.63 NVIDIA drivers and the auto contrast issue did not present itself. Hoping this issue will be fixed after upgrading to Windows 10 final.

Aaron44126, quiet!, don't let Nvidia know they broke the borked auto-contrast feature, or they will fix it in a driver update! ;)

hmscott
05-06-2015, 07:20 AM
Guys, not sure if this is related, but it might be worth looking into, it came as an optional update this last week Tuesday

Automatic brightness option is disabled unexpectedly after you switch between PC settings pages in Windows
https://support.microsoft.com/en-us/kb/3013538

Update for Windows 8.1 for x64-based Systems (KB3013538)
https://www.microsoft.com/en-us/download/details.aspx?id=46735

Found it in the breakdown of the 34 optional patches that came out last Tuesday:

This month's second Patch Tuesday brings 34 Windows updates, all optional
http://www.zdnet.com/article/this-months-second-patch-tuesday-brings-34-updates-all-optional/

ludigrga
05-06-2015, 06:22 PM
PatRaven, there are two major AdaptiveDisplayBrightness registry tree's, here are both as .reg.zip files, let us know if it helps :)

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AdaptiveDisplayBrightness
36961

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\ Windows NT\CurrentVersion\AdaptiveDisplayBrightness
36962


Hi

i'm new here.
I have g751jy running on win 7. Had a problem with adjusting screen brightness. Applying your .reg files and rebooting fixed my problem.

Thanks

aczelkri
05-25-2015, 06:59 PM
This is what solved the issue for me on G751JM

https://rog.asus.com/forum/showthread.php?35882-Cannot-disable-annoying-Auto-dimming-screen-brightness/page2

1. Search Windows for 'Intel'
2. Select 'Intel HD Graphics Control Panel'
3. Click the 'Power' square button
4. Click 'On Battery' tab
5. Disable 'Display Power Saving Technology' (I see it as the last option)

Hope it works for you too.

Aaron44126
07-16-2015, 12:15 PM
Update:
Did Windows 10 install with 352.63 NVIDIA drivers and the auto contrast issue did not present itself. Hoping this issue will be fixed after upgrading to Windows 10 final.

Upgraded existing Windows 8.1 install (with this issue) to Windows 10 and the problem still exists on NVIDIA drivers 353.30. Issue does not appear on a clean install. So, I've got some configuration issue hanging around that's causing the issue. Going to spend some time with it this weekend, hopefully can come up with yet another possible solution.

[Edit]
Nevermind... Must be crazy. My clean Windows install has the issue after all. So it doesn't appear to be a simple configuration issue (or the issue is included in the default config).

PatRaven
10-30-2015, 09:44 PM
Hi guys,
Long time and no news? :cool: I must admit I have been a bit reluctant to update to Windows 10, but today I decided to try it out. It took approx. 30 minutes including download. I use a SSD for my OS-disk so I guess that speed up the process. EVERYHTING went fine and no glitches what so ever during the upgrade process. I would say it was the smoothest transition ever. Windows 10 seems solid and I recommend it. I even turned off Classic Shell to see possible benefits of the new start menu and there are some… To make the story short: There’s no dimming, auto-contrast or whatever we call when I run on batteries. Great! ;)

Br,
Pat

wednesdayraven
11-27-2015, 04:47 PM
Good day,

Just like you all, I've found that the only way to get rid of it is by installing the latest nvidia driver to rectify this.....i know that many of you are gamers with this hardware and might not want the latest due to some compatibility issue with some games.
(I've did everything from changing the dynamic contrast setting in nvidia control panel, turn off the adaptive brightness setting in power option, press Fn+A .......etc. Non of it worked for me)

Thus recommend use the version of the nvidia (usually not the latest) from the official Asus website to get the driver following your model and walah......dimming is gone !! XD

Hope this helps everyone as i have heard lots of people finding this feature annoying as much as I have !

P.S : I'm using the Asus G751JT gaming laptop wth Windows 8.1.

Cheers

Chris86
05-07-2018, 03:42 PM
This has been driving me batty today but I figured I'll throw this in for peeps in future trying to find their SOLVED!
I too thought it would be a power/driver issue and I've recently been messing with settings a lot to optimise for Subnautica.

For me it was...the actual physical monitor settings. I'm using a second monitor instead of my G751jy monitor and couldn't figure why adjusting brightness wasn't working. I was also getting the ridiculous dimming on a darker screen (such as this one, and in Subnautica). Turns out it was a setting on the monitor options itself.

I had it set to Magic Colour(TM) which messes with the contrast. I've just been away for 2 weeks which is why this caught me out but it was doing the exact same thing many have described here...adjusting the picture according to the screen.

TLDR: These days with so many people using 2nd monitors...check your monitors physical settings before pulling your hair out over drivers and such!

Hope this helps somebody.

Aaron44126
06-25-2018, 08:22 PM
Regarding the driver bug, it is reportedly fixed with the ASUS version of the NVIDIA drivers as of late 2015.
It is fixed in the generic version of the NVIDIA drivers as of early 2018 (390 series drivers).