View Full Version : Suddenly can't disable touchpad, laptop seems to think it's a proper mouse

01-31-2014, 05:02 AM
So I've been using my G55 for almost a year now, and this morning just before I went to work, it suddenly winked out. Powered itself off right in the middle of a session, like somebody pulled out the plug. It's a bit worrisome, but I've had similar things happening to laptops over the years when I've had it on for a while, so I didn't think much of it.

And then when I turned it back on again, I found, too my surprise, that the touchpad is working when my finger brushes on it. I have my mouse plugged in, and I've the touchpad set to disable whenever the mouse is plugged.

So I tried pressing Fn+F9. Nothing. The 'wait' blue circle thing in Windows 8 shows up for a brief half-second, but the touchpad still works.

I went to control panel --> mouse, to see if anything changed, and sure enough it did.

The 'touchpad/Elantech' tab isn't there anymore.

I tried going into the hardware tab, and it seems that the laptop thinks the touchpad is a proper PS/2 mouse, which is why it wouldn't register as a touchpad. Following some advice on the internet, I redownloaded the drivers from the Asus page and reinstalled it, but it still doesn't work. The touchpad still can't be disabled whatever I do, which is extremely annoying, because you know this thing is oversensitive. Sometimes having your fingers hovering over it would cause it to respond.

Anyone has any idea what went wrong? Is it possible that in lugging it around, something fell off its proper place hardware-wise so the computer can't recognize it as a touchpad?

EDIT : DisableWhenDetectUSBMouse is at 1 in the registry, so it SHOULD stay disabled. Yet it doesn't. I have no idea what's going on.

EDIT 2 : Found a shoestring-and-glue solution. Running either EDCtrl or EDGestures in Program Files/Elantech causes it to work properly. (I'm not sure which one because I, uh, kind of ran all of them, but it's not Mag or Helper, I think.) So now I've thrown that into my Startup folder and hopefully it'll work. If it doesn't, I'll just make a shortcut to it somewhere and manually do it whenever I boot up. Bleah.