PDA

View Full Version : Asus G46VW Bios will not detect HDD or SSD, USB Flashdrive OS does



arky0011
01-31-2014, 05:41 AM
Machine: Asus G46VW Laptop

Ok, I have been trying to figure this out. It seems most people have the opposite problem where the OS does not detect the HDD/SSD.

My computer was working fine but when I turned it on today, it went straight to bios instead of normally booting to Windows 8. Within BIOS, I can not see my HDD at all. At first, I thought it was a HDD problem, so I bought a SSD to test out that theory. The same problem occurred. BIOS will not detect the HDD or SSD. I followed this up with flashing my bios to the newest one, same results.:pfff:

The thing is, I can boot my computer from a USB thumbdrive with an OS (Pinguy) on it. I can even install the OS from the USB drive, onto my SSD... meaning, the OS can detect my SSD just fine. But when I reboot and take out my USB drive, the computer boots straight to BIOS and the SSD/HDD are no where to be found.

Hoping someone can shed some light on this matter. Thank you!

UPDATE: I tried to do the same thing with a Windows 8 boot usb. It says that Windows cannot be installed on to the hard drive...make sure the controller is enabled in bios. But why did it recognize that there is a SSD there??:/:(

Clintlgm
01-31-2014, 03:33 PM
Try disabling Secure boot and enabling CSM, You can't install a MBR version of windows on a UEFI GPT disk and visa versa. This is addressed in this sticky thread (http://rog.asus.com/forum/showthread.php?28758-GUIDE-G55-G75-Upgrade-Notes&country=&status=)

echineko
02-01-2014, 04:19 AM
Hi there,

I suspect you are having the same problem as me (http://rog.asus.com/forum/showthread.php?43415-Devices-not-visible-in-boot-menu&country=&status=) , I was able to get a solution by doing a fresh install with the workaround provided in this link (http://www.eightforums.com/tutorials/15458-uefi-bootable-usb-flash-drive-create-windows.html) .

If possible within your BIOS, try a fresh install after disabling the UEFI setting. I'm guessing it will be the same as my G75 BIOS version which does not have this option available anymore.

Hope that helps,
echineko

arky0011
02-03-2014, 03:51 PM
hey guys! Thanks for the replies. What ended up working was created a Windows 8 USB flash drive with GPT and turning on Fast Boot. I had Fast Boot turned off and had CSM enabled but it didn't work after I created the boot drive so I just tried turning on Fast Boot and my computer detected the drive.... very strange. But I'm glad it worked!

BlackFireGamer
07-06-2014, 12:26 AM
Hello I got an Asus G46VW laptop and i have had some problems lately. The other day i went to get on to play some video games and it wouldn't load the bios so my father tried to fix the bios and after that restarted the computer then the computer wouldn't post. This is the first problem I've had with the computer and its a great computer please get back to me as soon as possible. Thank you

Clintlgm
07-06-2014, 02:39 PM
Sounds like you converted your hard drive to MBR, Windows 8 by default installs UEFI. Your System is UEFI by default. See this thread for your solution Upgrade Notes and Guides (http://rog.asus.com/forum/showthread.php?28758-GUIDE-G55-G75-Upgrade-Notes&country=&status=)

WeeKantoro
08-30-2015, 01:54 PM
Try disabling Secure boot and enabling CSM, You can't install a MBR version of windows on a UEFI GPT disk and visa versa. This is addressed in this sticky thread (http://rog.asus.com/forum/showthread.php?28758-GUIDE-G55-G75-Upgrade-Notes&country=&status=)

OH GOD THAT WORKS!!
Thank you very much