PDA

View Full Version : USB port on G55VW acting really strange



Nahrga
02-11-2014, 06:35 PM
Hello there..

One of my USB ports on my G55VW is acting really strange. When I for example connect my mouse to that port, the mouse buttons will most of the time not react. Sometimes it will keep clicking, even though I'm not even toucing the mouse (My mouse works fine on any other USB port). Using the USB port will sometimes also result in loosing connection to my keyboard, however, all the f hotkeys still work.

The last 2 months, the "broken" USB port has been used by my Asus Xonar U3 USB soundcard, until it started loosing conection I testet the USB port with my mouse. It was when I realized that something was wrong.

I have tried deleting the Xonar U3 drivers, but it didn't help.
- I believe that the Xonar U3 soundcard may have fried the USB port or that it maybe somehow could be driver related?

EDIT: When I press or hold down a key on my keyboard, it "locks" my mouse/USB port. But only on that USB port..

EDIT2: I recently updated keyboard device filter, could that be the problem?

EDIT3: nvm, I fixed it. The Windows 8.1 update made my USB port into a "touchpad", by typing on the keyboard it switched the USB port off. I removed the touchpad delay setting in the PC and devices settings and the problem disappeared....

Clintlgm
02-12-2014, 04:15 PM
I think that if your only having issues on 1 usb port that the issue would be a hardware issue with that port. Your could RMA it to have repaired, or get a USB hub and just don't use that port?