PDA

View Full Version : New Nvidia WHQL Drivers - 334.89



Thestroj
02-18-2014, 05:26 PM
Nvidia has released new drivers.

Did anyone test it already?

http://www.nvidia.com/download/driverResults.aspx/73216/en-us

sevymar
02-18-2014, 05:47 PM
i got the update notification aswell today but i'm not updating.
Waiting for ASUS to update it on the drivers download page for JX.

pombocom
02-18-2014, 06:22 PM
Will test today.

Thestroj
02-18-2014, 07:41 PM
I have tested the drivers.

Everything seems fine.
Reboot time is as it should be.
Horizontal lines on my Chi Mei display are only visible on very very few occasions. (this site is displayed perfectly)
Minor game Fps and stability improvment noticed...

Overall... best driver till now for me... but will see and know more after some time...

Take care

Dream
02-19-2014, 03:20 AM
I updated to 334.89 from 332.21.

I had trouble initially booting into Windows but that was due to an external monitor. (I forgot this happens every time I update the driver, it has to do with Windows settings, not Nvidia). Unplugged the monitor for my second boot, zero problems.

I selected "clean install" as usual.

Haven't had time to game yet, but according to the release notes, I should see significant improvements compared to my most recent driver which was a few updates behind.

fab5yo
02-19-2014, 07:36 AM
I just installed the new Nvidia Drive and it works awesome. Everything is running silky smooth. Best drive to date in my book

noone
02-19-2014, 08:29 AM
JW:
No dramas, works fine so far.
3D Mark benchmark is pretty much the same

No horizontal lines on 60hz screen any more? Pretty happy with that!

Gaming feels a little smoother, feel like I gained a few frames / overall smoothness (in Max Payne 3), no before and after tests, but certainly no worse.

My temps seem cooler if anything, which can only be good (not that the GPU ever ran hot)

fjollon
02-20-2014, 09:32 AM
Did anyone with the 3D-screen try this driver?

markgoimon
02-20-2014, 10:00 AM
3d seems to work fine on me too...

actually this driver solved my booting problems ( from 10-15 minutes into 20-25s, yes I had the worst nightmare in booting before the said update )

fjollon
02-20-2014, 10:21 AM
Thanks, will try it later today.

fjollon
02-20-2014, 05:30 PM
I upgraded my G750JX (120 Hz 3D) to 334.89 today. I was on the latest Asus driver before - the Asus driver site is down now so I can't see the number of that driver and I am not going to sit and watch it all night. (Edit - I was on V9.18.13.1193 before the update)

Anyway - in 3DMark 11 I had 5052 with the old driver and now I have 5227. So a nice improvement there. The 3D works well also.

No problems so far.

Demonicpagan
02-21-2014, 03:25 AM
I've had issues with the driver crashing on me quite frequently (at least as of today). I just did a clean reinstall and am going to see if it continues to crash.

Skat137321
02-21-2014, 08:08 AM
I've had issues with the driver crashing on me quite frequently (at least as of today). I just did a clean reinstall and am going to see if it continues to crash.

Having the same issue! Let me know if doing a clean install fixes your problem.

Demonicpagan
02-21-2014, 10:56 PM
Doing a clean reinstall did not. I have rolled back to 334.67 beta. I believe that driver didn't cause me any issues like 334.89 is. Am going to continue to monitor the status and see if I still have graphic driver crashes on my system.

CruiserX
02-22-2014, 03:25 AM
Its been 3days since I installed it.. been running smooth. No hiccups or High boot time. Everything perfect. Did a clean install but at first screen went blank and didn't respond for 10 minutes. Hard rebooted the laptop and tried clean install again and it worked fine.

CruiserX
02-22-2014, 03:26 AM
However Facing this issue still on the new driver

http://rog.asus.com/forum/showthread.php?43315-Auto-contrast-is-driving-me-nuts!!/page5

CruiserX
02-22-2014, 03:30 AM
Demonicpagan

Can u be more precise on what kind of crash are you facing?