View Full Version : HELP! I can't downgrade my bios using winflash!

02-25-2014, 05:07 PM
Hi everyone. If anyone can help me on my problem I'd really appreciate it a lot. Previously I upgrade my ROG G750JH to the latest bios version which I found in Asus.com site and that bios version is 204JHA. Now I've change my mind and roll it back again to the older bios version which is 203JHA. Then I tried some test to figure what is the difference between the two bios versions. Now I tried to go back to update to the latest bios version which is 204JHA using winflash and this problem occur. I can't update my bios over winflash when I press the exit my laptop doesn't restart unlike before. Then I tried to update It using Easy Flash and it went fine. Now there's this problem occur in my latest bios version "204JHA" the CPU easily gets hot and the GPU too. So I've decided to go to the original bios version "203JHA" using winflash but I can't manage to roll the bios back. When i press the "Flash" button then it will next say press "Exit" to reboot laptop and apply update, when I press the exit button nothing happens. Can anyone help me with this? I'd really appreciate it. Thanks guys.