PDA

View Full Version : Why Slow On Battery?



amitabhbansal
03-01-2014, 05:08 AM
i am playing Tomb Raider 2013 on G750JX, power plan is High Performance, it is working awesome while power plug is on, but whenever i remove the power source it gets very slow, i checked the power plan and it is on High Performance. Why is it happening?

Darnassus
03-01-2014, 06:00 AM
Don't forget the laptop isn't a real laptop, it's a desktop replacement.

Unplugging it from the wall will make the G750 go into power saving and cut down on chewing the battery too hard. Thus the graphics card isn't getting the 'food' it needs to work at 100%. That's why you see the game start to skip slightly and feel a little laggy.

You can fix this by removing the power4gear program. ( Uninstall it through program manager )

Most do this, but I personally don't want to, I feel it conditions my computer for a well being. Again, my personal thought.

amitabhbansal
03-01-2014, 06:03 AM
Don't forget the laptop isn't a real laptop, it's a desktop replacement.

Unplugging it from the wall will make the G750 go into power saving and cut down on chewing the battery too hard. Thus the graphics card isn't getting the 'food' it needs to work at 100%. That's why you see the game start to skip slightly and feel a little laggy.

You can fix this by removing the power4gear program. ( Uninstall it through program manager )

Most do this, but I personally don't want to, I feel it conditions my computer for a well being. Again, my personal thought.

Thanks for the info brother, i also wont going to remove power4gear. as of my thought the makers of the software made this for healthy laptop or battery.
Thanks again

Darnassus
03-01-2014, 07:06 AM
You're most welcome hon. ;d

You can always temporarily disable it I believe by stopping it from starting up when you boot Windows, just to see how it works out for you. Just know your battery won't last as long I believe, I'd probably estimate 10-20 minutes less life on battery?

cl-Albert
03-03-2014, 06:43 PM
i am playing Tomb Raider 2013 on G750JX, power plan is High Performance, it is working awesome while power plug is on, but whenever i remove the power source it gets very slow, i checked the power plan and it is on High Performance. Why is it happening?

Curious which bios version you are running?

If you want to risk flashing the bios (wait until a better time if necessary since the system may need to be sent back for repair in the worst case scenario of a bios flash failure), a newer version might help some with this as discussed in this sticky thread:
http://rog.asus.com/forum/showthread.php?35062-Processor-stuck-at-.77Ghz-when-unplugged-solved-w-new-bios&country=&status=

amitabhbansal
03-03-2014, 09:24 PM
Curious which bios version you are running?

If you want to risk flashing the bios (wait until a better time if necessary since the system may need to be sent back for repair in the worst case scenario of a bios flash failure), a newer version might help some with this as discussed in this sticky thread:
http://rog.asus.com/forum/showthread.php?35062-Processor-stuck-at-.77Ghz-when-unplugged-solved-w-new-bios&country=&status=

its the latest 209

Darnassus
03-04-2014, 05:37 AM
Apparently 209 isn't nice, 208 is the best. But if you see not many problems especially for start-up and shut-down procedures, wait for another bios revision that's confirmed for safe download and install.

amitabhbansal
03-04-2014, 05:40 AM
Apparently 209 isn't nice, 208 is the best. But if you see not many problems especially for start-up and shut-down procedures, wait for another bios revision that's confirmed for safe download and install.
In 209 i dont have any kind of problem in startup and shutdown

UltimateKyo
03-04-2014, 01:40 PM
I would agree with amitabhbansal, I had not problem with 209 as well. But just to state that I only get drivers update from Asus website directly.