View Full Version : New G53SX won't turn on

09-28-2011, 12:36 AM
I've just bought a brand new G53SX, and I've taken it out of the box, put the battery in, connected the charger, pressed the power button, and nothing.

The charging light both on the charger and the laptop are on, but no matter what it just won't power up

09-28-2011, 12:42 AM
sounds like a bad unit.

tried turning it on without the battery in it?

09-28-2011, 12:50 AM
Yeah, still nothing

09-28-2011, 01:55 AM
I would return it and get an exchange unit.

10-01-2011, 01:45 AM

I am just having the same problem??? Any idea on what was the problem and how you have fixed it?

Thanks in advance

10-01-2011, 03:01 PM
sorry dude, there's really not a fix. you got a defective unit that doesn't turn on. might be a faulty power button or something, return it for another.

word of advice, when you get the new one make sure it powers on before you leave.

i was thinking about this earlier, and i thought, damn, surely all these units didn't just squeak by quality control.

10-01-2011, 05:18 PM
. . . quality control.

roflmao Surely you jest!! I think ASUS needs to increase their sample size. ;)

10-02-2011, 04:42 PM
Remove the battery, disconnect AC, and hit the power button a few times. Then reconnect and try again.