PDA

View Full Version : G73JH - Black Screen, but responsive and works with HDMI/VGA out



Draakor
03-19-2014, 12:12 AM
I own the G73JH-A1 and I've had it since launch. I've performed a re-paste about 2 years ago with IC7 and have had zero heating issues since. Most recently, I have had to replace the main OS drive due to corruption, which I did replace with a Samsung 840 EVO and I regret not changing it sooner.

However, I have run in to an issue when opening games, before I reseated connections it occurred upon login, where my display will initially flicker and finally just shut off.

Summary: Booted up laptop, logged in, browsed the web for an hour and decided to play Diablo 3. Loaded the game up and it sat on character select absolutely fine, as soon as I clicked a menu option in the game, screen flickers and goes black. Prior to today, I would have been able to CtrlAltDel or AltTab to desktop where the display would reappear that is not the case anymore.

I've uninstalled, reinstalled, both current and old and beta drivers, with complete uninstalls, using ATI's uninstaller followed by DDU.

I have been able to successfully utilize both HDMI and VGA output during these blackouts, meaning it is strictly an issue with the laptop display, the gpu, or something in between such as the cable or socket.

I am reaching out to hopefully get an answer during my down time.

jumpserver
04-14-2014, 01:25 PM
im running into similar problem. Debating if its worth looking into replacing the GPU or Display. Im sure its cheaper than buying a whole new laptop at 1.2-1.5k!

QQallday
10-30-2014, 07:42 AM
same issues, did anyone solve this problem? It got worse then crashed like mad and seemed to fix itself, but problem recurring again!