PDA

View Full Version : G75VW: USB devices disabled during Win7 installation!



alecinator
03-21-2014, 11:39 PM
Hi guys. I hope some of you might help me with this rather frustrating issue:

I've been trying to install a fresh copy of Windows 7 on my newly installed SSD disc.
I burned a copy of my Windows ISO onto a DVD disc, but apparently something is wrong with my burner; discs turn up empty.
(Unrelated to the post, but has anyone ever experienced this?)

Anyways, I put the ISO on a USB-stick instead, using Windows 7 USB DVD Download Tool.
First of all, the tool reports an error and stops at 99% when copying the install files.
But I've read about other users still being able to install Windows fine from 99% progress. So I went ahead and rebooted.

Next step: Set USB-stick as primary boot device.
Windows installer starts up seemingly okay,
but as soon as I hit the first menu where you select language etc. all my USB devices stop working.


Now this is a HUGE problem for me as I have had to disable my touch pad and built in keyboard for various reasons.
(Please note that these USB devices work fine on my other Windows 7 install and also in BIOS.)


So I was thinking that the issue has something to do with Windows not recognizing USB 3.0 drivers during install and others on various forums have recommended bypassing this issue by either plugging the affected USB devices in non-USB 3.0 ports or disabling XHCI in BIOS...

Well, on my G75VW I don't have the option to turn off XHCI in BIOS (only Enabled and Smart Auto available here).
And as far as I know, the G75VW does not have USB 2.0 ports at all? All ports are blue.




Really frustrated and a bit worried at the moment guys. What was supposed to be a real quick and easy install has turned it to quite the nightmare.

I hope someone has experience with this!




Thanks in advance,
A :)

StereoROG
03-22-2014, 08:06 AM
All ports are blue = 3.0

i was using win 7 and i had an intel driver ( Win7_32_Win7_64_1.0.3.214 ).

I upgraded to win 8 and went to intel to download the latest ones, it was mentioned in the website that they will not release a win 8 version as it already has a driver built in ( a ****ty one ) but gets the job done i guess.

the only thing i think of is once you start the installation it copies the files on your hard drive and starts to load the win 7 drivers thats when ur problem starts as without the intel driver your USB-less.

Hope this helps a bit.

Good Luck

Clintlgm
03-22-2014, 02:28 PM
To start with all four of you ports are USB 3.0, 2.0 and 1.0 all versions USB are supported. You may want to check your BIOS and make sure that legacy USB is enabled
2nd if the creation of your USB Media did not complete, it is not going to install either.
Your system is UEFI unless you have converted to MBR?
Being UEFI GPT you must create your Install media for UEFI to boot and install. See this thread (http://rog.asus.com/forum/showthread.php?28758-GUIDE-G55-G75-Upgrade-Notes&country=&status=)
If that doesn't help you I suggest you check out the Severn forums (http://www.w7forums.com/threads/official-windows-7-sp1-iso-image-downloads.12325/)
What ever you do you must use a Win 7 SP 1 ISO to support UEFI, Download all the latest driver from Asus Support Download (http://support.asus.com/download/options.aspx?SLanguage=en&type=1)
Yes this UEFI stuff is new and we all had no idea at first, by now most of what you need to know is documented here and on the Window 7 and 8 forums.

alecinator
03-23-2014, 01:17 AM
Legacy was enabled the whole time.
I actually tried disabling it, which complicated things A LOT.
It completely disabled my USB devices.
Long story short: I managed to re-enable Legacy and was back to scratch.

Anyways, after a bit research I tried streamlining Windows installations (adding additional drivers not included in Win7 install).
I got the latest Intel USB 3.0 drivers and used WAIK (Windows Automated Installation Kit) to enclose the drivers.
I replaced the install.wim file on my USB drive with the newly created one and booted it up.

It worked!
Well... At least I had USB keyboard and mouse functions up until i got to the creating account part.
Which is where I lost all keyboard functions again.
I am guessing this was my fault because there was a minor issue with unmounting one of the driver images.

I completed the installation by (reluctantly) inserting the SSD into another computer and letting it finish there.
Don't know if this method is known to cause any errors, so procede with caution.


Btw, the USB boot device did the trick even at 99% completion :o





TLDR;
To anyone who ever might encounter this issue, i suggest you download WAIK (http://www.microsoft.com/en-us/download/details.aspx?id=5753) and do some reading on streamlining Windows installation.