View Full Version : Mad Catz R.A.T. 3 Mouse problems.

03-25-2014, 12:36 PM
Hello all, i was thinking about writing about this problem for some time, but never had the time or will to write it.
Now im just pissed of by my mouse and/or USB ports on the latop...

Couple of weeks ago i got myself an Mad Catz R.A.T. 3 mouse, mainly cause it looks nice and its made out of same material than my G750JX. The mouse is nice, goes into my hand perfectly, and 3200 DPI setting just feels good for me, overall im very happy with the mouse, probably the bets mous ei ever owned... The mouse is not wireless, so it has an cabel, i prefer mouse with cables. Cause im right handed i always plug my mouse on the left side so i dont have to deal with usb dongle on the right side.

Here is where first problem occurs. If i plug my mouse on the left side (by the cpu) my mouse stops tracking for 1 sec , then tracks for 10 sec and stops for 1 sec again. Its very anoying. it is impossible to play games or do any kind of work. Im a graphic designer.

If i plug the mouse on the right side it mainly works OK, it stops working for a second only cople of times per day. When this happens i normaly unplug the mouse and this fixes the problem. If i do not unplug it, the "not tracking for a secons" continues until i unplug it. I realy cant have my mouse pluged on the right side cause it simply bothers me, but ATM its the only solution.

- Mouse works fine on my old HP laptop (win 7)
- Tried reinstalling drivers/ R.A.T. 3 Software / Clean win 8.1 install
- Tried to clean gold plated usb connection on the mouse + on the laptop
- Tried to clean laser
- When using my old mouse everything seems ok (still testing)
- Tried to play with USB Selective suspend setting in power profile advanced settings ( no difference in any seting )

Im going to try to uninstall the software and use the mouse without the software ( but that just destroys the point of having a mouse with different DPI settings, cause it uses the default 350 DPI setting without the software) + try to older drivers.
Google search on this problem or older drivers wasnt sucsesfull...

Is anyone having the same problems? Any Ideas what to do and how to find what is causing this?
I think it could be the driver or the Software wich came along with the mouse. Maybe even USB ports on the laptop.

Could anyone with more knowledge help me out with this?

Thank you!

Mouse : http://ecx.images-amazon.com/images/I/61XH8S4nf2L._SL1001_.jpg

03-27-2014, 05:43 AM
Have you made sure your mouse isn't faulty in the cable from your certain mouse gestures?

Did you try turning down the mouse's polling rate?

Have you tried to disable Asus USB Charger Plus? (The voltage might be too much, not sure.)


I myself use a Razer Naga Epic, Wireless and Wired, and both are 100% functional. Never had a problem for the 3 months I've possessed my JX. Hopefully your USB's aren't faulty.

+ Holy Hellfire, that mouse really DOES go well with the G750 ;d My Naga still sexy though!

07-07-2014, 09:35 AM
There is a known issue with this mouse and USB3 ports which causes the issue you have mentioned. I have the same problem.

07-07-2014, 12:03 PM
There is a known issue with this mouse and USB3 ports which causes the issue you have mentioned. I have the same problem.

You might be 3 months late. ;d

10-03-2015, 09:18 PM
You might be 3 months late. ;d

Haha. I will be much more late. Got same problem. Mouse works fine only on ASUS USB Charger PLus

10-04-2015, 12:46 AM
ONLY? It cannot function without it? That's over 1A of current. ;U

10-04-2015, 07:54 AM
I chose the Genius Gila instead... looks better IMO

10-04-2015, 12:30 PM
I chose the Genius Gila instead... looks better IMO

What in the world?! ;U


10-04-2015, 11:40 PM
right?! (I know you'd like, Darnassuss) :)

10-06-2015, 07:42 AM
Thestroj? Any problems still? ;x

10-18-2015, 03:33 PM
ONLY? It cannot function without it? That's over 1A of current. ;U

No not only. It works in every port but only on this one without freezing.

10-19-2015, 10:59 AM
So I get it that there is no solving to this problem?
Wanna buy a Mad Catz r.a.t. TE and not sure if I should, as I want it to work properly.

10-19-2015, 04:33 PM
I had some issues getting a R.A.T. 7 to work with Win7 and Win8.1. Works fine, reboot, no work, reinstall driver, works fine, etc, all sorts of random USB weirdness (sometimes enumerates itself as a Mass Media Device, wtf). Sporadic failures which just won't go away. I've used plenty of other mice without issue (and still haven't found anything I like better than my Logitech G502), but I haven't found a machine or an OS which can keep the R.A.T. happy on a consistent basis.

The R.A.T. is a nifty product, I like the hardware side a lot, it's a solid chunk of tech, it's responsive and looks neat and feels great. Their software is crap. My unit uses a generic FTDI controller chip, there's really no reason they shouldn't be fully USB-compliant, but sloppy driver control will do that. Returned mine to the guy who lent it to me, happy I didn't actually buy one, I don't have time to waste on temperamental iffy junk.

10-20-2015, 07:31 PM
I just plugged my old one in (Looks a mess with carbon fibre wrapped all around it from about 3 years ago). All works fine when I plugged it into all ports. I haven't installed the drivers but shouldn't make any difference if yours doesn't work with out them either. Maybe its something to do with the touchpad drivers and the mouse disable feature or usb drivers?

Its a nice mouse, very light though after comparing it to my steel series rival, and I thought that was light.

10-20-2015, 07:43 PM
I prefer lightweight! I find that heavy feels reassuringly nice and solid, I want to pack in all the weights because it's just somehow more comforting to use. But the mouse then has some inertia and tends to slide around in a way which makes rapid stop-and-go precision more difficult. And mousepad "lift-offs" tend to have harder button-jarring crash landings. Well, I exaggerate a little, but it does make a noticeable difference.

The R.A.T. didn't have that hollow-sounding tinny internal echo most lightweight mice have when clicking away. A fantastic little mouse, too bad it just doesn't always work.

10-01-2016, 11:59 AM
Sorry for being late to the thread, but just bought the RAT 3 a few weeks ago. Definitely it's an issue with the mouse or mouse driver, since other Logitech mouses work for me.
If you just want to keep it working, put any USB Hub between the mouse and the USB port, it somehow eliminates the issue.
Check my very detailed thread here for further updates:

MAD CATZ R.A.T. 3 MOUSE LAGGY JERKY MOVEMENT ON USB 3.0 PORT ON ASUS G751JY (https://rog.asus.com/forum/showthread.php?87876-Mad-Catz-R-A-T-3-mouse-laggy-jerky-movement-on-USB-3-0-port-on-Asus-G751JY)

I would like to know how the O.P. did in the end?

10-07-2016, 08:40 PM
Mad Catz mouses are only supported on USB 2.0 ports. Check my recent thread here:

Mad Catz R.A.T. 3 mouse laggy jerky movement on USB 3.0 port on Asus G751JY (https://rog.asus.com/forum/showthread.php?87876-Mad-Catz-R-A-T-3-mouse-laggy-jerky-movement-on-USB-3-0-port-on-Asus-G751JY)

10-08-2016, 06:25 AM
Mad Catz mouses are only supported on USB 2.0 ports. Check my recent thread here:

Mad Catz R.A.T. 3 mouse laggy jerky movement on USB 3.0 port on Asus G751JY (https://rog.asus.com/forum/showthread.php?87876-Mad-Catz-R-A-T-3-mouse-laggy-jerky-movement-on-USB-3-0-port-on-Asus-G751JY)

I have a R.A.T.3 & R.A.T.7 mouse and have no problems at all using it on a USB 3.0 port_ quite a strange problem for some people to have this issues.