View Full Version : G74sx Not booting After Ram Upgrade

09-30-2011, 10:32 PM
I recently got 8 more gigs for my laptop , and after installing the new ram, my computer will not boot up. Power comes on but screen is black. Tried taking out new ram, same thing. Tried no ram. Same thing. Asus told me to send it in. Can't do it as I need it for work. Any idea's? New ram is exactly the same as the ram the computer came with.
I'm kinda screwed here. Would appreciate help. Thank you.

09-30-2011, 10:46 PM
Quick update: I got it to boot up with just one of the old (I think) RAM chips installed. Maybe its not reading the RAM? Am I not getting a solid connection or something? The plastic that holds the RAM in is really flimsy. Any ideas? Thanks again.

09-30-2011, 11:40 PM
i was going to suggest the possiblity that you may have shocked the board. if you're getting it to post, then it might be ok.

try this
1) insert 1 stick of the new ram you bought.
2) attempt to boot computer
a) if the computer boots, insert the next stick of the newer ram
b) if the computer fails to boot, try one stick of the original ram

if any of those succeed, then move on with the next stick, do this one at a time. this will test all of the ram.
check the slots, you should see a small number somewhere in the area indicating what slot it is (1,2,3,etc.) in order for DDR to work, two matching sticks need to be in alternating slots (like put the matching sticks in 1 and 3, do the same for 2 and 4).

try these things and get back to us with the results.