PDA

View Full Version : g750js low fps with Diablo 3



SlackerLogic
04-04-2014, 01:47 AM
Hello,

Long time lurker and fan of Asus laptops. I just replaced my g73jh for a g750js. Finished up cleaning up bloatware and installing a few games. Titanfall runs great, but I'm having serious issues with Diablo 3 at max settings: getting around 20 fps or lower. I made sure the 870m drivers are up to date, and based on what I know there shouldn't be a throttling issue... I searched around the forums but couldn't find a clear answer. Can anyone help?

Thanks in advance!

BIOHAZARD9519
04-04-2014, 03:51 AM
I find that quite surprising myself. My JS has run everything so far on max settings (with lowered or no aliasing) with frame rates of 50+.

Sorry I don't have Diablo 3 so I can't test this. Try checking anti-aliasing and turn it off to see if that helps. Also try turning off FSAA (another form of anti-aliasing). I have found anti-aliasing to be the "Achilles Heel" of all laptop GPUs in my past experience.

SlackerLogic
04-04-2014, 04:19 AM
I find that quite surprising myself. My JS has run everything so far on max settings (with lowered or no aliasing) with frame rates of 50+.

Sorry I don't have Diablo 3 so I can't test this. Try checking anti-aliasing and turn it off to see if that helps. Also try turning off FSAA (another form of anti-aliasing). I have found anti-aliasing to be the "Achilles Heel" of all laptop GPUs in my past experience.
Appreciate the response! I turned off AA and it only helped a little bit. I set everything to low and don't even exceed 30 fps. All of my other games are fine... I really think it has something to do with Diablo 3 :confused:

SlackerLogic
04-04-2014, 04:44 AM
Okay I think I have this sorted out. In NVIDIA Control Panel Diablo 3 wasn't set to the high performance NVIDIA processor. Diablo inherits from the global settings here so I set the NVIDIA processor to the preferred graphics processor. Seems to have solved it!

BIOHAZARD9519
04-04-2014, 05:05 AM
Okay I think I have this sorted out. In NVIDIA Control Panel Diablo 3 wasn't set to the high performance NVIDIA processor. Diablo inherits from the global settings here so I set the NVIDIA processor to the preferred graphics processor. Seems to have solved it!

Nice!

Surprised this was the case. I don't what told the control panel to not use the Nvidia GPU...

tilly
04-08-2014, 12:25 PM
Can you explain how you did this. I have looked in the control panel and cant seem to find this option. I have to run diablo 3 on low to medium with my g750js to have it run smoothly.

MrRuckus
04-09-2014, 09:50 PM
Can you explain how you did this. I have looked in the control panel and cant seem to find this option. I have to run diablo 3 on low to medium with my g750js to have it run smoothly.

I think he did what is referred to in this thread, there's a screenshot.

http://rog.asus.com/forum/showthread.php?46007-Slow-performance-by-G750JH&country=&status=

MrRuckus
04-09-2014, 09:51 PM
Right click on your desktop, choose "Nvidia Control Panel" and choose "manage 3d settings" on the left. This is where those settings are.

SofaKing
06-04-2014, 03:02 PM
Hi man ive tryed this, but my when i start the game my screen is black and all I can hear is in game sound! Ive been in cantact with ASUS support but did not lead to much, also Navida who was nice but no solution. I have tried so many things and nothing seems so work, all my other games runs on MAX GW2,Planetside2,LOL,Counterstrike. But not Diablo3 would be really nice with some more help!
Best regards SofaKing