PDA

View Full Version : Can I run The Elder Scrolls Online ?



Quasho
04-06-2014, 12:31 AM
Hey all,

I'm really sorry if I'm not on the right thread section! :(
Basically I just bought a new laptop (ROG G750JX) - I had the Asus N76VZ before, but since I like 'heavy' games I've bought the
G750JX.
The question is if my ROG can run The Elder Scrolls Online ? I don't see much difference between the N76VZ & the G750JX :( it seems that the game is always lagging or really slow :( on High or Medium sets. Do I have to tweak my graphic card preferences ? I don't understand much of it :/

Thanks a lot guys /O/

Darnassus
04-06-2014, 02:23 AM
Hehehe. :3

Just to confirm, this is the laptop you previously owned? http://www.asus.com/Notebooks_Ultrabooks/N76VZ/

If so, the G750JX blows that compy out of the water. You've upgraded from a 650m to a 770m. That is a BIG jump. http://gpuboss.com/gpus/GeForce-GTX-770M-vs-GeForce-GT-650M


Here's your info for how Elder Scrolls will run on a JX, given it's components.

http://www.game-debate.com/games/index.php?g_id=3734&game=The+Elder+Scrolls+Online&p_make=Intel&p_deriv=Core+i7-4700HQ+4-Core+2.4GHz&gc_make=Nvidia&gc_deriv=GeForce+GTX+770M&ram=16&checkSubmit=#systemRequirements



You should be able to run the game fine on Maximum.

Quasho
04-06-2014, 02:35 AM
Damn :O
Well true, now I've a GTX 770M but I get 20fps with High specs & on the N76VZ I had between 15-25fps on High setting as well.
I don't understand. I hope I didn't do anything wrong when I was trying to change the options over the Nvidia Control Center.
Thank you for your reply ^^

hahah 'dat' picture !!

Crmn1625
04-06-2014, 02:42 AM
Is your laptop plugged in - many forum posts (and personal experience) that the ROG's need to be plugged in for full GPU performance. Battery can't handle the GPU's, drain to quickly supposedly.

Quasho
04-06-2014, 04:26 AM
Yes, it's plugged in. Everything it's update as well. I just don't get it why I get so low FPS :/

Darnassus
04-06-2014, 05:08 AM
Ah so you have been playing Elder Scrolls: Online with the JX already? Sorry I didn't properly understand your post.

The game is new, I wouldn't be surprised if things aren't going as planned, it's not optimised yet as far as I'm aware. It's still in Beta, right?

arkejn
04-06-2014, 07:02 AM
I played ESO on my old PC and had no problems at all :x
specs:
phenom II x6 1100T
GTX460 1GB DCU
2x4GB Kingston T1

Crmn1625
04-06-2014, 07:26 AM
How about other games? Any issues there? Could there be something in the power plan setting that is not allowing you to use everything even while plugged in? I uninstalled Power4Gear and Splendid to keep those from interfering and changing settings. I do not play ESO so have no direct experience there but it does not make sense that you have such low fps.

Quasho
04-06-2014, 02:49 PM
Hey, sorry for the late reply. I was sleeping.
I've installed TESO on the SSD driver. I'm installing other games at the moment and I've been playing DayZ and everything is smooth.
I will keep you guys updated. The only game I've tried it was
World of Warcraft (Trial) just to see if everything was smooth, I played in Ultra but was a bit 'laggy', but I'm assuming it was because it was installing at the same time . I've try to play WoW Trial (Ultra specs) on my ASUS N76VZ with no problems at all. But then again, is World of Warcraft a demanding graphic game ? I don't know :(. I'm installing Crysis 3 - Anno 2070 - Assassin's Creed IV (Black Flag) & Dead Island and I will run
some tests :) - thank you guys for your patience and helpful comments!! :)

villiansv
04-06-2014, 03:16 PM
I'm playing TESO on my JX with no issues whatsoever (max settings). Including mass AvA battles.

Crmn1625
04-06-2014, 04:17 PM
I know this will not help with your issue but just to give an example. WOW is my main game of choice and it is not too graphically demanding unless playing on ultra settings. In ultra I usually am over 60 fps all the time on the JH but when only using battery, I have seen settings as low as 6 fps and just about always under 20, averaging around 10 -15, which sounds like what you are experiencing EOS. I have not seen this happen on my laptop in a while but very rarely in my first month, my laptop did not seem to detect the fact that I was plugged in even though I was. Don't remember if I had to do anything to change that or if it was resolved by removing Power4Gear. Sorry you are having these issues and good luck.

Quasho
04-06-2014, 06:59 PM
I'm back! :)

My battery is plugged and it seems its charging as well. So I don't think it's battery related. The thing is this laptop as 2 days old. I've updated everything & I downloaded and installed Windows 8.1 and then I run windows
update and everything is 'perfect'.

I've Norton 360 antivirus & Malwarebytes installed ( I don't know if this programs cause game issues ).

It's seems when I'm playing TESO the world seems really slow and my character seems quite laggy as well even
on medium or Low. If I choose minimum - the game runs fine. It happens the same thing with Dead Island, my character seems it's kind break dancing all the time :/

theblackangelic
07-03-2015, 01:15 AM
I have seen a lot of forum posts with issues having to do with the ROG Gamefirst software. Check to see if that is installed. If it is, uninstall.

Darnassus
07-03-2015, 03:25 AM
I have seen a lot of forum posts with issues having to do with the ROG Gamefirst software. Check to see if that is installed. If it is, uninstall.

Did.. you just dig up an old thread from over a year ago?

.... as your first post?! x'{