PDA

View Full Version : Black screen after rog screen on startup



5thMagic
04-06-2014, 04:07 AM
I have a g750jx and I have done little to it except update to windows 8.1 from 8. However now when I start it windows doesn't seem to be loading, all I get is a black screen. I have tried using the f2 and f9 keys at start up but the result is the same. Any advice on steps I should take?

zetdotcom
04-06-2014, 09:02 AM
Maybe is a screen problem. Try to collegate to an external monitor via hdmi or vga.

5thMagic
04-06-2014, 01:14 PM
Maybe is a screen problem. Try to collegate to an external monitor via hdmi or vga.
Thanks for the thought, I tried it just in case but it didn't work. Also the screen works enough to show me the rog logo while loading.

amitabhbansal
04-06-2014, 07:19 PM
I have a g750jx and I have done little to it except update to windows 8.1 from 8. However now when I start it windows doesn't seem to be loading, all I get is a black screen. I have tried using the f2 and f9 keys at start up but the result is the same. Any advice on steps I should take?

I faced the same issue when i bought it, power on the laptop if it start the windows then open the nvidia experience and update the driver, remember while updating check on fresh installation, and ur problem will be solved, if the win doesnt start keep pressing the power button until it shut off and then again power on, and update the driver

Kolya
04-06-2014, 10:54 PM
I have a very similar problem with my ASUS ROG G750J. It has happened to me at least 5 times so far. If I turn the computer completely off and try to restart later on (with Power button), the button lits up but the screen does not start. Stays black. SiImilar problem occurs if i try to wake up the computer from a deep sleep.

I have to press the Power button again - on and off. After a few attempts - luckily - it restarts, but it is VERY worrisome. My Nvidia GE Force is always kept up to date.

Is it a Power button issue?
Is it a conflict with Energy savings parameters or what not?
A driver issue?

I have Windows 8.1. ASUS - any help appreciated.

amitabhbansal
04-07-2014, 02:37 AM
I have a very similar problem with my ASUS ROG G750J. It has happened to me at least 5 times so far. If I turn the computer completely off and try to restart later on (with Power button), the button lits up but the screen does not start. Stays black. SiImilar problem occurs if i try to wake up the computer from a deep sleep.

I have to press the Power button again - on and off. After a few attempts - luckily - it restarts, but it is VERY worrisome. My Nvidia GE Force is always kept up to date.

Is it a Power button issue?
Is it a conflict with Energy savings parameters or what not?
A driver issue?

I have Windows 8.1. ASUS - any help appreciated.
Its not power button or screen issue, its only a driver issue, in windows 8.1 u have to update few drivers, on my side only nvidia driVer update solved the issue, when i bought the laptop it came with windows 8 and after upgrading to windows 8.1 black screen occurs, then i updated nvidia driver and it solved it, update one by one driver with fresh update and then restart it until ur problem is solved, it can be wan or bluetooth driver also. U have to check the laptop after every update because u should know which driver is not compatible, remember one thing, after any update just restart the laptop and work on it for at least 2 minute then shut windows down, and power it on after 5-10 minutes and see if that update sorted the issue or not, if not then go ahead with any other update.
I have G750JX-cv069p and found only nvidia driver problem.
Thanks

RogBo
04-07-2014, 11:14 PM
Go with 335.23 (I got mine from the Nvidia page, not ASUS support), this was the first one to work again for me. Haven't tested the latest one yet.

EDIT: My current driver version is 332.50, not 335.23.

Ryuuken
04-18-2014, 09:21 AM
I Just bough my ASUS G55 and I have the same problem after updating to windows 8.1.
when I start up the computer I can see the ROG logo loading but as soon as windows starts there is a black screen. I suspect it is in fact a driver problem, but I have already updated to 335.23 and it is still not fixed.
I found a temporary fix when this happens though. you just need to close the lid (this will put the computer in sleep mode) and power it up again. I am not sure why but this fixes the problem completely. also if you close it after turning it on it boots up normally, so this problem only arises (in my case anyway) when you either restart the computer or when you shut it down but you leave the lid open until the next use.

I would appreciate some help with this if anyone has been able to fix this successfully, or maybe some insight from the ROG people.

hmscott
04-18-2014, 09:49 AM
I Just bough my ASUS G55 and I have the same problem after updating to windows 8.1.
when I start up the computer I can see the ROG logo loading but as soon as windows starts there is a black screen. I suspect it is in fact a driver problem, but I have already updated to 335.23 and it is still not fixed.
I found a temporary fix when this happens though. you just need to close the lid (this will put the computer in sleep mode) and power it up again. I am not sure why but this fixes the problem completely. also if you close it after turning it on it boots up normally, so this problem only arises (in my case anyway) when you either restart the computer or when you shut it down but you leave the lid open until the next use.

I would appreciate some help with this if anyone has been able to fix this successfully, or maybe some insight from the ROG people.

It is the Bluetooth package/driver, the Windows 8.0 release version(s) cause this on Windows 8.1. Uninstalling the ROG Mouse driver is a good idea as well, it can cause crashes - and an updated version hasn't been found (anyone find it yet?)

For those that haven't updated to Windows 8.1 yet, it is recommended you update all your drivers to Windows 8.1 latest drivers before upgrading from Windows 8 to 8.1.

The new G750's, the JM, JS, JZ driver download areas have the latest Windows 8.1 drivers for our JW, JX, JH laptops. The new laptops come with Windows 8.1 and have the latest Windows 8.1 drivers. Our JW, JX, JH share most of the hardware, except for the new GTX8xx cards, so we can use the same drivers.

Here is a link that has all of the G750's support areas, and download area links:
http://support.asus.com/Search.aspx?SLanguage=en&keyword=g750&ps=10&pn=1

If you already upgraded to Windows 8.1, try turning off the BT/Wireless to boot, or boot into safe mode and uninstall the BT driver, then when you can boot upgrade all of the drivers for the hardware in your model.

Ryuuken
04-20-2014, 12:02 PM
Thanks, you suggest updating my bluetooth driver, but in the page under the g55 model for bluetooth drivers there are 3 available and I cant find which one is the one I have, there is qualcomm atheros, intel and broadcom. I also checked throught windows update and ausus update to see if my drivers where upt to date and nothing seems to be outdated. the model of my asus is g55vw s1024h. Also any news on whether ASUS or windows are working on any update to eliminate this isue anytime soon?

hmscott
04-20-2014, 09:10 PM
Thanks, you suggest updating my bluetooth driver, but in the page under the g55 model for bluetooth drivers there are 3 available and I cant find which one is the one I have, there is qualcomm atheros, intel and broadcom. I also checked throught windows update and ausus update to see if my drivers where upt to date and nothing seems to be outdated. the model of my asus is g55vw s1024h. Also any news on whether ASUS or windows are working on any update to eliminate this isue anytime soon?

Ryuuken, you are in the wrong forum :)

The response I gave was for the G750, I didn't notice it was a problem on a different model.

Head over here and the people familiar with the G55 can help get it fixed for you.

http://rog.asus.com/forum/forumdisplay.php?146-G75-G55-amp-G46-Gaming-Notebooks

The bluetooth driver problem on the G750 when upgrading from Windows 8.0 to 8.1 may not translate to the G55.

Crazy Killer
12-06-2015, 01:08 PM
I have a g750jx and I have done little to it except update to windows 8.1 from 8. However now when I start it windows doesn't seem to be loading, all I get is a black screen. I have tried using the f2 and f9 keys at start up but the result is the same. Any advice on steps I should take?


i bought rog 1 month back but after a week or so whenever i open my rog lappy it hangs and black screen comes on or repair option comes every time i have to repair it. worst experience i have till now. windows 10 comes preinstalled . and its wont log on many times. help needed

Crazy Killer
12-06-2015, 01:21 PM
I Just bough my ASUS G55 and I have the same problem after updating to windows 8.1.
when I start up the computer I can see the ROG logo loading but as soon as windows starts there is a black screen. I suspect it is in fact a driver problem, but I have already updated to 335.23 and it is still not fixed.
I found a temporary fix when this happens though. you just need to close the lid (this will put the computer in sleep mode) and power it up again. I am not sure why but this fixes the problem completely. also if you close it after turning it on it boots up normally, so this problem only arises (in my case anyway) when you either restart the computer or when you shut it down but you leave the lid open until the next use.

I would appreciate some help with this if anyone has been able to fix this successfully, or maybe some insight from the ROG people.

i am having the same problem with ASUS g55 win 10 version. everytime i restart the asus logo comes up and then it hangs up with black screen. everytime i have to repair it to work. only one month old laptop. if u get solution help me also

redduc900
12-06-2015, 05:49 PM
Will it boot into safe mode?

How to Start Windows 10 in Safe Mode
http://www.tenforums.com/tutorials/2304-safe-mode-start-windows-10-a.html

rohan2812
12-07-2015, 03:14 AM
Have you all updated nVidia drivers to latest version. G750JX laptops with 3D screens need to run only specific version of nVidia driver because generic drivers don't support 3D screens. Try downloading the nVidia driver from Asus Support page for your model, no matter how old the version is. Stick to it and also disable automatically download new drivers in GeForce Experience also
If you all are on Windows 10 you might need to tweak few more settings as MS will re-download the new driver for nVidia and you will have the same issue again. I faced the same problem when I bought my laptop and upgraded the nVidia drivers from nVidia website.

rohan2812
12-07-2015, 03:15 AM
i bought rog 1 month back but after a week or so whenever i open my rog lappy it hangs and black screen comes on or repair option comes every time i have to repair it. worst experience i have till now. windows 10 comes preinstalled . and its wont log on many times. help needed

Have you all updated nVidia drivers to latest version. G750JX laptops with 3D screens need to run only specific version of nVidia driver because generic drivers don't support 3D screens. Try downloading the nVidia driver from Asus Support page for your model, no matter how old the version is. Stick to it and also disable automatically download new drivers in GeForce Experience also
If you all are on Windows 10 you might need to tweak few more settings as MS will re-download the new driver for nVidia and you will have the same issue again. I faced the same problem when I bought my laptop and upgraded the nVidia drivers from nVidia website.

rohan2812
12-07-2015, 03:17 AM
I have a very similar problem with my ASUS ROG G750J. It has happened to me at least 5 times so far. If I turn the computer completely off and try to restart later on (with Power button), the button lits up but the screen does not start. Stays black. SiImilar problem occurs if i try to wake up the computer from a deep sleep.

I have to press the Power button again - on and off. After a few attempts - luckily - it restarts, but it is VERY worrisome. My Nvidia GE Force is always kept up to date.

Is it a Power button issue?
Is it a conflict with Energy savings parameters or what not?
A driver issue?

I have Windows 8.1. ASUS - any help appreciated.

Have you all updated nVidia drivers to latest version. G750JX laptops with 3D screens need to run only specific version of nVidia driver because generic drivers don't support 3D screens. Try downloading the nVidia driver from Asus Support page for your model, no matter how old the version is. Stick to it and also disable automatically download new drivers in GeForce Experience also
If you all are on Windows 10 you might need to tweak few more settings as MS will re-download the new driver for nVidia and you will have the same issue again. I faced the same problem when I bought my laptop and upgraded the nVidia drivers from nVidia website.

rohan2812
12-07-2015, 03:21 AM
Thanks, you suggest updating my bluetooth driver, but in the page under the g55 model for bluetooth drivers there are 3 available and I cant find which one is the one I have, there is qualcomm atheros, intel and broadcom. I also checked throught windows update and ausus update to see if my drivers where upt to date and nothing seems to be outdated. the model of my asus is g55vw s1024h. Also any news on whether ASUS or windows are working on any update to eliminate this isue anytime soon?

Goto device manager and under Bluetooth settings right click on Bluetooth Module and select Properties. The name of the manufacturer would be written there. You can then download the drivers that best suit you. Depending on configuration you can have multiple Bluetooth devices listed. In that case check the Properties for each of them and select the best driver.