PDA

View Full Version : Slow performance by G750JH



Phantom_120
04-08-2014, 06:51 AM
Hi guys
I would appreciate if you can lend a hand here with my new g750 laptop I bought.
First, this is the model I bought from Amazon (G750JH-DB71 (http://www.amazon.com/gp/product/B00EZ8BJNK/ref=oh_details_o01_s00_i00?ie=UTF8&psc=1)).

I bought it about 3 weeks ago, and immediately upgraded to windows 8.1
I am having a very strange performance by such a monster machine, checked the "recommended" and "auto detection" settings by multiple games, and all of them recommend setting the graphics on low, now just like any of you, I did not buy this laptop to play games on low settings!
I manually set the graphics settings to High, but the performance was far from convincing, while the game wasn't crashing or lagging, but it was not that smooth, running between 20-40fps and jumping temporarily to 60 for a couple of seconds, then back down.

I checked the drivers, and everything seems to be up to date.
I did the windows experience index (which is lousy in windows 8.1)
the results were rather surprised, pretty much everything was above 8! (the top score in win7 was 7.9, I did not know it was changed in windows8)
Anyway, it showed the dx10 result was 0, so i chacked and I already had dx 11.2, which is the latest version for win8.1.

I tried the dxdiag, but I must say I dont understand much about that.

I would really appreciate it if you guys could help me with performance.

Thank you

XellosUAE
04-09-2014, 04:03 AM
running between 20-40fps and jumping temporarily to 60 for a couple of seconds, then back down.

It does seem to me that your issue is with your GeForce trying to save power by sacrificing performance. I had this issue before. try going to your Nvidia setting and change Power Management Mode to Prefer Maximum Performance" as shown in the image below.

35606

Hope this helps.

Phantom_120
04-09-2014, 05:12 AM
Lovely. I will try this when I get home and get back with results.
Thanks.

Protervis
10-17-2014, 08:16 PM
It does seem to me that your issue is with your GeForce trying to save power by sacrificing performance. I had this issue before. try going to your Nvidia setting and change Power Management Mode to Prefer Maximum Performance" as shown in the image below.

35606

Hope this helps.

Hello everyone,

I just bought a g750js and have some troubles with the frame rate. Is it supposed to be maximum 60? Regarding the screen shot why when i go on nvidia control panel the only option i got is 3d settings category? I Do not see Display or Video categories i mean.

Cheers