PDA

View Full Version : G74 Screen Brightness issue - too dark in some games



Jay Behr
10-04-2011, 01:25 PM
Hi there. I bought my G74 last week and I must say I adore it :)

However, I'm having an odd issue which appears (ie I hadn't noticed it previously) to have popped up in the last couple of days.

I have a copy of Bioshock 2, via Steam. When I go into the game it's too dark, so I go to Options/Adjust Brightness and "up" the brightness. This seems to "take" for a couple of seconds, then something appears to say "no you don't", and puts the brightness back where it was (!).

I've gone into the nVidia control panel and tried "nVidia controls settings" and "system/player controls settings" as well as other options, and nothing seems to work.

The brightness is fine in Windows 7.

Something's clearly "overriding" my choice, hence the couple of seconds where something happens, then it doesn't, but what? The weird thing is, I can't recall this happening when I first got the machine (last week), so maybe something I've loaded since, or adjusted myself, has fouled things up, but what? Given the terribly slow net connection I have I don't really want to do a full wipe & re-install, as that would take forever (took 4 days just to get all my Steam games on!), so any suggestions?

Oh and I've checked the Asus site, nVidai's site, and used Asus live update, and I seem to be running the current versions of nVidia's drivers (although nVidia point me to Asus site for new drivers, but the 2 version numbers are the same).

Yours, shortly to be hairless due to tearing it out by the roots ... :)

xeromist
10-04-2011, 04:28 PM
Does this happen in other games? If it seems to be isolated to this game I would look to see if people have had any brightness issues and what they may have found to fix it.

Jay Behr
10-04-2011, 05:16 PM
Does this happen in other games? If it seems to be isolated to this game I would look to see if people have had any brightness issues and what they may have found to fix it.

It's most noticeable in BS2, but not only that game. And it's not the game ... I've now noticed the same "overriding" taking place when adjusting the nVidia GPU's settings - screen goes brighter, something kicks in, screen darkens. It's less noticeable in Win7 because the screen is SO flipping bright (a good thing, IMHO), but it's still there.

Still puzzled. I don't think it's a faulty screen, because it doesn't happen on all games.

xeromist
10-04-2011, 05:27 PM
EDIT: See Grungeboy's suggestion below first. Do this if that fails.

So you do see it on the Windows desktop as well then? If you're having brightness issues periodically and across the board that sounds like a bad ATK install to me. I'd try completely removing it and reinstalling to see if that makes a difference.

grungeboy2
10-04-2011, 05:31 PM
sounds like the nvidia control panel is overriding your brightness settings in 3d mode.

1) right click on desktop, select nvidia control panel
2) on the left hand side of the window that opens, under display, select adjust desktop color setting

under number 2, what is the setting? is it other applications control, or nvidia controls?

Jay Behr
10-04-2011, 06:18 PM
sounds like the nvidia control panel is overriding your brightness settings in 3d mode.

1) right click on desktop, select nvidia control panel
2) on the left hand side of the window that opens, under display, select adjust desktop color setting

under number 2, what is the setting? is it other applications control, or nvidia controls?

I've tried both, nvidia and "other apps", and neither makes any difference.

I'll try resetting it and trying again though, hang on.

<does stuff>

Sorry, still doing it :(

Jay Behr
10-04-2011, 06:25 PM
I've tried both, nvidia and "other apps", and neither makes any difference.

I'll try resetting it and trying again though, hang on.

<does stuff>

Sorry, still doing it :(

Ah-HA!

You set me thinking ... what else do I run that affects gamma correction? Answer: f.lux - I find the G74's display very "blue shift", so use f.lux to dynamically adjust the colour temperature.

Disabled f.flux. Works fine.

Many thanks to you both, I think we can label this one "sorted" :)

grungeboy2
10-04-2011, 08:49 PM
sweet. glad you got it figured out man.

Jay Behr
10-04-2011, 09:49 PM
sweet. glad you got it figured out man.


Wouldn't have twigged without your input though*, so thanks! :)

*weird how that's so often the way when problem solving eh?